Bug 55053 - FORMATTING: Outline Formatting Spacing Issues
Summary: FORMATTING: Outline Formatting Spacing Issues
Status: RESOLVED DUPLICATE of bug 56258
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: All All
: low normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Blocks: Bullet-Number-Outline-Lists
  Show dependency treegraph
Reported: 2012-09-18 14:43 UTC by Grayson Prettyman
Modified: 2023-01-05 19:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:

JPG of problem (50.72 KB, image/jpeg)
2015-01-10 05:53 UTC, Dane Mutters
problematic .odt (15.37 KB, application/vnd.oasis.opendocument.text)
2015-01-10 05:54 UTC, Dane Mutters
problematic .odt (17.95 KB, application/vnd.oasis.opendocument.text)
2015-01-10 06:08 UTC, Dane Mutters
JPG of problem (66.85 KB, image/jpeg)
2015-01-10 06:08 UTC, Dane Mutters
Outline type (28.86 KB, image/png)
2016-02-21 09:13 UTC, Dane Mutters
LibreOffice version info (41.32 KB, image/png)
2016-02-21 09:14 UTC, Dane Mutters
Outline showing problems (154.90 KB, image/png)
2016-02-21 09:14 UTC, Dane Mutters
Screenshot: problem persists in latest version (123.79 KB, image/png)
2018-06-13 15:26 UTC, Dane Mutters
Libreoffice 3 Screenshot (94.03 KB, image/png)
2018-06-13 16:49 UTC, Dane Mutters
Video showing the behavior on Ubuntu Linux in v (1.46 MB, video/x-flv)
2019-03-24 01:17 UTC, Dylan Taylor

Note You need to log in before you can comment on or make changes to this bug.
Description Grayson Prettyman 2012-09-18 14:43:03 UTC
Problem description: 

Steps to reproduce:
1. Click Format, then Bullets and Numbering
2. Choose the bottom left option (Roman numeral, Capital Letter, lowercase Roman numeral, lowercase letter, bullets)
3. Make atleast 3 Big Points (Capital Roman Numerals)

Current behavior: My third biggest point (III) is indented past where is should be. Like this

I. Blah
II. Blah
III.         Blah
IV. Blah

Expected behavior: Shouldn't be indented.

Platform (if different from the browser): 
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0.1
Comment 1 keith 2012-12-12 19:36:37 UTC
I also have this problem in on the Mac.

This problem makes Outline mode unusable as the formatting is all over the place.
Comment 2 QA Administrators 2015-01-05 17:51:33 UTC Comment hidden (obsolete)
Comment 3 Dane Mutters 2015-01-10 05:53:30 UTC
Created attachment 112043 [details]
JPG of problem
Comment 4 Dane Mutters 2015-01-10 05:54:14 UTC
Created attachment 112044 [details]
problematic .odt
Comment 5 Dane Mutters 2015-01-10 05:56:21 UTC
I've attached an .odt wherein this problem is evident, as well as an exported .jpg of that file, just in case.

I've been experiencing this problem since about the time that LibreOffice split from OpenOffice.  (Not sure if it was there before.)  I used to be able to manually correct the indentation by moving sliders around, near the top of the screen, but lately, for some reason, this has proven much more difficult than before.

In this example, I'm using the "I, A, i, a), -" outline format (currently the bottom left outline option).

Thanks, developers, for all your hard work.
Comment 6 Dane Mutters 2015-01-10 06:07:52 UTC
Ack...didn't see the above instructions.  The above was created using version  (Sorry.)

I'm uploading a new .odt made with version (freshly downloaded from libreoffice.org), as well as a .jpg image of it.  As you can see, the problem persists.
Comment 7 Dane Mutters 2015-01-10 06:08:17 UTC
Created attachment 112045 [details]
problematic .odt
Comment 8 Dane Mutters 2015-01-10 06:08:49 UTC
Created attachment 112046 [details]
JPG of problem
Comment 9 Jim Shipman 2015-01-29 21:57:23 UTC
I have the same problem on the latest Fedora FC21 version (build  Exactly as described below.  It seems that the bug repeats itself on the third top level entry and then it either continues below that or will reset and repeat again on each third entry after.
This is a really bad bug!
Tried to delete the libreoffice config file and restart with the same result.  No improvement.
Jim Shipman
Comment 10 QA Administrators 2016-02-21 08:35:40 UTC Comment hidden (obsolete)
Comment 11 Dane Mutters 2016-02-21 09:13:59 UTC
Created attachment 122839 [details]
Outline type
Comment 12 Dane Mutters 2016-02-21 09:14:25 UTC
Created attachment 122840 [details]
LibreOffice version info
Comment 13 Dane Mutters 2016-02-21 09:14:53 UTC
Created attachment 122841 [details]
Outline showing problems
Comment 14 Dane Mutters 2016-02-21 09:16:13 UTC
Thanks for your work, QA Administrators!

The problem still exists for me in version 5.0.3.  I've attached some new screenshots.
Comment 15 Xisco Faulí 2017-06-12 10:59:41 UTC
Changing version back to the earliest version affected.
Comment 16 QA Administrators 2018-06-13 02:36:45 UTC Comment hidden (obsolete)
Comment 17 Dane Mutters 2018-06-13 15:26:10 UTC
Created attachment 142707 [details]
Screenshot: problem persists in latest version

Help > About information is included in screenshot.
Comment 18 Dane Mutters 2018-06-13 16:49:18 UTC
Created attachment 142711 [details]
Libreoffice 3 Screenshot

This does not appear to be a regression.
Comment 19 Dylan Taylor 2019-03-24 01:17:06 UTC
This still seems to be a bug in
Comment 20 Dylan Taylor 2019-03-24 01:17:36 UTC
Created attachment 150244 [details]
Video showing the behavior on Ubuntu Linux in v
Comment 21 Mike Kaganski 2019-03-24 05:38:30 UTC
*** Bug 124301 has been marked as a duplicate of this bug. ***
Comment 22 Mike Kaganski 2019-03-24 05:48:32 UTC
So the problem here is too small tab stop for a default numbering style (taking into account that the number itself starts from non-0 position)? So that numbers taking more than that space force the tab stop to jump to the next (default) tab position. E.g., for "I.A.i.a)" outline style, the 1st level number is aligned at 0.64 cm, and tab stop is at 1.27 cm, leaving only 0.63 cm space for the roman number with following dot.

A manual fix is trivial - changing tab position (and indent?) to a reasonable value (like 2 cm).

Adjusting importance, since trivial workaround is available.
Comment 23 Mike Kaganski 2019-03-24 05:58:23 UTC
Already reproducible with OOo 3.3.1 OOO310m19 (build:9420). In previous versions, spacing from numbers to text seems to not depend on tab positions.
Comment 24 Mike Kaganski 2019-03-24 08:28:20 UTC
The outline numbering data is locale-specific, and is defined in i18npool/source/localedata/data/*.xml (see LC_OutLineNumberingLevel element). There, OutLineNumberingLevel elements have LeftMargin, SymbolTextDistance, and FirstLineOffset attributes (likely in 100th of inch); but apparently, those values are ignored (changing them and rebuilding does not change things; also lcl_CreateNumSettingsPtr does not take those into account).

The actual default offsets are global, and are created in SwNumRule::SwNumRule. So making a change there would change all pre-defined numbering styles.

Eike: is there some preferred way to change this, so that some list styles have different offsets?
Comment 25 Justin L 2023-01-05 19:08:07 UTC

*** This bug has been marked as a duplicate of bug 56258 ***