Download it now!
Bug 55266 - FORMATTING: Some cell borders (double line) don't work
Summary: FORMATTING: Some cell borders (double line) don't work
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.1 rc
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 58093 62392 (view as bug list)
Depends on:
Blocks: Cell-Border
  Show dependency treegraph
 
Reported: 2012-09-24 02:12 UTC by art guerra
Modified: 2019-08-20 11:27 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
CellBordersTest (16.77 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-21 00:26 UTC, m.a.riosv
Details
Edited copy of original submission with recreated borders (23.83 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-02-22 10:04 UTC, Bryan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description art guerra 2012-09-24 02:12:54 UTC
I am currently using version 3.6.2.1rc windows version.  To replicate this error go to any cell in calc, right click, select format cells, then select borders. The error occurs when you select border styles:

1st- several of the borders look alike there are three or four styles that look like double underline. Theya are all identical

2nd - if you select one of the double underline styles,the border will show up as a single bold line.

This error also occurs on writer cells.
Comment 1 m.a.riosv 2012-10-20 21:07:56 UTC
I can confirm this issue,

Only the first five border styles a saved with the style, the borders from 6th to 9th are replaced with the first border style.
Comment 2 m.a.riosv 2012-10-21 00:26:18 UTC
Created attachment 68857 [details]
CellBordersTest

Win7x64Ult LibreOffice Version 3.6.3.1 (Build ID: f8fce0b)

Added a file to test cell border lines:

For the first eight border line, five different sizes, using STYLE() function to apply.

To me many borders do not look as it can be expected, also exporting to pdf.

And other issue, style 84-Line is linked to 81-Line, clicking standard in border tab (modifying 84-Line style), the border style change to same than 81-Line, but if the border is set in 1 or more then change the border style to one not equal than the linked styled.
Comment 3 Michael Stahl (CIB) 2012-10-31 22:20:14 UTC
hmm... the problem is that the UI allows setting the style independent from the width, and the double borders are really indistinguishable at small widths.

the UI in Word offers fixed sizes for each style, and for many
of those double line style the effective minimum total width is 2.5pt or 3pt,
which makes this much less of a problem.
Comment 4 Jorendc 2012-12-14 19:04:26 UTC
*** Bug 58093 has been marked as a duplicate of this bug. ***
Comment 5 jkonecny 2012-12-20 04:02:11 UTC
Confirmed with LODev 4.00b1.
Comment 6 Jorendc 2013-03-17 20:57:19 UTC
*** Bug 62392 has been marked as a duplicate of this bug. ***
Comment 7 Carsten Hütter 2013-07-12 19:53:24 UTC
Bug is still present in LO 4.0.4. In fact, only the first three border styles are usable (simple line, dotted line, dashed line). 4th style looks like a copy of Nr. 1, but produces no border. No. 5 looks like another simple line. The options window's prewiew shows a simple line, much broader than expected; print shows something you would expect when choosing No. 8 (double line, narrow at the top and left side; broad at the bottom and right side). No. 6 produces another empty border. No. 7 looks like a double line, but produces a broad simple line. No. 8 produces a border similar to No. 5, but the wite space is much too narrow to be seen with a usual border width and print size.

It gets even more irritating with a larger width. All of a sudden, you get 6 more border styles, each of the previews barely seems to correspond to the print result.

In short: It's all screwed up.

I don't need no fancy new features. I just want the simple things work. Like cell borders, for example. Please,  please, please, debug the cell's borders source code. Please...

Tanks for all your efforts!
Comment 8 Carsten Hütter 2013-07-29 19:39:27 UTC
And it's still the same in LO 4.1.0.4.
Comment 9 m.a.riosv 2013-07-29 21:10:25 UTC
Hi Carsten, thanks for review.
Comment 10 public 2013-07-29 21:21:32 UTC Comment hidden (no-value)
Comment 11 m.a.riosv 2013-07-29 21:28:42 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2016-02-21 08:35:12 UTC Comment hidden (obsolete)
Comment 13 Bryan 2016-02-22 10:04:35 UTC
Created attachment 122863 [details]
Edited copy of original submission with recreated borders

Retest of border formatting in LO 5.1.0.3.  The bug is still present as detailed in the comments in the submitted file.
Comment 14 Friedmann Bruno 2017-03-14 15:54:05 UTC Comment hidden (me-too)
Comment 15 Friedmann Bruno 2017-03-14 16:16:05 UTC Comment hidden (obsolete)
Comment 16 QA Administrators 2018-03-15 03:38:11 UTC Comment hidden (obsolete)
Comment 17 oksthegreat 2019-08-20 11:27:08 UTC Comment hidden (spam)