Bug 55290 - LOdev 3.7 won't install. Error 1935
Summary: LOdev 3.7 won't install. Error 1935
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: All Windows (All)
: medium blocker
Assignee: David Tardon
QA Contact:
URL:
Whiteboard: target:3.7.0
Keywords:
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-09-24 19:48 UTC by tommy27
Modified: 2013-11-16 15:45 UTC (History)
8 users (show)

See Also:


Attachments
LOdev install errir dialog (137.96 KB, image/jpeg)
2012-09-24 19:48 UTC, tommy27
Details
Install log (572.65 KB, application/zip)
2012-09-27 10:19 UTC, Andras Timar
Details
grasping for a straw... (1.70 KB, patch)
2012-10-15 13:09 UTC, David Tardon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2012-09-24 19:48:12 UTC
Created attachment 67647 [details]
LOdev install errir dialog

today's Windows build master~2012-09-24_10.33.18_LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US.msi will not install on Vista 64bit and XP 32bit.

installation aborts at the same point in 2 different PCs giving the same error dialog (see screenshot):

Error 1935. An error occurred during installation of assembly.

'policy.1.0.cli_cppuhelper,publicKeyToken="ce2cb7e279207b9e",version="22.0.0.0",culture="neutral",processorArchitecture="x86". Please refer to Help and Sup...

prevoius 3 daily builds (19, 20 and 21 september) were installed without trobles on the same Vista 64bit PC
Comment 1 tommy27 2012-09-25 05:25:00 UTC
same error on master~2012-09-24_21.00.28_LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US.msi
Comment 2 Roman Eisele 2012-09-25 05:57:12 UTC
Comment on attachment 67647 [details]
LOdev install errir dialog

Tried to fix MIME type.
Comment 3 tommy27 2012-09-25 06:14:12 UTC
(In reply to comment #0)
> Created attachment 67647 [details]
> LOdev install errir dialog
> 
> today's Windows build
> master~2012-09-24_10.33.18_LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US.msi
> will not install on Vista 64bit and XP 32bit.
> 

did not install also on a 3rd PC with Win7 64bit.
same error dialog as above.
Comment 4 Andras Timar 2012-09-25 11:55:47 UTC
@dtardon: Possible side effect of merging feature/gbuild_ure?
Comment 5 tommy27 2012-09-26 05:20:43 UTC
as additional information, all the 3 PC where I experience the install failure have Intel processors. I do not have AMD machines to test.
Comment 6 David Tardon 2012-09-26 10:52:39 UTC
(In reply to comment #4)
> @dtardon: Possible side effect of merging feature/gbuild_ure?

Yes, nearly certainly. I will investigate.
Comment 7 David Tardon 2012-09-27 08:42:06 UTC
Could you get verbose log of the installation and attach it here?

msiexec /lv install.log /i master~2012-09-24_10.33.18_LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US.msi
Comment 8 Andras Timar 2012-09-27 10:19:42 UTC
Created attachment 67761 [details]
Install log
Comment 9 tommy27 2012-09-29 07:38:25 UTC
just an information: has the Win-x86@6 tinderbox stopped producing new daily builds because of this bug?

as far as I see, the last available master is from 2012-09-24_21.00.28/ 

http://dev-builds.libreoffice.org/daily/Win-x86@6/master/
Comment 10 David Tardon 2012-10-15 13:09:21 UTC
Created attachment 68572 [details]
grasping for a straw...

Bah, the log file has not helped me at all... I examined the changes between the old and new makefiles again and found one I previously missed (or ignored): the old makefile.mk explicitly reset use_shl_versions, which means there was no resource file linked in. Just in case this makes a difference, I am attaching a patch that does the same thing in gbuild world...
Comment 11 tommy27 2012-10-15 13:33:07 UTC
@David Tardon
as soon that patch will be integrated into master and in new daily build, I'll be glad to test it.
Comment 12 Andras Timar 2012-10-15 13:36:01 UTC
(In reply to comment #10)
> Created attachment 68572 [details] [review]
Please push it, QA people will check it in daily builds. I cannot try it right now, because I don't have a current master Windows build, and I depart to Berlin soon to LibOCon.
Comment 13 Not Assigned 2012-10-16 11:29:59 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=40a4c469dff783736ba69ec4134e3c23e78b2769

fdo#55290 do not use resource file for assembly libs



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 tommy27 2012-10-16 20:11:14 UTC
@David Tardon

the Win-x86@6 tinderbox ( http://dev-builds.libreoffice.org/daily/Win-x86@6/ ) stopped producing new dailies few days after I reported this issue.

I think that someone stopped it since it was useless to create build that would not install. so, actually there's no available master build to test.

I'm wondering if the tindebox will soon resume working after your patch.

thanks
Comment 15 Pedro 2012-10-20 22:09:02 UTC
Version 3.7.0.0.alpha0+ (Build ID: 370m0(Build:0))

downloaded from

/daily/Win-x86@6/master/2012-10-20_14.21.35

installs correctly as a parallel instal under Win XP Pro SP3
Comment 16 V Stuart Foote 2012-10-20 23:05:45 UTC
Unfortunately for me, on Win7-64, todays TB-6 master~2012-10-20_14.21.35_LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US.msi  is still throwing the MSI installer Error 1935.

MSI installed without any other LibO present.


Extract of Verbose installer log at point of Error:

MSI (s) (34:08) [17:44:55:970]: Executing op: CleanupConfigData()^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\E9C157D1DAA4D3840A4896873B7964B2\Patches 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Executing op: RegisterPatchOrder(Continue=0,SequenceType=1,Remove=0)^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Products\E9C157D1DAA4D3840A4896873B7964B2\Patches 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Executing op: ProductPublish(PackageKey={B1C37A46-A3EF-4F16-A275-8CD86DC3850B})^M
1: {1D751C9E-4AAD-483D-A084-6978B397462B} ^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2 3: 2 ^M
MSI (s) (34:08) [17:44:55:970]: Executing op: UpgradeCodePublish(UpgradeCode={910006D2-BDF1-440C-89D3-8F1DD93790FE})^M
MSI (s) (34:08) [17:44:55:970]: Executing op: SourceListPublish(,,DiskPromptTemplate=[1],,NumberOfDisks=1)^M
MSI (s) (34:08) [17:44:55:970]: Note: 1: 1402 2: UNKNOWN\Installer\Products\E9C157D1DAA4D3840A4896873B7964B2\SourceList 3: 2 ^M
MSI (s) (34:08) [17:44:55:985]: Executing op: ProductPublishClient(,,)^M
MSI (s) (34:08) [17:44:55:985]: Executing op: SourceListRegisterLastUsed(SourceProduct={1D751C9E-4AAD-483D-A084-6978B397462B},LastUsedSource=C:\Users\vsfoote\Downloads\)^M
MSI (s) (34:08) [17:44:55:985]: Entering CMsiConfigurationManager::SetLastUsedSource.^M
MSI (s) (34:08) [17:44:55:985]: Specifed source is already in a list.^M
MSI (s) (34:08) [17:44:55:985]: User policy value 'SearchOrder' is 'nmu'^M
MSI (s) (34:08) [17:44:55:985]: Adding new sources is allowed.^M
MSI (s) (34:08) [17:44:55:985]: Set LastUsedSource to: C:\Users\vsfoote\Downloads\.^M
MSI (s) (34:08) [17:44:55:985]: Set LastUsedType to: n.^M
MSI (s) (34:08) [17:44:55:985]: Set LastUsedIndex to: 1.^M
MSI (s) (34:08) [17:44:55:985]: Executing op: End(Checksum=0,ProgressTotalHDWord=0,ProgressTotalLDWord=542385297)^M
MSI (s) (34:08) [17:44:56:001]: Assembly Error:The given assembly name or codebase, '%1', was invalid.^M
MSI (s) (34:08) [17:44:56:001]: Note: 1: 1935 2: {22185FB0-0AED-5CE4-C190-48CC661F0454} 3: 0x80131047 4: IAssemblyCacheItem 5: Commit 6: policy.1.0.cli_cppuhelper,publicKeyToken="ce2cb7e279207b9e",version="22.0.0.0",culture="neutral",processorArchitecture="x86" ^M
DEBUG: Error 2835:  The control ErrorIcon was not found on dialog SetupError^M
Internal Error 2835. ErrorIcon, SetupError^M
Error 1935.An error occurred during the installation of assembly 'policy.1.0.cli_cppuhelper,publicKeyToken="ce2cb7e279207b9e",version="22.0.0.0",culture="neutral",processorArchitecture="x86"'. Please refer to Help and Support for more information. HRESULT: 0x80131047. assembly interface: IAssemblyCacheItem, function: Commit, component: {22185FB0-0AED-5CE4-C190-48CC661F0454}^M
MSI (s) (34:08) [17:45:45:141]: Product: LOdev 3.7 -- Error 1935.An error occurred during the installation of assembly 'policy.1.0.cli_cppuhelper,publicKeyToken="ce2cb7e279207b9e",version="22.0.0.0",culture="neutral",processorArchitecture="x86"'. Please refer to Help and Support for more information. HRESULT: 0x80131047. assembly interface: IAssemblyCacheItem, function: Commit, component: {22185FB0-0AED-5CE4-C190-48CC661F0454}^M
^M
Action ended 17:45:45: InstallFinalize. Return value 3.^M
MSI (s) (34:08) [17:45:45:156]: User policy value 'DisableRollback' is 0^M
MSI (s) (34:08) [17:45:45:156]: Machine policy value 'DisableRollback' is 0^M
Comment 17 David Tardon 2012-10-21 08:33:15 UTC
(In reply to comment #15)
> Version 3.7.0.0.alpha0+ (Build ID: 370m0(Build:0))
> 
> downloaded from
> 
> /daily/Win-x86@6/master/2012-10-20_14.21.35
> 
> installs correctly as a parallel instal under Win XP Pro SP3

Do you have .NET runtime installed? I think it was not present by default on Windows XP.
Comment 18 David Tardon 2012-10-21 08:45:09 UTC
(In reply to comment #16)
> Unfortunately for me, on Win7-64, todays TB-6
> master~2012-10-20_14.21.35_LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US.msi
> is still throwing the MSI installer Error 1935.
> 
> MSI installed without any other LibO present.
> 
> 
> Extract of Verbose installer log at point of Error:
> 
> MSI (s) (34:08) [17:44:55:985]: Executing op:
> End(Checksum=0,ProgressTotalHDWord=0,ProgressTotalLDWord=542385297)^M
> MSI (s) (34:08) [17:44:56:001]: Assembly Error:The given assembly name or
> codebase, '%1', was invalid.^M
> MSI (s) (34:08) [17:44:56:001]: Note: 1: 1935 2:
> {22185FB0-0AED-5CE4-C190-48CC661F0454} 3: 0x80131047 4: IAssemblyCacheItem
> 5: Commit 6:
> policy.1.0.cli_cppuhelper,publicKeyToken="ce2cb7e279207b9e",version="22.0.0.
> 0",culture="neutral",processorArchitecture="x86" ^M

This is the same error as before, so it seems we got nowhere :-( Has anyone any idea how to proceed with further debugging? I still think it is a change in the way the native CLI library is built, but I fail to see anything substantive... Unless it is a trivial change, like a (default) define that was present before or is present now.
Comment 19 tommy27 2012-10-21 09:18:36 UTC
I confirm that the issue is still present in  master~2012-10-20_14.21.35_LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US.msi 

master aborts installation on Win Vista 64 bit SP1 Home Premium with MS .NET framework 3.5 SP1

the error message is exactly the same as in my first report
Comment 20 Andras Timar 2012-10-21 13:22:01 UTC
I'm still in Prague on openSUSE Conference, away from my Windows box. I can debug it only on the week beginning on Oct 29. I found two blog posts that could help, of course they can be tested only on Windows.

How to debug 1935 errors with HRESULT 0x80131047 in an MSI-based setup
http://blogs.msdn.com/b/astebner/archive/2007/05/06/2457576.aspx

Troubleshooting 1935 and 2908 errors during installation
http://blogs.msdn.com/b/astebner/archive/2004/11/10/255346.aspx

I think the bug finally will boil down to a typo in the new makefiles, but we shall see...
Comment 21 tommy27 2012-10-22 06:15:56 UTC
as said in the first report, the last functioning master build was that of september 21st, and I started experiencing the bug since september 24th build.
so the timeframe where to look the bug for is between 21 and 23rd september.
Comment 22 David Tardon 2012-10-22 08:57:58 UTC
It seems that the problem is that the policy dlls are not created with the installation name already, but are renamed. At least that is how I understand the following error message from gacutil.exe -i:

Failure adding assembly policy.1.0.cli_cppuhelper.dll to the cache: the filename "policy.1.0.cli_cppuhelper.dll" doesn't match the assembly name "cli_cppuhelper"
Comment 23 Not Assigned 2012-10-22 12:39:36 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cbd9dddb4d259df3ab7b3e58e5b7165d18037c1a

fdo#55290 create CLI assemblies with the right name



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Not Assigned 2012-10-22 21:09:33 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2589505cc299950a2d41aa65e0100fb0c6f0a7a6

fdo#55290: CliAssembly: fix cbd9dddb: s/NAME/OUTFILE/



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Michael Meeks 2012-10-26 09:49:35 UTC
Any confirmation if:

http://dev-builds.libreoffice.org/daily/W2008R2@16-minimal_build/master/current/

Now installs correctly for people ? if so we can close this :-) [ Thanks David & Michael ].
Comment 26 tommy27 2012-10-26 12:07:59 UTC
@Micheal Meeks

tried master~2012-10-25_22.55.31 on Vista 64bit
still aborts installation at the same point.

the error message is:
..............................................................
Error 1935. An error occurred during installation of assembly.

'cli_cppuhelper,publicKeyToken="ce2cb7e279207b9e",version="1.0.22.0",culture="neutral",processorArchitecture="x86". Please refer to Help and Support...
..............................................................


which is slightly different from the original report which was:

..............................................................
Error 1935. An error occurred during installation of assembly.

'policy.1.0.cli_cppuhelper,publicKeyToken="ce2cb7e279207b9e",version="22.0.0.0",culture="neutral",processorArchitecture="x86". Please refer to Help and Sup...
..............................................................

so, this time there's no "policy.1.0" at the beginning of the phrase and version is "1.0.22.0" instead of "22.0.0.0". all the rest is the same.


don't know if this may help you.
Comment 27 David Tardon 2012-10-26 16:24:31 UTC
So the native library may not be renamed either.
Comment 28 DavidO 2012-10-27 20:23:06 UTC
in fact gbuildified cli_cppuhelper.dll is almoust 20% bigger compared to dmake version (107 kb vs. 127 kb).

So my first thought was to replace master's build version with the rel's 3.6.3.2 build version
in solver and rerun msi creation with make command.
But cli_cppuhelper.dll was not contained on my machine after complete 
installation of 3.6.3.2. What am i missing here?

Anyway here is a workaround how to install current master build for now

1. download the latest rel build (3.6.3.2 worked for me).
2. extract the content of rel msi to hard drive:
   msiexec /a LibO-3.6.3.2_Win_x86_install_multi.msi TARGETDIR=%TEMP%\LibO-3.6.3.2
3. extract the content of master build to hard drive:
   msiexec /a LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US.msi TARGETDIR=%TEMP%\LibO-3.7
4. replace cli_cpppuhelper.dll from LibO-3.6.3.2/URE/bin to LibO-3.7/URE/bin:
   copy %TEMP%\LibO-3.6.3.2\URE\bin\cli_cpppuhelper.dll %TEMP%\LibO-3.7\URE\bin
5. installation is working now: %TEMP%\LibO-3.7\LibO-Dev_3.7.0.0.alpha0_Win_x86_install_en-US.msi

Note, I could upload a working copy of cli_cppuhelper.dll to some location to skip the steps 1 and 2 above.
Comment 29 DavidO 2012-10-28 10:05:52 UTC
Th easiest way to track down further that problem is to compare dmake and gbuild builds. Here we go:

Verbose build of recent dmake clie_ure module (branch libreoffice-3-6-2):

https://ci.idaia.de/job/LO-WinXP-Head/65/console

Verbose build of recent gbuildified clie_ure module (master), VC 2010:

full console output:

https://ci.idaia.de/job/LO-Win2008-VC2010/3/console

broken msi:

https://ci.idaia.de/job/LO-Win2008-VC2010/3/
Comment 30 DavidO 2012-10-28 15:03:30 UTC
Do we have somehow version mismatch? al.exe is newer then the runtime?
(In my case Windows 2008 with .net 4.0 used ... the the messages translated from german)

C:\Users\Administrator\AppData\Local\Temp\LO-dev-3.7\URE\bin>"C:\Program Files (
x86)\Microsoft SDKs\Windows\v7.0A\Bin\gacutil.exe" /i cli_cppuhelper.dll
Microsoft (R) .NET Global Assembly Cache Utility.  Version 3.5.30729.1
Copyright (c) Microsoft Corporation. Alle Rechte vorbehalten.

Error adding assembly to the cache: This assembly is built by a
runtime newer than the currently loaded runtime and cannot be loaded.

The dmake version (branch 3-6-3-2) can be added and removed without problems:

C:\Users\Administrator\AppData\Local\Temp\LO-rel-3.6.3.2\URE\bin>"C:\Program Fil
es (x86)\Microsoft SDKs\Windows\v7.0A\Bin\gacutil.exe" /i cli_cppuhelper.dll
Microsoft (R) .NET Global Assembly Cache Utility.  Version 3.5.30729.1
Copyright (c) Microsoft Corporation. Alle Rechte vorbehalten.

The assembly was successful added to the cache.

C:\Users\Administrator\AppData\Local\Temp\LO-rel-3.6.3.2\URE\bin>"C:\Program Fil
es (x86)\Microsoft SDKs\Windows\v7.0A\Bin\gacutil.exe" /u cli_cppuhelper
Microsoft (R) .NET Global Assembly Cache Utility.  Version 3.5.30729.1
Copyright (c) Microsoft Corporation. Alle Rechte vorbehalten.

Assembly: cli_cppuhelper, Version=1.0.22.0, Culture=neutral, PublicKeyToken=ce2c
b7e279207b9e, processorArchitecture=x86
Deinstalliert: cli_cppuhelper, Version=1.0.22.0, Culture=neutral, PublicKeyToken
=ce2cb7e279207b9e, processorArchitecture=x86
Anzahl der deinstallierten Assemblys = 1
Anzahl der Fehler = 0
Comment 31 DavidO 2012-10-28 15:23:32 UTC
ok, this time the right gacutil.exe used (from Bin\NETFX 4.0 Tools):

C:\Users\Administrator\AppData\Local\Temp\LO-dev-3.7\URE\bin>"C:\Program Files (
x86)\Microsoft SDKs\Windows\v7.0A\Bin\NETFX 4.0 Tools\gacutil.exe" /i cli_cppuhe
lper.dll
Microsoft (R) .NET Global Assembly Cache Utility.  Version 4.0.30319.1
Copyright (c) Microsoft Corporation.  All rights reserved.

Failure adding assembly to the cache: Invalid file or assembly name.  The name o
f the file must be the name of the assembly plus .dll or .exe .
Comment 32 Not Assigned 2012-10-28 22:20:16 UTC
David Ostrovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8865b7f013bcd9b4ce41dd98be28ba28aeb22e66

fdo#55290: use the right native library name



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 33 V Stuart Foote 2012-10-29 02:07:02 UTC
Clean install with TB 16:

Build Info
tinderbox: administrator: nthiebaud@gmail.com
tinderbox: buildname: W2008R2@16-minimal_build
tinderbox: tree: MASTER
tinderbox: pull time 2012-10-28 23:54:54
tinderbox: git sha1s
core:0dd085f8f327b08cf5d69c3e1b93ff82016995fb

On a Win7 64-bit system that was halting with 1935 installer error before.
Comment 34 tommy27 2012-10-29 07:11:22 UTC
same build as in previous comment finally installs on Vista 64 as well.

well done, guys!!!
Comment 35 Korrawit Pruegsanusak 2012-11-02 17:24:03 UTC
(In reply to comment #33)
> Clean install with TB 16:
> 
> Build Info
> tinderbox: administrator: nthiebaud@gmail.com
> tinderbox: buildname: W2008R2@16-minimal_build
> tinderbox: tree: MASTER
> tinderbox: pull time 2012-10-28 23:54:54
> tinderbox: git sha1s
> core:0dd085f8f327b08cf5d69c3e1b93ff82016995fb
> 
> On a Win7 64-bit system that was halting with 1935 installer error before.

Do you still have a problem with newer build? I've just installed (normal install by double click an installer and next, next, next, ...) the following build successfully on Windows 7 64 bit:

Build Info
tinderbox: administrator: nthiebaud@gmail.com
tinderbox: buildname: W2008R2@16-minimal_build
tinderbox: tree: MASTER
tinderbox: pull time 2012-11-01 23:27:25
tinderbox: git sha1s
core:1219bcb0c4f1dd1753c8bb63baf957f878971b70
Comment 36 V Stuart Foote 2012-11-02 18:49:18 UTC
No more error 1935 issue and the TB 16 builds were working fine as indicated in comment 33.  Bug seems fully quashed.
Comment 37 Michael Meeks 2012-11-05 11:40:14 UTC
Thanks for the testing Stuart ! :-)