Download it now!
Bug 55485 (columnsort) - sort option "left to right" does sort "top to bottom"
Summary: sort option "left to right" does sort "top to bottom"
Status: RESOLVED DUPLICATE of bug 55967
Alias: columnsort
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-01 06:20 UTC by Martin Trautmann
Modified: 2012-10-15 05:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Trautmann 2012-10-01 06:20:17 UTC
When I select the sort option from left to right, it still does sort from top to bottom.

That's the major fault, but the sorting is a major bug and ui collection:

Bugs:
* sort options are not sticky: when  you do select the same range of data again, the former option such as "Range contains column labels" is not kept.

* sort now failed with the option of column labels: it did show the column labels to select from, but it still did include the labels within the sorting, thus moving the first row downwards

User Interface:
* the selection of sort criteria is very user unfriendly. If you want to see a better implementation, check e.g. FileMaker: A left column with available fields (labels), a right column to move the fields over and the option to reorder the selected fields (labels) - either by drag'n'drop or with up/down arrows

* the major requirement to use the pop up lists is not user friendly. It's a poor copy of Excel, while over there you still may edit the selection by hand, e.g. to enter both the label or identifiers such as "column z"

* field selection should trigger automatic sort options: when I do select the full table, full columns or full rows, it's very probable that this selection would include range labels. On the other hand, selection of a few cells only probably could mean no range labels, but data only.
Comment 1 Uwe Altmann 2012-10-10 19:54:40 UTC
Using OS 10.6.8 with LO 3.6.2.2

Sort option from left to right works as long as "Range contains column labels" is not checked.
Once checked, sort from left to right doesn't work at all (which is not totally unexpected).
But this option is far too sticky - it is impossible to get rid of it. You may uncheck it, but horizontal sort don't work and when reopening dialog, it is still there.

But sorting top-down respects column labels once it is checked.
Seems to be the newest version of bug https://bugs.freedesktop.org/show_bug.cgi?id=53482

UI improvements sound good - moved to a new issue id=55852

Platform removed - seems to be a long lasting problem not only for Mac OS
Comment 2 Rainer Bielefeld Retired 2012-10-15 05:01:49 UTC
I mark this one as DUP of Bug 55485 because description there is more precise.

*** This bug has been marked as a duplicate of bug 55967 ***