Bug 55522 - FILEOPEN: paticular .CDR (7) shows pixel picture text contents blue instead of read
Summary: FILEOPEN: paticular .CDR (7) shows pixel picture text contents blue instead o...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Fridrich Strba
URL:
Whiteboard: BSA target:3.6.3 target:4.0.0.beta1
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-02 04:12 UTC by Rainer Bielefeld Retired
Modified: 2012-12-11 16:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample Document (168.87 KB, application/vnd.corel-draw)
2012-10-02 04:12 UTC, Rainer Bielefeld Retired
Details
Sample Document New (168.89 KB, application/vnd.corel-draw)
2012-10-05 05:45 UTC, Rainer Bielefeld Retired
Details
This should fix the stuff in libcdr (1.04 KB, patch)
2012-10-05 09:00 UTC, Fridrich Strba
Details
A fixed dll for Rainer's testing (1.74 MB, application/octet-stream)
2012-10-05 09:13 UTC, Fridrich Strba
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-10-02 04:12:56 UTC
Created attachment 67958 [details]
Sample Document

Steps to reproduce:
1. Open attached "staefa.cdr" in LibO 3.6
   Expected: Text is red
   Actual: Text is blue
     
I created this document in 2001 and can't remember whether I scanned that or made a snapshot of a PDF or whatever else.

The problem ersists when I open and save the sample document with CorelDRAW X6

I have too few sample documents to test whether the problem is a general one ofonly for that particular document
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120909 Firefox/15.0.1 SeaMonkey/2.12.1
Comment 1 Valek Filippov 2012-10-05 03:27:24 UTC
Comment on attachment 67958 [details]
Sample Document

File seems to be corrupted.
At least it doesn't have first 16 bytes.
Comment 2 Rainer Bielefeld Retired 2012-10-05 05:45:26 UTC
Created attachment 68105 [details]
Sample Document New

Because old sample was corrupted because of "Bug 55506 BUGZILLA: attachments damaged during upload with auto-detect content type on"
Comment 3 Rainer Bielefeld Retired 2012-10-05 05:47:42 UTC
Comment on attachment 67958 [details]
Sample Document

Bug 55506 BUGZILLA: attachments damaged during upload with auto-detect content type on
Comment 4 Fridrich Strba 2012-10-05 06:34:00 UTC
I opened it with the release 3.6.2.2 on Linux x86_64, with yesterday's master too. Both show the bitmap in red
Comment 5 Rainer Bielefeld Retired 2012-10-05 07:47:15 UTC
Strange, Server Installation of "LibreOffice 3.6.2.2  German UI/ German Locale [Build-ID:  da8c1e6] on German WIN7 Home Premium (64bit) definitively shows blue bitmap
Comment 6 Fridrich Strba 2012-10-05 07:51:06 UTC
@Rainer: could you attach the resulting flat odg that it produces when importing the document? Will try to dig whether there is some weird level of locale-dependent behaviour.
Comment 7 Fridrich Strba 2012-10-05 08:59:23 UTC
OK, so it is a windows specific stuff with indexed (paletted) bitmaps.
Comment 8 Fridrich Strba 2012-10-05 09:00:07 UTC
Created attachment 68108 [details]
This should fix the stuff in libcdr
Comment 9 Fridrich Strba 2012-10-05 09:13:56 UTC
Created attachment 68111 [details]
A fixed dll for Rainer's testing

If you replace the previous version of the wpftdrawlo.dll in the program folder, you should start to see red. Will try to push new libcdr with this bug and the two heise bugs for 3.6.3
Comment 10 Not Assigned 2012-10-05 14:47:31 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1e7340538bfe4374df48e914e47ad5cddf1e309a&g=libreoffice-3-6

New release libcdr 0.0.9, fixes fdo#55522 and partly fdo#54785


It will be available in LibreOffice 3.6.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Rainer Bielefeld Retired 2012-10-06 16:11:40 UTC
Now works fine with Server-installation of Master "3.7.0.alpha0+  – ENGLISH UI [Build ID: b255de8]" {tinderbox: Win-x86@16, pull time 2012-10-06 09:31:39} on German WIN7 Home Premium (64bit) UserInstallation=$SYSUSERCONFIG/LOdev/3

An indeed, replacing the .dll heals the problem for Server Installation of "LibreOffice 3.6.2.2 release”  German UI/ German Locale [Build-ID:  da8c1e6] on German WIN7 Home Premium (64bit)

I woder how the fix came into 3.7 without target info here, but I think we can close this one FIXED
Comment 12 Michael Stahl (allotropia) 2012-12-11 16:31:43 UTC
apparently this is fixed?