Bug 55937 - Can't type text into frames
Summary: Can't type text into frames
Status: RESOLVED DUPLICATE of bug 55842
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: Other All
: high major
Assignee: Not Assigned
Keywords: regression
Depends on:
Reported: 2012-10-12 18:52 UTC by hyper_ch
Modified: 2012-12-02 22:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

Honorar.odt (32.51 KB, application/vnd.oasis.opendocument.text)
2012-10-12 18:52 UTC, hyper_ch

Note You need to log in before you can comment on or make changes to this bug.
Description hyper_ch 2012-10-12 18:52:33 UTC
Created attachment 68502 [details]

I have a little Writer document in which I use a frame for the recipient address. In the main body there's an embedded calc sheet for doing some calculations.

Prior to I could just type text into the frame without problems. In I can't anymore.

I also tried to create a new frame also outside the main text body area. Same result. It can't be selected to type things into.

However if I add a frame inside the main text body area it works as expected.

The according .odt is attached.

1.) Open the attached Honorar.odt
2.) Try to select the top left frame and type something into

Result: You can't select it for typing
Comment 1 Roman Schleicher 2012-10-12 19:16:18 UTC
(In reply to comment #1)
> Created attachment 68502 [details]
> Honorar.odt

Maybe the same problem as here:

Comment 2 manj_k 2012-10-13 08:50:00 UTC
Confirmed (on WinXP 32b) with
- LibO
- LibO
- LibO-Dev_3.6.4.0+
  Win-x86_9-Voreppe libreoffice-3-6
  pull time 2012-10-12 13:47:16
- LibO-Dev
  W2008R2@20-With-Symbol-Bytemark-Hosting MASTER
  pull time 2012-10-01 05:02:30

Works fine with LibO

- Select the frame via Navigator (F5) → Text frames
- Navigate with the arrow keys → Edit
Comment 3 hyper_ch 2012-10-13 09:21:25 UTC
@ Roman Schleicher

That sounds like my problem. The workaround in there works also... right-click the frame and start typing. That way it gets highlighted.

@ mani k

Your workaround works also. Thanks :)
Comment 4 manj_k 2012-10-13 10:47:52 UTC
Keyword "regression"
Comment 5 manj_k 2012-10-13 11:04:10 UTC
Marked as duplicate of 'Bug 55842 - no focus on frame for editing' after discussion on → http://nabble.documentfoundation.org/Problem-in-LibO-3-6-2-mit-Textrahmen-td4013026.html#none .

*** This bug has been marked as a duplicate of bug 55842 ***