Bug Hunting Session
Bug 56028 - [UI]Zooming makes cell content disappear partly
Summary: [UI]Zooming makes cell content disappear partly
Status: RESOLVED DUPLICATE of bug 108638
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering Zoom-Issues
  Show dependency treegraph
 
Reported: 2012-10-16 09:28 UTC by Winfried Donkers
Modified: 2017-09-25 10:37 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (ods) that shows problem. (10.03 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-16 09:28 UTC, Winfried Donkers
Details
sample zoomed at 100% (gif) (22.55 KB, image/gif)
2012-10-16 09:29 UTC, Winfried Donkers
Details
sample zoomed at 90% (gif) (21.98 KB, image/gif)
2012-10-16 09:29 UTC, Winfried Donkers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Donkers 2012-10-16 09:28:27 UTC
Created attachment 68616 [details]
sample (ods) that shows problem.

See attachment (sample.ods).
Zoomed at 100% the complete contenst is visible. see attachment (100percent.gif)
When zooming to e.g. 90% by clicking on the minus left of the zoom-scale in the status bar of the form, the content is partly hidden because it no longer fits in the cell. see attachment (90percent.gif)

IMO when zooming the layout should not change.
Comment 1 Winfried Donkers 2012-10-16 09:29:01 UTC
Created attachment 68617 [details]
sample zoomed at 100% (gif)
Comment 2 Winfried Donkers 2012-10-16 09:29:27 UTC
Created attachment 68618 [details]
sample zoomed at 90% (gif)
Comment 3 Teo91 2014-09-06 11:26:13 UTC
I can confirm this bug on LO 4.3.1

It's particularly bad because the page numbering goes crazy: depending on the zoom (80-90-120%...) the number of pages in the spreadsheet changes (e.g. when you have a macro showing the page number).
The only "workaround" is working constantly at the same zoom level, which is not a viable solution.

Set to HIGH normal: Calc becomes potentially useless working on some documents.
Comment 4 Teo91 2014-09-08 12:43:25 UTC
Another (weak) workaround, at the beginning of a macro you can use something like:

ThisComponent.CurrentController.ZoomValue = 100

It's still a poor solution, users might be disoriented by a zoom automatic change.
Comment 5 Tom Colley 2015-10-12 00:46:43 UTC
I've also experienced this issue with LibreOffice, on Ubuntu, and for some years now, up to and including Version 4.4.5.2.
Comment 6 QA Administrators 2016-11-08 11:11:03 UTC Comment hidden (obsolete)
Comment 7 Winfried Donkers (retired) 2016-11-08 12:59:48 UTC
Problem still present in version 5.2.3 (Windows7).
Comment 8 Tom Colley 2017-03-18 03:04:05 UTC
I think this bug is a duplicate of bug 73658.

*** This bug has been marked as a duplicate of bug 73658 ***
Comment 9 Winfried Donkers (retired) 2017-03-20 11:51:18 UTC
(In reply to Tom Colley from comment #8)
> I think this bug is a duplicate of bug 73658.
> 
> *** This bug has been marked as a duplicate of bug 73658 ***

It would be better practise to make the newer bug report (i.e. bug 73658) a duplicate of the older one (i.e. bug 56028).

For instance, bug 56028 shows that the problem occurs since (at least) version 3.6.2.2, whereas bug 73658 suggests that the problem only exists since version 4.1.0.4. .

I will change this.
Comment 10 Winfried Donkers (retired) 2017-03-20 11:51:34 UTC
*** Bug 73658 has been marked as a duplicate of this bug. ***
Comment 11 Buovjaga 2017-06-10 17:43:08 UTC
*** Bug 108274 has been marked as a duplicate of this bug. ***
Comment 12 Yousuf Philips (jay) (retired) 2017-09-25 10:37:04 UTC

*** This bug has been marked as a duplicate of bug 108638 ***