Download it now!
Bug 56137 - LO uses absolute paths to other document even with "use relative paths" option checked
Summary: LO uses absolute paths to other document even with "use relative paths" optio...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2012-10-18 12:45 UTC by kavalec74
Modified: 2018-07-26 10:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kavalec74 2012-10-18 12:45:55 UTC
Check "Use relative pathes"

open two documents, link from one to another

LO uses always abolute pathes!
Comment 1 kavalec74 2012-10-18 12:46:58 UTC Comment hidden (no-value)
Comment 2 Thomas Hackert 2013-06-30 14:59:28 UTC
Hello kavalec74, *,
would you be so kind to tell me, how you have the link? Or could you attach a document to this issue, so we QAer could test it? And have you tried it with a newer version than LO 3.6.2.2? It would be nice, if you could close the bug, if it is fixed there ... ;)
Sorry for the inconvenience
Thomas.
Comment 3 QA Administrators 2014-02-02 02:06:36 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2014-02-26 19:31:06 UTC Comment hidden (obsolete)
Comment 5 gmolleda 2016-06-18 11:23:47 UTC
LibreOffice 5.0.6.3 GNU/Linux LinuxMint 17.3 (Ubuntu 14.04)
Steps:
1) You have a folder with a document (a.pdf, a.txt or a.odt)
2) you open a new LibreOffice document: Writer or Calc or Impress
3) You save the new document in the same folder of a.pdf, a.txt or a.odt.
4) You insert a hyperlink (select a text first in Writer or Impress), select Document and choice the path with button folder and select the file for linking.

You have a full path in the path line.

If you save the file, you move both files (new document and linked file) to other folder and the hyperlink don't work.

If you change the path line and remove all path folder and only write a.pdf (or a.txt, ...) then the hyperlink is transformed to smb link, it don't work.

Why I want a relative path hyperlink?
In impress I want insert a hyperlink to a video file, when I push the hyperlink, the video file must to be opened with the default video program.
Comment 6 Regina Henschel 2018-07-26 07:58:42 UTC
There has been a fix in bug 79305 in regard to relative links and I cannot reproduce the problem in current master. So I'll close this issue as "works for me".

Please test a current version of LibreOffice and if you still get no relative link open a new issue. You should know, that the paths shown in the dialogs are the calculated paths in the current situation. You need to unpack the saved document and look into it, to see the actual saved form of the link.
Comment 7 gmolleda 2018-07-26 10:17:01 UTC
Esperanto:
Kiujn paŝojn vi sekvis?
Se mi enmetas video, ĝi funkcias bone ĉar la video estas enigita ene de la Impress dosiero.
Sed se mi kreas ligilon al dokumento PDF lokita en la sama dosierujo kiel la .odp-dosiero (Impress) la dosierindiko estas absoluta ĉar LO bezonas la absolutan doiserindikon por ruli la PDF-legilon (Adobe Reader, Evince, ...).
LibreOffice devas konservi la relativan dosierindikon kaj aldoni al ĝi la reston de la dosierindiko de la aktualan dosierujon de la dosiero por kompletigi la dosierindikon por sendi al la ekstera legilo-programo.

Inglés:
What steps have you followed?
If I insert a video it works well because the video is embedded inside the Impress file.
But if I create a link to a pdf document located in the same directory as the .odp file (impress) the path is absolute because it says the program that needs it so to call the external reader program (.../reader.exe AbsolutePATH/file.pdf).
LibreOffice should save the relative path and add the rest of the path by calculating the current working directory of the file to complete the path to send to the external reader program.

Español:
¿Qué pasos has seguido?
Si inserto un vídeo funciona bien porque el vídeo es embebido dentro del fichero de impress.
Pero si creo un enlace a un documento pdf ubicado en el mismo directorio que el fichero .odp (impress) la ruta es absoluta porque dice el programa que lo necesita así para llamar al programa lector externo.
LibreOffice debería guardar la ruta relativa y añadirle si quiere el resto de la ruta calculando el directorio de trabajo actual del fichero para completar la ruta a enviar al programa lector externo.
Comment 8 gmolleda 2018-07-26 10:18:19 UTC
LibreOffice
Versión: 6.0.3.2
Id. de compilación: 1:6.0.3-0ubuntu1
Subprocs. CPU: 4; SO: Linux 4.15; Repres. IU: predet.; VCL: gtk3; 
Configuración regional: es-ES (eo.UTF-8); Calc: group

LinuxMint 19.
Comment 9 gmolleda 2018-07-26 10:21:36 UTC
Sorry, it worked when I changed the folder.
Pardonpetas, ĝi rulis bone kiam mi ŝanĝis la dosierujon.
Perdon, trabajó bien al moverlo de carpeta.