Download it now!
Bug 56584 - EDITING: 'Delete Comment' leaves abandoned callout
Summary: EDITING: 'Delete Comment' leaves abandoned callout
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: BSA target:4.0.0 target:3.6.5
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-10-30 15:43 UTC by giloudepau
Modified: 2015-12-22 01:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description giloudepau 2012-10-30 15:43:37 UTC
Problem description: 
Firstly, what a brilliant tool LibreOffice really is! This is the future!

I added a comment to a cell, set it to Show Comment. If I right-click on the cell and select Delete Comment with the Show Comment selected, it fails to delete it. The drop-down menu now does not offer to either Show or Delete the existing comment.

Steps to reproduce:
1. Add a comment to a cell
2. Select Show comment
3. Select Delete comment
4. Try to either Show or Delete the existing comment, I cannot.

Current behavior:
No option offered in the drop-down menu.

Expected behavior:
Warn the user then include the 2 possibilities mentioned above.

Platform (if different from the browser): 
This is run on Windows7

Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4
Comment 1 Rainer Bielefeld Retired 2012-10-30 16:29:06 UTC
[Reproducible] with "LibreOffice 3.6.3.2” German UI/ German Locale [Build-ID: 58f22d5]" on German WIN7 Home Premium (64bit).

I deleted a comment with checked "Visible". Comment disappears from Navigator, but callout remains. Undo restores the comment with a new callout, what can be seen when you drag and drop the cell with comment to a new place:
- 1 Callout anchored to the comment moves with the cell
- 1 Callout remains at the old place

Already [Reproducible] with 
- Server Installation of  "LibreOffice 3.6.0beta1  German UI/Locale [Build-ID: 1f1cdd8] on German WIN7 Home Premium (64bit) 
- 3.6.0.0.alpha+ 2012-04-26 own profile MinGW

Still worked fine with Server installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 475d0c5-829fc92-39746e8-206648e-fefd87]" (2012-02-14)

Was ok with 3.5.7.2, so regression

Same effect with menu 'Edit'

Currently only reproduced with WIN (although I am pretty sure that all OS will be affected.

@gpjc37@gmail.com
Good shot, thank you for your attention!

@Markus: 
Do you believe a bibisect can be useful?
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC).
Comment 2 Jean-Baptiste Faure 2012-11-03 12:40:06 UTC
Reproducible with current LO 3.6.3 under Ubuntu 12.04 x86_64
Workaround: selecting the comment and hitting the delete key works fine for me.

Set platform to ALL.

Best regards. JBF
Comment 3 Markus Mohrhard 2012-11-04 17:26:39 UTC
> @Markus: 
> Do you believe a bibisect can be useful?
> Please set Status to ASSIGNED and add yourself to "Assigned To" if you
> accept this Bug or forward the Bug if it's not your turf (and remove others
> in team from CC).

No bibisect needed for this one. It was introduced with the notes storage rework.

I'm trying to look into it soon.
Comment 4 Rainer Bielefeld Retired 2012-11-04 17:30:43 UTC
- bibisectrequest due to comment
Comment 5 Markus Mohrhard 2012-11-17 17:42:39 UTC
Ok, have a fix for it but it will not make it into 3.6.4 because the lifecycle of the note caption object is fragile and I need some more testing before it makes it into the stable branch.

The long term goal has to be to bring some sanity into the note caption livecycle. Right now the object is not always deleted because undo doc and normal doc share the object.
Comment 6 Cor Nouws 2012-11-17 20:07:02 UTC
(In reply to comment #5)
> Ok, have a fix for it but [...]

Hi markus, 
I guess the fix you mean is the one tagged  in gerrit with fdo#56548 ?
Comment 7 Markus Mohrhard 2012-11-18 03:25:59 UTC
Playing git bugzilla bot because it was down.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f44928cbd51fc7d08e2b81dcdf837650cd215847
Comment 8 Not Assigned 2012-11-21 14:42:19 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a7ad12f2832c519fcef243c591fcccdc170874c0&g=libreoffice-3-6

fdo#56584: delete also note caption.


It will be available in LibreOffice 3.6.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 giloudepau 2012-11-21 20:14:42 UTC
Bravo Markus!



2012/11/21 <bugzilla-daemon@freedesktop.org>

>  Markus Mohrhard <markus.mohrhard@googlemail.com> changed bug 56584<https://bugs.freedesktop.org/show_bug.cgi?id=56584>
>  What Removed Added  Status ASSIGNED RESOLVED  Resolution --- FIXED
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 10 Robinson Tryon (qubit) 2015-12-22 01:31:07 UTC
Removing comma from Whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
[NinjaEdit]