Bug Hunting Session
Bug 56763 - SLIDESHOW displays CHART without gradients
Summary: SLIDESHOW displays CHART without gradients
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-05 09:49 UTC by bugquestcontri
Modified: 2013-06-13 04:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of slide in normal view (31.58 KB, image/gif)
2012-11-05 09:49 UTC, bugquestcontri
Details
screenshot of same slide in slide show (33.04 KB, image/gif)
2012-11-05 09:50 UTC, bugquestcontri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2012-11-05 09:49:21 UTC
Created attachment 69551 [details]
screenshot of slide in normal view

Problem description: 
I created several slides with charts (stacked column) using the data table of Impress chart, Each data series' area was formatted with a gradient (see attachment 1)
When changing to slide show the gradient formatting disappeared
Steps to reproduce:
1.create a chart in impress with data table of Impress chart ....
2. format data series of stacked column with a gradient area filling
3. chage to Slide Show
4. gradient filling disappears

Current behavior:
gradient filling in in stacked column chart disappears when changing to Slide Show

Expected behavior:
In Slide Show the gradient filling should be correctly displayes as in Normal View

Platform (if different from the browser): 
XP  / SP#
Browser: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

I can be contacted
Comment 1 bugquestcontri 2012-11-05 09:50:11 UTC
Created attachment 69552 [details]
screenshot of same slide in slide show
Comment 2 bugquestcontri 2012-11-20 13:42:20 UTC
togehter with the bug https://bugs.freedesktop.org/show_bug.cgi?id=56766 this creates a full blocker. I cannot use Impress for presentations when I need to show slides in the layout of my company (data series in column charts area filling with gradient.
Therefore I change importance to highest and blocker.

These 2 bugs created a 1 - 2 day loss

I can be contacted
Comment 3 Petr Mladek 2012-11-26 12:21:12 UTC
Same as in the bug #56766. The difference between normal and slide view is usually caused by the hardware acceleration. It might help to disable the checkbox "Tools/Options/View/Use Hardware Acceleration".

Could you please attach sample document that shows the problem? It could help a lot with fixing.

I can't confirm this easily without the test documents but I guess that this is an older bug. I guess that the disabled acceleration would help => it should not block the next bugfix release with other useful fixes => reducing the severity a bit.

We are sorry that this bug caused so many troubles to you.
Comment 4 bugquestcontri 2012-11-26 14:10:00 UTC
Although I  am not an LibO expert but I can follow your argument that this bug is the same as bug #56766..
I added a sample Impress file to bug bug #56766.
I just hope the bug fix comes soon.

Is there somewhere a list of bug fixes in a release?
Comment 5 Rainer Bielefeld Retired 2012-11-26 17:55:16 UTC
I see a very obvious gradient problem, what might be similar to "Bug 57238 - Gradients in calc graphs elements not shown when inserted in an impress file and slideshow is started"

I wonder whethe this one is a DUP or at least related to "Bug 35680 - FORMATTING: Gradient rendered wrongly in presentation mode when groupedBug 35680 - FORMATTING: Gradient rendered wrongly in presentation mode when grouped
Comment 6 Rainer Bielefeld Retired 2012-11-26 18:02:40 UTC
Already reproducible with LibO 3.4.5 (may be more early), worked fine with OOo 3.1.1, so at least regression concerning early OOo. But AOOo 3.4.1 suffers from the same problem, so I assume "inherited from OOo".
Comment 7 ign_christian 2013-06-13 04:40:30 UTC
Not reproducible using attached files in Bug 56766 (LO 4.0.4.1 - Win7 32bit).
Perhaps it's been fixed