Download it now!
Bug 56764 - FORMATTING: Calc chart goes back to default format when changeing data range
Summary: FORMATTING: Calc chart goes back to default format when changeing data range
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-05 10:14 UTC by bugquestcontri
Modified: 2015-04-21 11:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot shows the original chart with customized columns on the right side and on the left hand side the chart with the default format. this chart should have the same column format at slide on right hand side (25.02 KB, image/gif)
2012-11-05 10:14 UTC, bugquestcontri
Details
Minimum test case for data range bug (15.88 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2012-11-26 15:58 UTC, Michael Crouch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2012-11-05 10:14:19 UTC
Created attachment 69553 [details]
screen shot shows the original chart with customized columns on the right side and on the left hand side the chart with the default format. this chart should have the same column format at slide on right hand side

Problem description: 
1 -Created chart in Calc and customized format of stacked columns with gradient filling
2 - Copied and pasted chart
3 - Edited chart and changed data range
4 - Columns in chart went back to default format

Steps to reproduce:
1 -Create chart in Calc and customize format of stacked columns with gradient filling
2 - Copy and paste chart
3 - Edit chart and change data range
4 - Columns in chart go back to default format


Current behavior:

Column format goes back to default format when changing data range


Expected behavior:

Column format stays as it is when changing data range


Platform (if different from the browser): XP / SP3  LibO 3.5.7
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

I can be contacted
Comment 1 Michael Crouch 2012-11-12 18:07:53 UTC
I can confirm this bug in Version 3.6.3.2 (Build ID: 58f22d5).  When I update the data range in an XY scatter plot, it changes the line colors, symbols, primary vs. secondary axis, etc.
Comment 2 Michael Crouch 2012-11-12 18:10:54 UTC
*** Bug 55973 has been marked as a duplicate of this bug. ***
Comment 3 Michael Crouch 2012-11-26 15:58:50 UTC
Created attachment 70598 [details]
Minimum test case for data range bug
Comment 4 Michael Crouch 2012-11-26 16:04:58 UTC
I submitted an attachment with a minimum test case for this bug.

Instructions to reproduce:
1) Double-click on chart
2) Right-click, then click "Data Ranges"
3) The data range should read "$Sheet1.$A$1:$B$7,$Sheet1.$E$1:$E$7".  Change the first "7" to "12".
4) Wait until the preview updates.
5) Change the second "7" to "12".  The second series reappears, but with its formatting reset.  (It changes from green to red).
6) Click "OK".

As you can see, changing the data range of this graph resets all of the formatting choices in the second series.

This bug does *not* happen if you make both changes quickly enough (by typing quickly, or using copy-paste to overwrite both at once).  It seems to only happen when previewing, and only when the data range contains multiple cell ranges.
Comment 5 bugquestcontri 2013-11-24 15:26:46 UTC
Thanks for looking into this matter and identifying the "needed speed".
Comment 6 QA Administrators 2015-04-19 03:22:45 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 7 bugquestcontri 2015-04-21 11:08:42 UTC
I made a test in 4.3.6.1 and the bug does not show up anymore.

Thus changed status to RESOLVED and WORKSFORME