Bug Hunting Session
Bug 56768 - FILESAVE: xls file with pivot table when saved with password pivot table will not work when re-open
Summary: FILESAVE: xls file with pivot table when saved with password pivot table will...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Pivot-Table-XLS
  Show dependency treegraph
 
Reported: 2012-11-05 11:38 UTC by lokeck65
Modified: 2019-04-18 05:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lokeck65 2012-11-05 11:38:22 UTC
Problem description: 
spreadsheet file with pivot table when saved in Microsoft Excel 97/2000/xp/2003 (.xls)with password, the pivot table will not work when re-open

Steps to reproduce:
1. create a simple spreadsheet with a pivot table either in MS Excel or LO Calc
2. save it as file type "Microsoft Excel 97/2000/xp/2003 (.xls) with the save with password option enable.
3. key in a password for the file and close it
4. re-open the file 

Current behavior:
Pivot table in .xls with password protection will not work upon re-open the file

Expected behavior:
Pivot table in .xls with password protection should work when re-open 

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4
Comment 1 billhook 2012-11-06 01:37:52 UTC
Confirmed on LO 3.6.3.1 Vista 32bit. I created the original spreadsheet in LO Calc.

To clarify the pivot table "not working"; after reopening the .xls, the pivot table sheet has only 2 cells on it:

A1 contains the text "Filter"
A3 contains the text "(empty)"

It should contain an actual pivot table.

The problem seems to be the specific combination of xls and password protection. I tried other combinations and could not reproduce the problem:

Microsoft Excel 97/2000/xp/2003 (.xls); password -> Doesn't work
Microsoft Excel 97/2000/xp/2003 (.xls); no password -> Works
ODF Spreadsheet (.ods); password -> Works
Excel 2007/2010 XML; no password -> Works
Comment 2 QA Administrators 2015-01-05 17:51:16 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-01-26 15:42:12 UTC
Could not repro.

I used an example pivot table from here: http://www.ahuka.com/?page_id=911
In LibO, I did Tools - Protect document - Sheet. Saved as .xls. Nothing was lost.

Closing as WFM.

Win 8.1 32-bit

LibreOffice Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36