Bug Hunting Session
Bug 56846 - Current Cell Should Turn White When Border Is Bold
Summary: Current Cell Should Turn White When Border Is Bold
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 36825 (view as bug list)
Depends on:
Blocks: Cell-Selection
  Show dependency treegraph
 
Reported: 2012-11-07 17:35 UTC by Dave Richards
Modified: 2017-09-03 07:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Richards 2012-11-07 17:35:56 UTC
We got word from our users that they could not see which was the currently selected cell.  It turned out they had made the borders bold and when they click into the cell the only visual cue is the small box that appears in the corner.  Tested with Excel 2010 and that software makes the cell turn white if the border is black/bold.  This small UI change makes it much easier for users to figure out cursor location.  Requesting this feature be implemented.

Similar to issue 52100, but not quite the same.
Comment 1 Emir Sarı (away) 2012-12-04 10:16:53 UTC
This seems like a valid enhancement request, so setting status to: "NEW". 

Could be considered as a bug also, though.
Comment 2 Roeland 2016-09-15 18:47:42 UTC
*** Bug 36825 has been marked as a duplicate of this bug. ***
Comment 3 Thomas Lendo 2017-09-02 22:41:22 UTC
Is this an enhancement request? Seems to be a bug for me due to missing contrast.

Similar to Bug 87289 "UI: single cell selection frame is invisible in black documents".
Comment 4 Heiko Tietze 2017-09-03 07:32:37 UTC
Cell background is white by default; and with the boldness of the selection it's easily to distinguish from the normal grid. Range selection is highlighted in light blue where the actual selection(s) is/are drawn in the background color (white). That perfectly works for me.  

Of course, everything breaks with black cell background or bold cell borders as reported in bug 36825. It's not a good solution to always highlight focused cells as done with ranges. 

My take is to keep the current status.

Remark: Default colors can be adjusted under Tools > Options > Application Colors.