Bug Hunting Session
Bug 57000 - UI: No context menu available in Input Line (formula bar)
Summary: UI: No context menu available in Input Line (formula bar)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Maxim Monastirsky
URL:
Whiteboard: BSA target:6.1.0
Keywords: needsDevEval, topicUI
: 46870 68500 77645 80461 107105 (view as bug list)
Depends on:
Blocks: Context-Menu Calc-UX Calc-Formula-Bar
  Show dependency treegraph
 
Reported: 2012-11-12 03:33 UTC by DarwinSurvivor
Modified: 2018-04-26 20:31 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DarwinSurvivor 2012-11-12 03:33:21 UTC
Problem description: 

Steps to reproduce:
1. Open a spreadsheet (either new or existing)
2. Right click in the formula bar

Current behavior:
Nothing Happens

Expected behavior:
A context menu should appear with copy/paste/etc available

Platform (if different from the browser):
ArchLinux - current as of 2012-11-11
Ubuntu - 12.10
Comment 1 Rainer Bielefeld Retired 2012-11-12 07:59:03 UTC
[Reproducible] with "LibreOffice 3.6.3.2" German UI/ German Locale [Build-ID: 58f22d5] on German WIN7 Home Premium (64bit) 

Inherited from OOo, I never saw that working back until OOo 1.1.5

Not a big thing, but at least inconsistent, in WRITER the text calculation formula bar has that context menu function.

@Ivan:
One for you?
Comment 2 Joel Madero 2015-05-02 15:41:13 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-06-20 12:14:47 UTC
Still true.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 4 Winfried Donkers (retired) 2015-07-21 09:03:19 UTC
*** Bug 68500 has been marked as a duplicate of this bug. ***
Comment 5 Winfried Donkers (retired) 2015-07-21 09:03:59 UTC
*** Bug 46870 has been marked as a duplicate of this bug. ***
Comment 6 Yousuf Philips (jay) (retired) 2015-08-03 16:55:48 UTC
*** Bug 80461 has been marked as a duplicate of this bug. ***
Comment 7 Robinson Tryon (qubit) 2015-12-14 06:09:59 UTC Comment hidden (obsolete)
Comment 8 Ettore Atalan 2016-02-22 17:57:43 UTC
Still no Input Line context menu in LibreOffice Calc 5.1.0.3.
Comment 9 Rpnpif 2016-02-22 18:16:26 UTC
The policy of this bugzilla request the older release of the issue.
Comment 10 Yousuf Philips (jay) (retired) 2017-04-18 13:47:56 UTC
*** Bug 107105 has been marked as a duplicate of this bug. ***
Comment 11 V Stuart Foote 2017-04-18 14:40:09 UTC
The Formula Input line field already responds to OS clipboard and the main menu Edit -> Select, Cut, Copy, Paste all connect to the control.

So, would expect should be able create the context menu controls which would be helpful.
Comment 12 Maxim Monastirsky 2018-04-17 13:08:18 UTC
*** Bug 77645 has been marked as a duplicate of this bug. ***
Comment 13 Commit Notification 2018-04-26 20:15:20 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9d9076cb00c474ba7f13d458f1e280e31f5d4bac

tdf#57000 Add a context menu to the formula bar input field

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.