Bug 57085 - FILEOPEN: Some doc files takes minutes to be opened (problem seems to be picture-related)
Summary: FILEOPEN: Some doc files takes minutes to be opened (problem seems to be pict...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: antistress
QA Contact:
URL:
Whiteboard: BSA NoRepro:4.1.3.2:Ubuntu13.10
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-13 18:45 UTC by antistress
Modified: 2013-12-12 11:37 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Test DOC file to experiment the bug (262.83 KB, application/msword)
2012-11-13 18:45 UTC, antistress
Details
Screenshot with LibreOffice 3.5.4.2 on Debian Sid 64 bits (28.95 KB, image/png)
2013-04-25 22:41 UTC, antistress
Details

Note You need to log in before you can comment on or make changes to this bug.
Description antistress 2012-11-13 18:45:03 UTC
Created attachment 70021 [details]
Test DOC file to experiment the bug

Problem description: 
With a last generation CPU (Core i3-3225 dual core Ivy Bridge @ 3.3 GHz with Hyperthreading), SSD and 8 GB RAM, some DOC files takes minutes to be opened.

Steps to reproduce:
1. Open attached DOC file

Removing the picture within the DOC file seems to avoid the delay.
Therefore the problem seems to be related with the way LibO opens DOC files with pictures

Current behavior:
Wait minutes before the document to be opened

Expected behavior:
Much quicker file opening is expecting !

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0 Iceweasel/16.0.2

Debian Sid 64 bits with GNOME
LibreOffice 3.5.4.2 
Version ID : 350m1(Build:2)
Comment 1 billhook 2012-11-14 22:44:23 UTC
It opens instantly on LO 3.6.3.2 on Windows Vista.
Comment 2 Jean-François Fortin Tam 2012-11-19 17:08:09 UTC
For what it's worth, on Fedora 18 64-bits with LibreOffice 3.6.3.2, it takes around 12-15 seconds to load and display the file on a conventional hard drive and Intel Atom D525 CPU.
Comment 3 A (Andy) 2013-04-20 09:36:18 UTC
not reproducible with LO 4.0.2.2 (Win7 Home, 64bit, i5), it takes around 7 seconds to open the file

Does this issue still persist for you with the latest release of LO?  If not, then I would propose to close this bug report.
Comment 4 antistress 2013-04-25 22:41:39 UTC
Created attachment 78489 [details]
Screenshot with LibreOffice 3.5.4.2 on Debian Sid 64 bits

Unfortunately it seems that this bug is not solved with LibreOffice v4 (Debian with Libreoffice experimental package) although it has evolved : if the file doesn't take too long to be opened, the picture is not displayed at all !

On LibreOffice 3.5.4.2 (Debian Sid) the file takes a long time to be opened and the picture is displayed (but its size and position are noot good) : see screenshot attached
Comment 5 retired 2013-12-10 09:47:41 UTC
on Ubuntu 13.10 LO 4.1.3.2 LO is slow to open this file but it opens fine.

WORKSFORME.

If this issue persists with LO 4.1.3.2 or above please re-open this bug.
Comment 6 antistress 2013-12-11 20:54:10 UTC
(In reply to comment #5)
> on Ubuntu 13.10 LO 4.1.3.2 LO is slow to open this file but it opens fine.
> 
> WORKSFORME.
> 
> If this issue persists with LO 4.1.3.2 or above please re-open this bug.

Please read my above comment (#4) : Indeed with newer versions the file don't take too much time to be opened BUT the picture (which I suspect to be related to that bug) is not displayed anymore !

I'm using version 4.1.3.2 on Debian amd64 Sid at present time
Comment 7 retired 2013-12-12 10:47:00 UTC
I suggest to keep the focus, please open a new separate bug. This bug here was about long opening times. That is no longer an issue. And there's the rule: one bug per problem.
Comment 8 antistress 2013-12-12 11:37:02 UTC
I can't say if the bug is fixed since the picture which may cause the delay is not displayed anymore but I let you decide