Bug 57171 - FILESAVE: Comments not saved when impress file saved as pptx
Summary: FILESAVE: Comments not saved when impress file saved as pptx
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 66842 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-15 23:44 UTC by Russell Almond
Modified: 2015-02-12 11:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Russell Almond 2012-11-15 23:44:53 UTC
Problem description: 
I opened and added some comments to a Powerpoint file sent by one of my students.  And saved the result as powerpoints.  The comments are now missing.


Steps to reproduce:
1. .... Open an existing Powerpoint document in PPTX format.
2. ....  Add a comment to one of the slides.
3. .... Save the document as a powerpoint.
4. .... Close Libre Office and reopen the document.

Current behavior:
Comments are not saved with the document and are not present when the document is opened.

Expected behavior:
Comments would be saved.

Platform (if different from the browser): 
Ubuntu 12.04
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 Rob Snelders 2012-11-19 22:34:21 UTC
Thank you for submitting this bug.

Confirmed the bug with LO 3.6.0.1 and LO 3.7.0.0-alpha on Ubuntu 12.04 x86_64.

When I look in the file the comment is saved. I am however not sure if it is saved correctly. At least it doesn't show up when loading the file again.
Comment 2 Rob Snelders 2012-11-19 22:34:47 UTC
forgot the new-status
Comment 3 Thorsten Behrens (CIB) 2013-02-21 12:24:47 UTC
To avoid duplication of work - in-progress fix at https://gerrit.libreoffice.org/#/c/2048/
Comment 4 ign_christian 2013-07-13 03:48:56 UTC
*** Bug 66842 has been marked as a duplicate of this bug. ***
Comment 5 Matthew Francis 2015-02-12 07:03:26 UTC
Already fixed by 4.4.0.3, presumably by the comment mentioned in comment 3

-> RESOLVED FIXED
Comment 6 bugquestcontri 2015-02-12 11:01:21 UTC
Thanks to whoever fixed the bug! I am looking forward to the 4.4 version