Bug Hunting Session
Bug 57799 - Useful Error Message required if wrong password for ftp login has been used
Summary: Useful Error Message required if wrong password for ftp login has been used
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Error-Messages
  Show dependency treegraph
 
Reported: 2012-12-02 10:03 UTC by Rainer Bielefeld Retired
Modified: 2017-08-25 11:22 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Error message as it works in the current implementation (16.13 KB, image/png)
2017-08-25 09:13 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-12-02 10:03:17 UTC
This is a spin off from "57765 - FILEOPEN via FTP from Server causes General Error"

Steps how to reproduce:
Proceed as you see in original report for a.m. Bug, but type a wrong password in Step 5
Expected: Error 530: Login incorrect
Actual: Password dialog reappears without any warning or useful message
Comment 1 Joel Madero 2014-05-28 02:17:17 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.0.0.alpha0+ Build ID: 84862db95a5e22b9ef89baa2a8a5deeffefbdef6
Date:   Thu Apr 24 21:43:16 2014 +0300
Platform: Ubuntu Linux 14.04 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
Low - pretty obvious what's going on, most users would assume wrong password (or username). None the less valid request

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Muhammet Kara 2017-03-01 13:26:08 UTC
Some code pointers for the interested ones:

If you open the mentioned dialog, you will see the string "Wrong user name and password for" on the password prompt dialog.

Find the ui file which includes that string by using grep:
git grep "Wrong user name and password for"

You will see that the string is in the file "uui/uiconfig/ui/logindialog.ui"

Then grep for "logindialog.ui" to find the source file which includes this ui file:
git grep logindialog.ui

You will find out that the ui file is included in the source file "uui/source/logindlg.cxx".

Now you will need to read the logindlg.cxx file (and the corresponding .hxx file) to understand its logic, and move from there. You can also open the logindialog.ui file with "glade" to see it on the screen and be able to edit it visually.
Comment 3 Aleksas Pantechovskis 2017-03-02 06:58:53 UTC
Is this bug still active? As far as I can the dialog has message about wrong username/password when the password is wrong.
http://imgur.com/a/YNg59

Or am I reproducing it wrong? I clicked the Servers... button, added FTP and then clicked it in the Places panel.
Comment 4 jani 2017-05-14 07:42:38 UTC Comment hidden (obsolete)
Comment 5 Aleksas Pantechovskis 2017-05-14 07:49:03 UTC
(In reply to jani from comment #4)
> A polite ping, still working on this bug

No, as far as I can see I couldn't reproduce the issue.
Comment 6 Shinnok 2017-08-25 08:58:54 UTC
(In reply to Aleksas Pantechovskis from comment #5)
> (In reply to jani from comment #4)
> > A polite ping, still working on this bug
> 
> No, as far as I can see I couldn't reproduce the issue.

I can confirm too that I get the proper message with the File -> Save Remote -> FTP protocol, on macOS in my case. The only other case where this would apply is via the save as dialog, but then the platform specific protocol handler will take over (like fish for e.g.).

I'd like to close this bug report with UNCONFIRMED, Xisco can you briefly ensure, from a QA standpoint, that I took the proper steps in closing a really old report like this?
Comment 7 Heiko Tietze 2017-08-25 09:09:49 UTC
(In reply to admin from comment #6)
> I'd like to close this bug report with UNCONFIRMED, Xisco can you briefly
> ensure, from a QA standpoint, that I took the proper steps in closing a
> really old report like this?

I think we can safely set this ticket to resolved.

(removing keywords difficultyBeginner, easyHack, skillCpp, topicUI)
Comment 8 Heiko Tietze 2017-08-25 09:13:20 UTC
Created attachment 135785 [details]
Error message as it works in the current implementation
Comment 9 Cor Nouws 2017-08-25 11:22:10 UTC
thanks for the extra testwork, 'admin' ;) and Aleksas!