Bug 58026 - Localization problem for GoogleDocs extension
Summary: Localization problem for GoogleDocs extension
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Andras Timar
QA Contact:
URL:
Whiteboard: target:4.1.0 target:4.0.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-08 17:58 UTC by Julien Nabet
Modified: 2013-01-15 11:51 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2012-12-08 17:58:28 UTC
Problem description: 
With Google docs extension 2a64b8e6f185a7f6c19d00fb8bb4cf64-gdocs_3.0.1_modified.oxt, and with English localization, one of the option isn't translated.

Steps to reproduce:
1. Open Writer
2. Select Menu File/Google Docs and Zoho 

Current behavior:
One of the option is "Exportar a Zoho"

Expected behavior:
It should be "Export to Zoho"
Comment 1 Julien Nabet 2012-12-08 18:07:29 UTC
In fact, the problem is just here on Addon.xcu:
88 <prop oor:name="Title" oor:type="xs:string">
89   <value xml:lang="en">Export to Zoho</value>
90   <value xml:lang="pl">Eksport do Zoho</value>
91   <value xml:lang="de">Export zu Zoho</value>
92   <value xml:lang="en">Exportar a Zoho</value>
93   <value xml:lang="it">Esporta in Zoho</value>
94   <value xml:lang="cs">Exportovat do Zoho</value>

Obviously, there's just a typo : "en" instead of "es" line 92.

the oxt is 2a64b8e6f185a7f6c19d00fb8bb4cf64-gdocs_3.0.1_modified.oxt
I found a contact on description.xml but since it's a modified version, I don't know how to "ping".

David: any idea about this?
Comment 2 Joel Madero 2013-01-08 17:45:00 UTC
Julien: On an English install (US), I see Export To Zoho correctly. Am I missing something?
Comment 3 Jorendc 2013-01-08 18:17:00 UTC
Hi Julien,

Can you provide us the link to download the extension?
I found this http://extensions.libreoffice.org/extension-center/openoffice.org2googledocs-export-import-to-google-docs-zoho-webdav

But when I compare the file name (.oxt), it's "ooo2gd_3.0.0.oxt", and not something like 'gdocs_' etc.

Until response -> status to NEEDINFO
Thanks!
Comment 4 Julien Nabet 2013-01-08 19:17:22 UTC
There's still the problem on master sources updated today.

In fact, I build the master sources and these use this link:
http://dev-www.libreoffice.org/src/2a64b8e6f185a7f6c19d00fb8bb4cf64-gdocs_3.0.1_modified.oxt

I unzipped the oxt and just noticed this inside description.xml
<version value="3.0.1"/><!-- version number bumped to 3.0.1 because of passive registration -->
Comment 5 Jorendc 2013-01-08 19:21:31 UTC
I can reproduce using LibreOffice 3.6.4.3; Ubuntu 12.10;
Comment 6 Julien Nabet 2013-01-08 19:28:35 UTC
my autogen.lastrun contains "--enable-ext-google-docs"
Comment 7 Caolán McNamara 2013-01-09 13:16:49 UTC
looking back over history (git log --follow -Sgdocs configure.ac) , it seems that Andras and Kami are who typically update the gdoc extension when there's a new version and upload modified versions if additional fixes are required. e.g. http://cgit.freedesktop.org/libreoffice/core/commit/?id=f2d97ff3bae3993d6c1cae911fe53710fba19d0f

so lets assign to Andras to poke ooo2gd upstream with a fix, and if he thinks we need to, upload a new modified version.
Comment 8 Not Assigned 2013-01-15 10:28:17 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f813d9f692d10f6d151c27617c2c5a36fac8c19

fdo#58026 typo fix in Addons.xcu of Google Docs extension



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Not Assigned 2013-01-15 11:51:57 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=371983fb8252356b36f8d424dbceba318c14609d&h=libreoffice-4-0

fdo#58026 typo fix in Addons.xcu of Google Docs extension


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.