Bug 58079 - FILEOPEN: Table shrinked in Word 2003 XML document
Summary: FILEOPEN: Table shrinked in Word 2003 XML document
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MSO-XML2003
  Show dependency treegraph
 
Reported: 2012-12-10 12:56 UTC by Rusbearing
Modified: 2019-08-31 17:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example of such file (251.13 KB, text/xml)
2012-12-10 12:56 UTC, Rusbearing
Details
Snapshot Of two windows - 2010 and Libo (269.46 KB, image/jpeg)
2012-12-18 22:10 UTC, ydutrieux
Details
doc (xml?) file (195.23 KB, text/xml)
2013-02-21 06:27 UTC, Rusbearing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rusbearing 2012-12-10 12:56:29 UTC
Created attachment 71264 [details]
example of such file

If I open attached file with MS Word 2003 I see a table in it. If I open it with LibreOffice I don't see the table, it is corrupted.

If I change extension to .xml and open it with OpenOffice 3.3 (!) I also see the table.

Probably, this file have bad extension and should be .xml, but not .doc. Anyway MS Word open it without problems.

This table should be placed between "1.   Ассортимент, объем и цена поставляемой продукции: " and "Итого :  4262.82 RUB"
Comment 1 ydutrieux 2012-12-18 22:10:07 UTC
Created attachment 71765 [details]
Snapshot Of two windows - 2010 and Libo

Hi,

Reproduced on Libo Version 4.0.0.0.beta1+ (Build ID: 6d4a55bf38a1c470c49f904dbbddf94eb2f6154)

Yes the original file should be .xml file.
it's probably a 2003xml file.

In Libo, we see the table but it's completely shrinked.
Comment 2 Jorendc 2012-12-27 23:02:42 UTC
I can confirm that there is a shrinked table in LibreOffice (4.1.0.0.alpha0+ (Build ID: 699132c269a6c6d9e815fc582e2e6a106e46923)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2012-12-27_01:05:51)

Opened it with 'Word for Mac 2011', and there is indeed a correct table in the document. I can confirm behavior of Attachment 71765 [details] 'Snapshot Of two windows - 2010 and Libo'.

Thanks for reporting!

@ydutrieux: when you can reproduce it, please set bug status to 'NEW'. Thanks in advance.

kind regards,
Joren
Comment 3 Jorendc 2013-01-02 20:02:33 UTC
I forgot to set it as 'NEW' by myself. -> bug status -> NEW ;-)
Comment 4 Rusbearing 2013-02-21 06:27:45 UTC
Created attachment 75226 [details]
doc (xml?) file

This file can be opened with MS Word 2007 and can not be opened with LibreOffice
Comment 5 Jorendc 2013-02-21 08:31:02 UTC
Thanks for an additional test file. Please, the LibreOffice version of this bug is the oldest LibreOffice version you can reproduce this problem. Therefore I mark it again as '4.0.0.0 beta1'.

Kind regards,
Joren
Comment 6 QA Administrators 2015-04-19 03:21:35 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2015-06-16 16:08:27 UTC
Table still crunched.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 80ec99db4325a439a8a3f1d420d0a80f8bf9c439
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-16_00:00:20
Locale: fi-FI (fi_FI)
Comment 8 QA Administrators 2016-09-20 10:02:14 UTC Comment hidden (obsolete)
Comment 9 eisa01 2019-08-31 17:27:13 UTC
Still present

Version: 6.4.0.0.alpha0+
Build ID: 1c539c548b662104431e283aa4a62cb81174380b
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2019-08-28_05:21:39
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded