Bug 58136 - Add tooltips to the buttons at the bottom of the Option Dialogs and improve help about these buttons
Summary: Add tooltips to the buttons at the bottom of the Option Dialogs and improve h...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: sdc.blanco
URL:
Whiteboard: BSA target:7.2.0
Keywords:
Depends on:
Blocks: Help-Changes-Features
  Show dependency treegraph
 
Reported: 2012-12-11 11:51 UTC by Harald Koester
Modified: 2021-03-09 18:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2012-12-11 11:51:23 UTC
Problem description: 

To my opinion not all aspects mentioned in bug 39452 are resolved. The comment list of that bug is quite long. So I tried to disentangle this a bit with new bug reports. This is the fifth of them.

The user help according the option dialogs should be checked, improved and corrected:

(1) In the help text (F1) of the option dialogs the buttons OK, Cancel, Revert and Default (only in few dialogs, e. g. dialog “LibreOffice Writer > Basic Fonts (Western)”) are not explained. Especially the buttons Revert and Default need explanations, whatever the functions of these buttons are.

(2) If the option “Extended Tips” is enabled, tips are displayed if you rest the cursor on the Revert and Default button. This tips should be checked if they are correct and if necessary corrected. Also the translations of this tips should be checked, e.g. currently the content of the German translation is different to the English tip.

(3) Also the manuals should be checked if they explain the use of the buttons Revert and Default in option dialogs correctly. E.g. the label change from Back to Revert has not been considered yet.

              
Operating System: Windows 7
Comment 1 Harald Koester 2012-12-11 14:09:47 UTC
See also bug 58132, bug 58133, bug 58134, bug 58135.
Comment 2 Jorendc 2013-01-27 20:13:57 UTC
Regarding all 'See Also' bugs I can confirm this.

Don't know how to mark this priority... So I leave it as 'medium normal' for now.

Thanks for reporting!
Joren
Comment 3 QA Administrators 2015-02-19 15:41:14 UTC Comment hidden (obsolete)
Comment 4 Harald Koester 2015-03-03 10:35:59 UTC
Bug still exists in version 4.4.0.3. 

Regarding (1): The button 'Revert' has changed it name, it's now 'Reset'.
Comment 5 tommy27 2016-04-16 07:28:19 UTC Comment hidden (obsolete)
Comment 6 Harald Koester 2017-04-06 11:00:35 UTC
Bug still exists in version 5.3.1 with Win7. 

Bug already exists in version 3.3.0. Hence inherited from OOo.
Comment 7 Harald Koester 2020-04-29 22:05:24 UTC
Checked with version 6.4.2 (Win10):

Respective (1): Buttons Reset, OK, Cancel and Default are now explainded in the help page Options. A new button Apply has been introduced. This button is not explained in the Help.

Respective (2): Tips of the buttons Reset, Apply, OK and Cancel are no longer displayed if Extended Tips are enabled. It would be good, if these tips would be introduced again. Especially because if you click Help these buttons are not explained in the opened help page and you have to change to the help page Options.

Respective (3): The current Getting Started Guide describes the version 6.0 and is not up to date respective the buttons in the Options dialogue.
Comment 8 sdc.blanco 2021-02-27 17:25:45 UTC
(In reply to Harald Koester from comment #7)
> Respective (3): The current Getting Started Guide describes the version 6.0
> and is not up to date respective the buttons in the Options dialogue.
All comments and suggestions about manuals should be sent to: documentation@global.libreoffice.org 

That issue is not addressed here.

> Respective (1): A new button Apply has been introduced. This button
> is not explained in the Help.
Is there a specific page (URL) you have in mind?

> Respective (2): Tooltips for the buttons Reset, Apply, OK and Cancel 
Ok.
Comment 9 sdc.blanco 2021-02-27 22:11:25 UTC
(In reply to sdc.blanco from comment #8)
> > Respective (1): A new button Apply has been introduced. This button
> > is not explained in the Help.
Addressed in:
https://git.libreoffice.org/help/commit/5bbeaa6e676b2ce465f8b05c09bfa483aef2c40e

Should appear in 7.1 onward...

https://help.libreoffice.org/7.1/en-US/text/shared/optionen/01000000.html


> > Respective (2): Tooltips for the buttons Reset, Apply, OK and Cancel 
https://gerrit.libreoffice.org/c/core/+/111694
Comment 10 sdc.blanco 2021-03-04 22:52:52 UTC
(In reply to Harald Koester from comment #7)
>A new button Apply has been introduced. 
Unlike "Reset", which only applies to the visible tab, "Apply" saves modifications on all tabs, without the possibility to "Reset".  How to express compactly?

Proposed tooltip for "Apply" 

   Save all modifications without closing dialog. Cannot be reverted.


Comments?
Comment 11 Commit Notification 2021-03-09 18:07:03 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1ee086906bd64bd5be3f3af06d2c08da680aaef1

tdf#58136 add tooltips to Options dialog buttons

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 sdc.blanco 2021-03-09 18:09:09 UTC
Ok. Tooltips should be back in Reset, Apply, OK and Cancel for the Options dialog and help pages are up-to-date, so closing as FIXED.