Bug Hunting Session
Bug 58168 (UnspecificHelp) - [META] LOCALHELP reached via Help button should be context related
Summary: [META] LOCALHELP reached via Help button should be context related
Status: RESOLVED DUPLICATE of bug 115254
Alias: UnspecificHelp
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 63548 55212 58170 58241 60872
Blocks: Help
  Show dependency treegraph
 
Reported: 2012-12-12 05:38 UTC by Rainer Bielefeld Retired
Modified: 2018-12-30 06:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-12-12 05:38:50 UTC
This is the tracking Bug for all bugs related to the problem that clicking the Help button leads to unspecific help.

Since we started LibO the context sensitivity of Help has been lost more and more. Users can expect that clicking the Help button in a dialog will lead them exactly the the help chapter for this dialog, not to the Help start page.
Comment 1 Rainer Bielefeld Retired 2012-12-12 05:40:25 UTC
I add "Bug 55212 - UI: Context sensitive Help <f1> and Help Button missing in Conditional Formatting dialogs "
Comment 2 Rainer Bielefeld Retired 2012-12-12 06:02:11 UTC
I add "Bug 58170 - Help button in menu 'Tools - Options - Load/Save - General' does not reach context related LOCALHELP"
Comment 3 Rainer Bielefeld Retired 2012-12-13 12:48:40 UTC
I add "Bug 58241 - Help button in menu 'Tools - Options - Language Settings - Languages' does not reach context related LOCALHELP"
Comment 4 Rainer Bielefeld Retired 2013-02-15 05:48:00 UTC
I add "Bug 60872 - Help button in menu 'Tools - Options - LibO - Appearance' does not reach context related LOCALHELP"
Comment 5 Rainer Bielefeld Retired 2013-02-15 06:38:31 UTC
I add: "Bug 60873 - UI: Context sensitive Help <f1> and Help Button missing in 'Tools -> Protect Document -> Sheet' dialog "
and
"Bug 60874 - UI: Context sensitive Help <f1> and Help Button missing in 'Tools -> Protect Document -> Document' dialog"
Comment 6 Kumāra 2013-05-18 06:33:07 UTC
Adding Andras Timar (documentation in terms of fixing bugs in localhelp expert) to cc.

The bug lowers the public perception of LibO's competence.
Comment 7 Olivier Hallot 2018-07-28 11:49:35 UTC
This bug affects many help pages and is connected to the *.ui (Glade edited) dialogs, which is being solved by bug#115254.

*** This bug has been marked as a duplicate of bug 115254 ***