Bug Hunting Session
Bug 58252 - EDITING: Wrong external editing tools for SVG
Summary: EDITING: Wrong external editing tools for SVG
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-13 16:24 UTC by Fernand
Modified: 2015-12-18 12:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test file with svg image (207.66 KB, application/vnd.oasis.opendocument.text)
2015-02-21 11:04 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fernand 2012-12-13 16:24:19 UTC
Problem description: 
When using the External Tool for editing a SVG image, the application is not a SVG editing tool like InkScape but the tool to edit the also embeded bitmap counterpart (png)for the SVG image.
Steps to reproduce:

1. make in Windows InkScape the standard editor for SVG
2. put a SVG in a writer doc
3. us the External Tool for editing the SVG image
4. the SVG opens in a external editor as a bitmap not as a vector 

Current behavior:

Expected behavior:
opening the SVG as VECTOR graphic with the in Window choosen SVG Editor
              
Operating System: Windows XP
Comment 1 Marco Menardi 2013-01-13 11:33:30 UTC
I've tested with Beta2 and RC1, Inkscape, Win XP.
The svg is associated to Inkscape, in fact if I double click to a svg file on the desktop, Inkscape is run.
If I use the External tool for ediging from Writer (Right click on the image, Edit with external tool), the "Windows Image Viewer" (I've the Italian version of XP, just a "on the fly" translation) is used with a .tmp.jpg made from that svg.
If my file is a.svg and from command prompt I enter
C.> a.svg
Inkscape is run.
Comment 2 QA Administrators 2015-02-19 15:50:26 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 3 Jean-Baptiste Faure 2015-02-21 11:03:43 UTC
Not reproducible for me with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64

I installed Inkscape and made it the default software to open svg file. Then a created a new text document in writer and inserted an svg file (the famous tiger), saved the document and reloaded it. Then right click on the graphic and choose Edit with external tool. And the graphics is opened in Inkscape.

Closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF
Comment 4 Jean-Baptiste Faure 2015-02-21 11:04:32 UTC
Created attachment 113574 [details]
test file with svg image
Comment 5 Regina Henschel 2015-12-18 12:45:53 UTC
Not reproducible with Windows 7 and Version: 5.1.0.1.0+
Build ID: 51a1b41ab4a840544e5454d1d4234b443edd5466
Threads 4; Ver: Windows 6.1; Render: default; 

It opens in that application that is associated with file extension ".svg" in Windows.