Bug 58277 - EDITING: LO writer crashes when attempting to delete all comments
Summary: EDITING: LO writer crashes when attempting to delete all comments
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
3.5.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Caolán McNamara
Whiteboard: BSA target:4.4.0
Depends on:
Reported: 2012-12-14 04:29 UTC by konsultor
Modified: 2014-10-03 16:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

the doc that crashes LO on "Delete all Comments" (103.00 KB, application/msword)
2012-12-17 06:11 UTC, konsultor
bt + console logs on 4.0 branch (14.22 KB, text/plain)
2012-12-27 06:45 UTC, Julien Nabet
Crashlog Mac OS X (61.96 KB, text/plain)
2012-12-30 13:06 UTC, Jorendc

Note You need to log in before you can comment on or make changes to this bug.
Description konsultor 2012-12-14 04:29:27 UTC
Problem description: 
LibreOffice crashes with all open documents lost (reverts to last back up) when attempting to delete all comments

Steps to reproduce:
1. in file created with MS Word, editing text that contains many tracked changes;  with Edit/Changes/Record 'on' and E/C/Show 'off'
2. Go to a comment that's associated with an entry in a table.
3. In a comment (one of many on the page created in MS Word), click on the menu arrow to reveal actions
4. Click on 'Delete All Comments'

Current behavior:
LO and all documents disappear.  soffice no longer is listed by System Monitor.

Expected behavior:
Comments would be deleted.

Repeated a second time when started with
strace -o /tmp/strace.log -f -tt -s 512 lowriter (from openSuse Forum)
strace attached

Running on 4-core Intel processor.  64-bit openSuse 12.2 with KDE

Have not tried to delete comments in other versions of LO.
Operating System: Linux (Other)
Comment 1 Jorendc 2012-12-16 10:34:42 UTC
Thanks for reporting.

I can't reproduce it on my Mac OS X 10.8.2, with a .docx-document I created in Word for Mac 2011 (see attachment). How big was your document? I just created 1 page of text and a table with a lot of comments. Is it possible to attach it (or does it contain private information?)?

Tested with LO and LO Version (Build-id: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2012-12-05_22:13:37; With Dutch helppack
Comment 2 konsultor 2012-12-17 06:11:22 UTC
Created attachment 71628 [details]
the doc that crashes LO on "Delete all Comments"

Tried again to delete all comments just now (17 Dec 2012) and it crashed again.
Comment 3 Julien Nabet 2012-12-27 06:38:41 UTC
On pc Debian x86-64 with Debian packages 3.6 sources and 4.0 both updated yesterday, I reproduced this.

Here are the steps:
- selected a comment in first table I found (NERC CIP (003, 005, 007, 009))
- clicked on the arrow to reveal all the actions
- selected "Delete All comments".
=> Then a popup appeared to ask "... Do you want to show the changes to avoid delays"
- if "Yes", had no crashes
- if "No", crashes.

With master sources updated yesterday, LO crashes when trying to open the file.
Comment 4 Julien Nabet 2012-12-27 06:45:55 UTC
Created attachment 72165 [details]
bt + console logs on 4.0 branch

Here's the bt + console logs.

FYI, if click on yes (and so have no crash), I got this log repeated about 20 times:
warn:legacy.osl:6692:1:/home/julien/compile-libreoffice/libo_4_0/sw/source/core/access/acccontext.cxx:441: fire event for diposed frame?
Comment 5 Jorendc 2012-12-30 13:05:53 UTC
I tried again several times (try -> no crash -> close -> reopen; try -> crash -> close -> reopen), I had 1 crash in 5 tries.

Tested with Mac OS X 10.8.2, LibreOffice (Build ID: c5132e30fb09477aa46d810dd86727b3aa8cf20)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2012-12-30_01:12:12
Comment 6 Jorendc 2012-12-30 13:06:29 UTC
Created attachment 72302 [details]
Crashlog Mac OS X
Comment 7 Julien Nabet 2013-01-11 21:41:51 UTC
With master sources updated today, I've got an almost identical bt than one I had attached.

Michael/Cedric: one for you?
Comment 8 Cédric Bosdonnat 2014-01-20 08:57:37 UTC
Restricted my LibreOffice hacking area
Comment 9 Caolán McNamara 2014-10-03 15:56:55 UTC
Deleting postits with change tracking enabled, but not shown is a tricky business. The fields are changing underneath the feet of the deletion loop so it ends up double deleting fields that are already deleted, and then missing the replacements that were added