Bug 58526 - UI: Add a "close search" button to the search bar
Summary: UI: Add a "close search" button to the search bar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other All
: medium enhancement
Assignee: Jorendc
QA Contact:
URL:
Whiteboard: BSA target:4.1.0
Keywords:
: 58593 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-19 17:53 UTC by santiago473
Modified: 2015-12-22 01:37 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description santiago473 2012-12-19 17:53:18 UTC
Problem description:

LibreOffice implements additional menus by default as usually temporary tool bars instead of separate windows.

Therefore you can open the search bar by choosing "Edit -> Find" or pressing "STRG + F" but there is no intuitive and user-friendly way to close the search bar afterwards, like the close button of Firefox's search bar.

Steps to reproduce:

1. Open Writer
2. Press "STRG + F" or select "Edit -> Find"

Current behavior:

The search bar is opened but there is no intuitive way to close it again.

Expected behavior:

Add a "close search" button to the search bar similar to the page preview's "close preview" button.
Operating System: Windows XP
Version: 4.0.0.0.beta1
Comment 1 leighman 2012-12-19 23:09:41 UTC
Confirmed.
I remember having trouble with this.
Alternative would be having ability to right-click -> Close on toolbars
Comment 2 leighman 2012-12-19 23:18:35 UTC
I mean alternative/workaround is* to right-click -> Close
Comment 3 santiago473 2012-12-20 00:24:17 UTC
(In reply to comment #2)
> I mean alternative/workaround is* to right-click -> Close

Yes, but as you say I would regard this merely a work-around, than an user friendly solution. The context menu is meant to customize the UI, not to replace the UI itself. I am sure a "beginner" would look for a separate button, not the customization context menu.
Comment 4 leighman 2012-12-21 12:42:05 UTC
*** Bug 58593 has been marked as a duplicate of this bug. ***
Comment 5 Jorendc 2013-01-06 17:58:37 UTC
I'll try to implement this enhancement
Comment 6 Jorendc 2013-01-06 23:20:03 UTC
I add the option to Writer (see https://gerrit.libreoffice.org/#/c/1557/)
It first need to be reviewed, and after that's done, I'll implement it to other components (calc, etc) as well.
Comment 7 Leon Arundell 2013-01-07 06:34:48 UTC
Thank you Joren.

Please tell me if I can assist.
Comment 8 Michael Meeks 2013-01-10 17:45:38 UTC
Kendy - any chance you can keep an eye on this work to the search-bar from a new contributor: Joren who already does some great QA work for us :-)
Comment 9 Jorendc 2013-01-16 20:38:45 UTC
This feature will be implemented in LibreOffice 4.1.0 on all components (currently it's accepted for Writer, but it'll also be accepted very soon for the other components).
I'll see if I can backport it also to 4.0.0;
Therefore I mark this enhancement request as RESOLVED FIXED
Comment 10 Richard Prins 2013-04-11 11:50:01 UTC
You can also let the search toolbar be opened as a floating "window" by default, so that it is more visible. These windows have a close button by default.
Comment 11 Milan Bouchet-Valat 2013-05-31 12:41:06 UTC
Nice improvement, but I don't think the icon should be red: it looks like cancel/delete. Firefox uses a grey cross, which is much more in line with color codes.
Comment 12 Jorendc 2013-05-31 12:42:40 UTC
(In reply to comment #11)
> Nice improvement, but I don't think the icon should be red: it looks like
> cancel/delete. Firefox uses a grey cross, which is much more in line with
> color codes.

I re-used that button from an already existing one. Thanks for your feedback. I really appreciate that :-), and I do agree.

I'll see what I can do, maybe I have to bug the design team for creating one :-).

Kind regards,
Joren
Comment 13 Milan Bouchet-Valat 2013-05-31 12:55:20 UTC
Thanks for the reply. I think the icon already exists: it is used e.g. for the File->Close menu item. It is not visible under GNOME, but you can see it using Tools->Customize.
Comment 14 Michael Meeks 2013-06-04 14:41:46 UTC
There are a number of small black close icons - one is used in the top right of a document window to allow closing that & getting back to the shell: might work ?
Comment 15 santiago473 2013-06-21 05:03:54 UTC
(In reply to comment #9)
> This feature will be implemented in LibreOffice 4.1.0 on all components
> (currently it's accepted for Writer, but it'll also be accepted very soon
> for the other components).
> I'll see if I can backport it also to 4.0.0;
> Therefore I mark this enhancement request as RESOLVED FIXED

Thank you very much Joren! Nice to see things working out.
Comment 16 Robinson Tryon (qubit) 2015-12-22 01:37:14 UTC
Remove semicolon from Whiteboard.
[NinjaEdit]