Bug Hunting Session
Bug 58572 - FORMATTING: i gets capitalized even in non-english languages
Summary: FORMATTING: i gets capitalized even in non-english languages
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-12-20 12:46 UTC by strug
Modified: 2012-12-30 14:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description strug 2012-12-20 12:46:31 UTC
Problem description: 

Steps to reproduce:
1. write letter "i" and press space



Current behavior:
"i" gets autocorrected to "I" even if I have polish version of LO and have chosen polish language.
I checked autocorrect options and didn't find this rule, so it has to be hidden somewhere deeper (or I missed something)

Expected behavior:
i doesn't autocorrect "i" is polish word for "and" so its used a lot an annoys 
              
Operating System: Ubuntu
Version: 4.0.0.0.beta1
Last worked in: 3.6.4.3 release
Comment 1 s-joyemusequna 2012-12-20 17:31:17 UTC
Confirmed with LOdev 4.0 beta1 under Windows Vista 64 with german text.
Comment 2 tommy27 2012-12-30 09:18:04 UTC
I do not see "i" to "I" autocorrection in LibO 4.0 beta2 using italian or english language, unless it is first letter of a sentence so it gets auto-capitalized.  Windows Vista 64bit.

do u still experience this issue in beta2?
Comment 3 s-joyemusequna 2012-12-30 14:32:26 UTC
No. It works with Beta2.