Download it now!
Bug 58591 - Setting text language dialogs are misleading.
Summary: Setting text language dialogs are misleading.
Status: RESOLVED DUPLICATE of bug 103036
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-20 23:07 UTC by brmj.page
Modified: 2018-11-04 21:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brmj.page 2012-12-20 23:07:15 UTC
A dedicated dialog for text language selection would reduce confusion.

There are at least four closed bugs saying that Tools -> Languages -> For paragraph -> More... leads to the wrong dialog box. It leads to the character formatting dialog because text language is considered to be part of the character formatting. Counter-intuitive.

Tools -> Languages -> For all Text -> More... leads to the general program options and there lets you set the language just for the current doc. Again counter-intuitive, but less confusing.

This new dialog should just let you choose the language you want to use for the text, maybe also let you choose whether to apply it to the whole doc, the current paragraph, the selection, or maybe even make it the default for all docs.
Comment 1 Urmas 2012-12-21 09:07:00 UTC
Just keep in mind that this dialog will be setting three languages simultaneously, and dialogs with 4 (!) possible states (for scope in this case) are inacceptable from usability standpoint.
Comment 2 Jorendc 2013-01-30 14:27:42 UTC
Thanks fore reporting!

Because this is a valid enhancement request I'll just mark this as 'valid'. I'm not THAT familiar to discuss what do delete/change/.. and what not. Therefore I just mark it as NEW.
Comment 3 Jorendc 2013-01-30 14:29:02 UTC
@Andras: I think it's good to have an expert opinion for this one.

Thanks in advance,
Joren
Comment 4 StephenM 2016-10-06 12:56:24 UTC
I always expected the "More..." button to take me to a dialog where I get to select which languages show under the "For All Text" sub-menu (et al.), marking one as the default.

This would be the most useful because people could tick the languages they commonly use. Here in Europe, it is extremely common for people to speak three or four languages and work in all of them, from time to time.

For consistency with the current behaviour, the U.I. language should probably be ticked and not untickable.

I think bug #91119 is relevant: https://bugs.documentfoundation.org/show_bug.cgi?id=91119
Comment 5 Thomas Lendo 2018-11-04 21:10:09 UTC
This is the older bug but in the newer one there is more discussion, therefore I set this issue as dupe.

*** This bug has been marked as a duplicate of bug 103036 ***