Bug 58725 - Changing styles is not recorded with Tracking Changes
Summary: Changing styles is not recorded with Tracking Changes
Status: RESOLVED DUPLICATE of bug 91983
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2012-12-24 19:24 UTC by Zeki Bildirici
Modified: 2019-05-29 15:23 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zeki Bildirici 2012-12-24 19:24:07 UTC
Problem description: 

LibreOffice does not recognize a change of words to a heading. Even it recognizes other style and attribute changes, it does not recognize changes in headings.

Changes in headings and heading levels are very important in important documents as reports, thesis and many other contracts and etc


Current behavior:

Changes to headings and changes in headings are not treated as a change in record changes

Expected behavior:

To record this kind of changes

Best regards,
Zeki

              
Operating System: All
Version: 3.6.4.3 release
Comment 1 Jorendc 2013-01-25 00:10:00 UTC
(In reply to comment #0)
> Problem description: 
> 
> LibreOffice does not recognize a change of words to a heading. Even it
> recognizes other style and attribute changes, it does not recognize changes
> in headings.
> 
> Changes in headings and heading levels are very important in important
> documents as reports, thesis and many other contracts and etc

If I understand it correct... the changes you made with other (paragraph?) styles will be recorded correct? I can't reproduce that as far as I test it.

So I can reproduce the fact it didn't record it when you set a text to 'Heading 1' or changing it to another heading style. But I think it didn't do that with all the paragraph styles...

Thanks for reporting!

Marking this bug as new, but I don't know or I need to mark it as an enhancement or as a bug.

Kind regards
Comment 2 Jorendc 2013-01-25 10:55:39 UTC
Code pointer where I think this magic happens (not 100% sure):

http://opengrok.libreoffice.org/xref/core/svx/source/tbxctrls/tbcontrl.cxx#404
Comment 3 Jorendc 2013-01-25 11:36:35 UTC
(In reply to comment #2)
> Code pointer where I think this magic happens (not 100% sure):
> 
> http://opengrok.libreoffice.org/xref/core/svx/source/tbxctrls/tbcontrl.
> cxx#404

Sorry, I think I opened the wrong bug. This is NOT a correct code pointer.
Comment 4 Zeki Bildirici 2013-01-25 14:53:27 UTC
(In reply to comment #3)
> Sorry, I think I opened the wrong bug. This is NOT a correct code pointer.

That's bad. I hoped finally someone will attended to this bug report :(

Yes you are right, i didn't had much paragraph style, so i only figured the heading style. 

Now i, tried that, the problem seems serious, LibreOffice does not recognize any style change in the document. 

I think it will be better to change the bugs name as:

Changing styles is not recorded with Tracking Changes

I hope it will be fixed/implemented, because it is very important in proffessional documents.

Best regards,
Zeki
Comment 5 Cédric Bosdonnat 2014-01-20 08:57:21 UTC
Restricted my LibreOffice hacking area
Comment 6 QA Administrators 2015-07-18 17:43:43 UTC Comment hidden (obsolete)
Comment 7 Gülşah Köse 2016-02-09 12:59:51 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2016-11-02 08:17:10 UTC
(In reply to Gülşah Köse from comment #7)
> (In reply to Zeki Bildirici from comment #0)
> > Expected behavior:
> > 
> > To record this kind of changes
> 
> Hi Zeki, I couldn't reproduce that bug in LibreOfficeDev 5.2.0.0.alpha0. Can
> you test it again or write reproducings steps?

1. Type a word
2. Edit - Track changes - Record
3. Change the paragraph style of the word to something other than default
4. Edit - Track change - Manage shows empty list

Win 7 Pro 64-bit Version: 5.3.0.0.alpha1+
Build ID: 4b4abb73fcd7f2802e73102b3e7c30face8d309c
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: old; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-10-31_02:54:50
Locale: fi-FI (fi_FI); Calc: group
Comment 9 QA Administrators 2018-04-15 02:31:26 UTC Comment hidden (obsolete)
Comment 10 Gabor Kelemen 2019-05-29 15:23:28 UTC

*** This bug has been marked as a duplicate of bug 91983 ***