Bug 59042 - Option 'Application background' invisible because 'Document Background' covers Application Background
Summary: Option 'Application background' invisible because 'Document Background' cover...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Robert Roth
URL:
Whiteboard: target:4.1.0
Keywords:
Depends on:
Blocks: Unify-Across-Apps
  Show dependency treegraph
 
Reported: 2013-01-05 05:20 UTC by ape
Modified: 2018-04-09 22:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
example (116.05 KB, image/png)
2013-01-05 05:20 UTC, ape
Details
Application background: Yellow (18.47 KB, image/png)
2013-01-06 04:23 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2013-01-05 05:20:41 UTC
Created attachment 72527 [details]
example

Option 'Application background' does not work in The LibreOffice's Main Window and in The Draw_LibO - see attachment.
Comment 1 m.a.riosv 2013-01-06 00:39:39 UTC
Hi api, thanks for reporting.

Try using for example a yellow as background colour and you can see where the change is.
Comment 2 ape 2013-01-06 04:23:45 UTC
Created attachment 72578 [details]
Application background: Yellow

Hi mariosv,
Probably, you write about another option (look an attachment ‘Yellow’). ‘Tools – Options – Lodev – Appearance – Application background’ does not work in The LibreOffice's Main Window and in The Draw_LibO.
Comment 3 m.a.riosv 2013-01-06 13:55:21 UTC
Hi @api,

right, no change in Draw and Main Window, but I have verify this is for all versions from 3.3.4 (As in Aoo 3.4.1).

This was reporter in 51535

*** This bug has been marked as a duplicate of bug 51535 ***
Comment 4 Rainer Bielefeld Retired 2013-01-07 05:34:47 UTC
This never worked in LibO, is inherited from OOo.

An additional characteristic of this bug here is that that Document Background (from menu 'Tools -> Options -> Appearance') fills the application backgound (try document background blue), what might be the reason for the _invisible_ Applcation background (what is different to a not selectable one of Bug 51535)

This never worked in OOo, so it's definitively not critical.

@mariosv:
Although this one is the same area as Bug 51535, I doubt that it's a DUP (also see above in this comment), because this one changes the behavior between OOo 2 and OOo 3, but the roots go back to OOo 1, where we did not have a start center. I would prefer to leave this one separate - or do you have more information than me?
Comment 5 Rainer Bielefeld Retired 2013-01-07 05:45:17 UTC
As mentioned above, the real bug here seems to be that menu 'Tools -> Options -> Appearance - Document background' covers all contents windows area. Change "Auto" to "Light Blue" and you will see that also the Application background area will be shown light blue.

This was more or less the same behavior back until OOo 1
Comment 6 Rainer Bielefeld Retired 2013-01-07 05:48:34 UTC
I removed AOOo issue relation because in that report the assumtion concerning the roots of the problem is wrong.

@Thorsten:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf
Comment 7 Not Assigned 2013-02-04 14:15:42 UTC
Robert Roth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d18b593f36c9146bd317b9e62163f8dc078f6b8

Use application background consistently in Draw, fdo#59042



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.