Bug 59240 - FORMATTING: Thai number shown as Arabic numerals
Summary: FORMATTING: Thai number shown as Arabic numerals
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Jorendc
QA Contact:
URL:
Whiteboard: bibisected40 target:4.0.0.2 target:4.1.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-01-11 12:06 UTC by Korrawit Pruegsanusak
Modified: 2013-02-11 11:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example file (7.49 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-01-11 12:08 UTC, Korrawit Pruegsanusak
Details
screenshot in 3.6 -- correct (62.83 KB, image/png)
2013-01-11 12:14 UTC, Korrawit Pruegsanusak
Details
screenshot in 4.0 -- wrong (61.21 KB, image/png)
2013-01-11 12:14 UTC, Korrawit Pruegsanusak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Korrawit Pruegsanusak 2013-01-11 12:06:08 UTC
Problem: In cell formatting as Thai numerals, it shown as Arabic numerals.

Steps to reproduce
0. Open new Spreadsheet
1. Type "11" (eleven) without quotes in cell A1
2. Right-click at cell A1 > Format Cells ...
3. Language > Thai
4. Category > Number
5. Select any Format that has Format Code starting with [NatNum1][$-41E], such as [NatNum1][$-41E]0.00 > OK

What is expected:
Number changed to ๑๑.๐๐

What actually happened:
No change

Note:
1. Saving file from LibO 3.6.3, opened *wrong* in 4.0.0.1 -- will provide a test file in next comment

2. The Formats in dialog are also wrong -- will provide screenshot comparing 3.6 and 4.0

Last worked in: 3.6.3 => regression
OS: Windows XP
Comment 1 Korrawit Pruegsanusak 2013-01-11 12:08:48 UTC
Created attachment 72849 [details]
example file

Attachment Expectation:
should show ๑๑.๐๐ in cell A1 -- this is correct in 3.6.3

What actually happened:
showing 11.00 in cell A1 -- wrong in 4.0.0.1
Comment 2 Korrawit Pruegsanusak 2013-01-11 12:14:24 UTC
Created attachment 72850 [details]
screenshot in 3.6 -- correct
Comment 3 Korrawit Pruegsanusak 2013-01-11 12:14:48 UTC
Created attachment 72851 [details]
screenshot in 4.0 -- wrong
Comment 4 Korrawit Pruegsanusak 2013-01-11 12:21:49 UTC
REPRODUCIBLE since build from tinderbox Win-x86@6, pull time 2012-12-18 08:36:19, core: fd17055017b7bb4c02c247ce1136447126cdb5e6

NOT REPRODUCIBLE with build from tinderbox W2008R2@16-minimal_build, pull time 2012-10-25 22:55:31, core: 582265477d0ef819125e906cd08e5bf32916088a

So regression introduced between that.
Comment 5 Jorendc 2013-01-11 23:38:44 UTC
Thanks for reporting and the clear steps!

Can reproduce using Windows 7 x64; LibreOffice Version 4.0.0.1 (Build id: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799); Dutch UI
Comment 6 Korrawit Pruegsanusak 2013-01-19 09:18:08 UTC
k@vbox ~/bibisect40 $ git bisect log
git bisect start
# good: [e2e46267c18c2706de771a08472ebfce19f68520] source-hash-4316e643ef345b0f673b4a03a80a4b7cb3185588
git bisect good e2e46267c18c2706de771a08472ebfce19f68520
# bad: [eb01a04acbb7373331312a2ee3d9d90d20548fca] source-hash-ce90f99a2d66c2b998ad3f9f028e2ea623a757f5
git bisect bad eb01a04acbb7373331312a2ee3d9d90d20548fca
# good: [5dddcff8ae35692d89751ae98ab8acbbf802b5b4] source-hash-d85fd8a85501547d5bb87822d2589a07aed7f2d6
git bisect good 5dddcff8ae35692d89751ae98ab8acbbf802b5b4
# good: [79f6cca2cef3c5a9cbda4089d46146ff3099648b] source-hash-11e776023c89b3de690b37ffaed18ec996b9c207
git bisect good 79f6cca2cef3c5a9cbda4089d46146ff3099648b
# bad: [5655f1571312ca27537c9c147c69d6431986b76d] source-hash-b67a51b40a4876f4bd97a2917103112006710b0c
git bisect bad 5655f1571312ca27537c9c147c69d6431986b76d
# bad: [ec7d01ea25190e36518df830ed84b791b2417e2e] source-hash-c33019b36d613f951787ce9836e34d74bfbd6a1b
git bisect bad ec7d01ea25190e36518df830ed84b791b2417e2e


This means regression introduced between http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=11e776023c89b3de690b37ffaed18ec996b9c207..c33019b36d613f951787ce9836e34d74bfbd6a1b
Comment 7 Jorendc 2013-01-19 09:28:03 UTC
Thanks for your bibisect log

I'm absolutely not sure, but this seems like a quite relevant commit to this bug http://cgit.freedesktop.org/libreoffice/core/commit/?id=ee1df64d6cc0c2b8684063e2ae33676fd50440a7
Comment 9 Jorendc 2013-01-19 09:38:23 UTC
@Norbert: can you please have a look at this one? Following the bibisect you made a lot of changes in this range related to this topic. If I'm wrong, I'm sorry to disturb you.

Kind regards,
Joren
Comment 10 Jorendc 2013-01-19 13:34:45 UTC
@Norbert, I found the issue; sorry to disturb you.
(currently under review: https://gerrit.libreoffice.org/#/c/1769/ )
Comment 11 Not Assigned 2013-01-21 15:44:08 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e30f57fa1804d3c77cddfca897787d16fbe508da&h=libreoffice-4-0

resolve fdo#59240 - FORMATTING: Thai number shown as Arabic numerals


It will be available in LibreOffice 4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Not Assigned 2013-01-21 15:44:28 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=49ce84919aff654104987c86c3102304202fef6d

resolve fdo#59240 - FORMATTING: Thai number shown as Arabic numerals



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Jorendc 2013-01-21 15:45:50 UTC
See comments above. My changes are pushed, so I mark this bug as resolved fixed.
Comment 14 Korrawit Pruegsanusak 2013-02-10 07:56:48 UTC
Sorry for late reply, but, Thanks very much Joren! :-)

Since I've verified the fix with 4.0.0.2 on Windows 7 => mark as VERIFIED.

Also, I've submitted a unit test for this bug at https://gerrit.libreoffice.org/2078. Hope it'll be merged soon. :-)
Comment 15 Not Assigned 2013-02-11 11:49:34 UTC
Korrawit Pruegsanusak committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=97642ab568861444b95bddac63d4a41729934efc

add unittest for fdo#59240



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.