Bug Hunting Session
Bug 59427 - [Template Manager] low discoverability of new template manager - we could use "File → Organize templates" menu
Summary: [Template Manager] low discoverability of new template manager - we could use...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.2.0
Keywords: regression
: 59349 62161 67202 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-15 16:11 UTC by mikamail
Modified: 2014-02-03 20:37 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikamail 2013-01-15 16:11:15 UTC
Problem description: 

Steps to reproduce:
1. no menu entry

Current behavior:
i can't administrate templates for documents. i can't define standard-template.
it exists only the entry for saving as document-template

Expected behavior:
in earier versions there was an entry in the menu bar called (in German: Dokumentvorlage verwalten = administrate templates for documents).

best wishes
mika


              
Operating System: Windows 7
Version: 4.0.0.1 rc
Last worked in: 3.6.4.1 rc
Comment 1 Joel Madero 2013-01-15 16:59:08 UTC
adding Caolan as he knows more about template stuff. Our entire template manager has changed so this might be a WONTFIX but I'll let Caolan decide that.
Comment 2 Caolán McNamara 2013-01-15 20:12:37 UTC
cedric's reworking the template dialog, so its his baby :-)
Comment 3 Joel Madero 2013-01-16 15:46:10 UTC
@Cedric - Opinions?
Comment 4 mikamail 2013-01-16 19:07:26 UTC
meanwhile I found the template-administration-window. but I think it's a bit hidden. I got it when I created a new document by selecting a template. I like the window. my recommendation: give a direct, coherent labeled access by the file menu. so everybody can find it and enjoy it.
Best wishes
mika
Comment 5 Rainer Bielefeld Retired 2013-01-22 07:59:45 UTC
NEW due to facts

Has nothing to do with "German"
Comment 6 Rainer Bielefeld Retired 2013-01-22 08:00:52 UTC
*** Bug 59349 has been marked as a duplicate of this bug. ***
Comment 7 Nikos 2013-02-04 17:38:10 UTC
Sorry to bump into this, as I am not sure this is the same bug, or even that this is a bug. I used to copy styles from one file to another with the old template manager (templates ---> oganize). Is this possible with the new template organizer?
Comment 8 Mirosław Zalewski 2013-02-10 12:41:37 UTC
Nikos: I strongly believe that this bug is about low discoverability of new template manager. This is pretty true: new manager is right in front of user in LO center (the one that can launch other applications), but quite hidden in apps. We could definitely use "File → Organize templates" menu item.

What you are talking about, is missing feature of new template manager in compare to old one. I have filed another bug report about this:
https://bugs.freedesktop.org/show_bug.cgi?id=60589
Comment 9 Cor Nouws 2013-02-25 22:46:33 UTC
@nikos, all

(In reply to comment #8)
> Nikos: I strongly believe that this bug is about low discoverability of new
> template manager. This is pretty true: new manager is right in front of user
> in LO center (the one that can launch other applications), but quite hidden
> in apps. We could definitely use "File → Organize templates" menu item.

So the summary of this issue should be changed ...

And the menu
   File > Save as template 
in 4.0.x, could be replaced by

File > Template > Save
             .. > Edit 

Opinions?
Comment 10 Mirosław Zalewski 2013-02-25 22:59:30 UTC
> So the summary of this issue should be changed ...

Could you rephrase?
I do not trust my English skills enough...

> And the menu
>    File > Save as template 
> in 4.0.x, could be replaced by

> File > Template > Save
>              .. > Edit

I would vote for:
File > Templates > Manage
File > Templates > Save

I think "Manage" is better - it would fire new template manager, which can not only edit templates (what "Edit" suggests), but also organize them (move around, change names, import, export etc.).

Another case, creating new file from template, is covered by 
File > New > From template
(the same as it was in pre-4.0).
Comment 11 Cor Nouws 2013-03-02 15:43:11 UTC
(In reply to comment #10)

> Could you rephrase?
> I do not trust my English skills enough...

Ehh, done with using your words ;-)

> I would vote for:
> File > Templates > Manage
> File > Templates > Save
> 
> I think "Manage" is better - it would fire new template manager, which can
> not only edit templates (what "Edit" suggests), but also organize them (move
> around, change names, import, export etc.).
> 
> Another case, creating new file from template, is covered by 
> File > New > From template
> (the same as it was in pre-4.0).

And there is the problem described in fdo#61465 - No possibility to edit templates that are saved on some random location
Comment 12 Jorendc 2013-03-11 16:13:39 UTC
*** Bug 62161 has been marked as a duplicate of this bug. ***
Comment 13 Jorendc 2013-03-11 16:15:13 UTC
Not Windows only -> Platform = all.
Comment 14 marco.defelice 2013-03-11 16:17:18 UTC
At least update the HELP file to correctly identify where this Template 
manager is.   Help file shows old location.


--Marco deFelice

On 3/11/2013 5:15 PM, bugzilla-daemon@freedesktop.org wrote:
> Jorendc <mailto:joren.libreoffice@telenet.be> changed bug 59427 
> <https://bugs.freedesktop.org/show_bug.cgi?id=59427>
> What 	Removed 	Added
> OS 	Windows (All) 	All
> CC 		joren.libreoffice@telenet.be
>
> *Comment # 13 <https://bugs.freedesktop.org/show_bug.cgi?id=59427#c13> 
> on bug 59427 <https://bugs.freedesktop.org/show_bug.cgi?id=59427> from 
> Jorendc <mailto:joren.libreoffice@telenet.be> *
> Not Windows only -> Platform = all.
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You are on the CC list for the bug.
>
Comment 15 Jorendc 2013-03-11 16:41:32 UTC
With respect to our Prioritizing flowchart [1] I mark this as Normal Highest.

* Normal: In a kind of way it DOES prevent users from high quality work (can't find it anymore).
* Highest: highest possible priority in the 'Normal' range; this 'bug' is seen as a *regression* by users and is an accessibility issue.

[1] https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 16 marco.defelice 2013-03-11 17:12:05 UTC
The help file is incorrect if we are going to continue putting Template management under "file-new". 
  

However, "Template management"  is not a NEW document.  Users can also manage, edit, change default templates.  So, it seems to me (a heavy template user for years) to put this under the File - New menu is incorrect. 
I would return to prior practice, it's own voice under File.
Comment 17 Paul Weiss 2013-03-11 17:22:54 UTC
(In reply to comment #16)
I agree.
Comment 18 Rafael Dominguez 2013-03-12 13:45:08 UTC
(In reply to comment #16)
> The help file is incorrect if we are going to continue putting Template
> management under "file-new". 
>   
> 
> However, "Template management"  is not a NEW document.  Users can also
> manage, edit, change default templates.  So, it seems to me (a heavy
> template user for years) to put this under the File - New menu is incorrect. 
> I would return to prior practice, it's own voice under File.

I kinda like the idea of putting it under File, but we should keep the new Template menu too, since then how would users create a new template ? Through manage menu?
Comment 19 Cor Nouws 2013-03-12 14:48:27 UTC
So it could be:


File >
   New >     ..
             ..
             Templates
   Open
   Recent documents
   - - - - -
   Wizards
   - - - - -
   Templates > Manage...
               Save...
               Edit...

(Note: 'Manage' is currently labeled 'Organize')
Comment 20 Cor Nouws 2013-07-23 21:11:22 UTC
*** Bug 67202 has been marked as a duplicate of this bug. ***
Comment 21 Commit Notification 2013-07-25 08:58:01 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=12a034623e015ca05b56c82ebb63230ce731bab4

fdo#59427 first step for template menu



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2013-11-20 11:36:19 UTC
Cor Nouws committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae2a19fa846f533e6ec7d1bb9839a6a709862872

fdo#59427 next step template menu: change string New Document.. to Manage



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Björn Michaelsen 2014-01-17 00:43:31 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so called MAB (most annoying bugs) -- as this bug has not run through that process (including writing a short rationale for this bug being a candidate and other who are watching the tracker bug silently approving that rationale etc.) its priority is set to high. Note this is effectively no change in the urgency assigned to this bug, as we are currently not making a difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by contacting libreoffice qa on irc:

 http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact with the team (if IRC fails you, your next best choice is the mailing list):

 https://wiki.documentfoundation.org/QA
Comment 24 Cédric Bosdonnat 2014-01-20 09:00:29 UTC
Restricted my LibreOffice hacking area
Comment 25 Cor Nouws 2014-02-03 20:37:27 UTC
see comments 21 and 22