Bug 59699 - RTF: INCLUDEPICTURE image not shown
Summary: RTF: INCLUDEPICTURE image not shown
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other Windows (All)
: medium major
Assignee: Miklos Vajna
URL:
Whiteboard: BSA target:5.2.0 target:5.1.2 target:...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-22 07:54 UTC by SI Albertville
Modified: 2016-10-25 19:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
exemple fichier word 2003 (41.59 KB, application/rtf)
2013-01-22 07:54 UTC, SI Albertville
Details
Linked image to RTF - minimized RTF and screenshot (20.55 KB, application/x-zip-compressed)
2016-04-25 10:55 UTC, Michal Vašut
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SI Albertville 2013-01-22 07:54:02 UTC
Created attachment 73431 [details]
exemple fichier word 2003

Problem description: 

Steps to reproduce:
1. When I open a rtf file containing images (linked or embedded)
2. 
3. 

Current behavior:
libreoffice does not display the images

Expected behavior:
display the images


              
Operating System: Windows XP
Version: 3.6.4.3 release
Comment 1 Urmas 2013-01-22 09:08:59 UTC
The second image in document is completely absent in 4.0.0.1 too.
Comment 2 SI Albertville 2013-02-11 07:34:01 UTC
Sorry, I complet my first ask.

A insert objet picture in the rtf file is allright.
A insert link picture in the rtf file is not show by LibreOffice.
Comment 3 retired 2014-01-04 10:27:06 UTC
NOTABUG

Downloaded test file

Open in Word 2010: first image shows, second image does not show
Open in LO: first image shows, second image does not show

This looks very much like it is the expected result. If you disagree, please tell me, with which software to open the test file to view both files.

Is this bug still valid / reproducible with the latest pre-release 4.2.0.1: http://www.libreoffice.org/download/pre-releases/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to NEW. Just re-open it.
Comment 4 Albrecht Müller 2014-05-13 16:58:10 UTC
This bug still exists in LibreOffice 4.2.3.3. To reproduce the error you need a file named ciril.png containing some graphic. The example file uses a relative path therefore this file should exist in the working directory (the directory containing the example file?). Windows 2010 did not show the second graphic as it was not there. LibreOffice does not show it even the file containing the external graphic exists.

I think this is a major problem as there are tools creating rtf documents containing many linked graphics. You cannot use LibreOffice with these tools as you will not see those graphics and doing some workarounds by hand is not a feasible option.

There is a related problem: I created a document containing a link to some external jpg file and saved it in rtf format. The resulting file did not contain the link to the external jpg file and contained the content of the graphic instead. The expected behavior is that the rtf file contains the links to the linked graphics.
Comment 5 Albrecht Müller 2014-05-14 13:42:20 UTC
Using a very old installation of Star Office 9 I was able to convert a .rtf file containing linked pictures into an .odt file. LibreOffice displays the converted file correctly. There are some flaws however:

A more then 15 years old version of Word, Word97, shows the pictures in some reasonable default format, e.g. it scales larges pictures in a way such that they fit on a page.

The .odf file seems to contain the pictures in their original size. This requires substantial work to format them by hand, and I think the related dialog box is confusing and lacks a feature that allows to change the scaling while maintainig a fixed aspect ratio, especially the aspect ratio of the original picture.

I would expect that LibreOffice scales big linked pictures such that they fit on a page while maintaining the aspect ratio of the original as a default behaviour (the .rtf file may specify something else).

A feature that allows to scale a picture using a fixed aspect ratio would be helpful. GIMPs user interface contains this kind of scaling transformations.
Comment 6 Joel Madero 2014-11-06 00:02:37 UTC
Moving to UNCONFIRMED as it seems unclear if anyone has confirmed this after foss was not able to confirm. Moving to UNCONFIRMED to get fresh eyes to look at it. Thanks all for understanding.
Comment 7 Urmas 2014-11-06 03:35:10 UTC
Confirming with 4.4.
Comment 8 QA Administrators 2015-12-20 16:12:23 UTC Comment hidden (obsolete)
Comment 9 Commit Notification 2016-02-16 08:18:48 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6083a8f188e2cd3fe6849e2112a6b06fbf8e1ad3

Related: tdf#59699 DOCX import: fix linked graphics with relative URLs

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-02-23 08:16:26 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f94cab9c43f88624b58a47ad03ad5f87032595d

tdf#59699 RTF import: handle INCLUDEPICTURE field

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-03-09 16:23:40 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bbab30f26382da83dda75c056e7ff9e51a1db9df&h=libreoffice-5-1

tdf#59699 RTF import: handle INCLUDEPICTURE field

It will be available in 5.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2016-03-24 13:23:16 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b5464c15078b57e852100a76f03fadef3186c93d&h=libreoffice-5-0

tdf#59699 RTF import: handle INCLUDEPICTURE field

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Michal Vašut 2016-04-25 10:55:11 UTC
Created attachment 124622 [details]
Linked image to RTF - minimized RTF and screenshot
Comment 14 Michal Vašut 2016-04-25 10:58:25 UTC
Just downloaded last alpha (5.2.0.0.alpha0+), to check if it's fixed there (because in stable, it is not). And it's fixed only halfway :-(.
The image is inserted, but is too tiny and missing in navigator (there is only blank line). I've added zip archive with minimized rtf, that works in MS Word 2013 and screenshot how it looks in latest alpha.

tested in:

Version: 5.2.0.0.alpha0+
Build ID: 5bb308a9ad16f6002486a60e4a753693818580b6
CPU Threads: 8; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-04-20_19:07:06
Locale: en-US (en_US)
Comment 15 Miklos Vajna 2016-04-26 12:45:32 UTC
Hi Michal,

Before the above fix the image wasn't imported at all. Also for the given test document, even its size is OK. :-)

Please open a new follow-up bugreport mentioning the related problem you noticed. See <https://wiki.documentfoundation.org/QA/BSA/BugReport_Details#How_to_reopen_Bugs> for more details on why not reopening this bug.

Thanks,

Miklos