Bug Hunting Session
Bug 59764 - Unable to set different data paths per component
Summary: Unable to set different data paths per component
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog-Paths
  Show dependency treegraph
 
Reported: 2013-01-23 14:41 UTC by dann2dc
Modified: 2019-03-07 11:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dann2dc 2013-01-23 14:41:54 UTC
With MS Office, I use different data folders for Word and Excel (a "doc" folder and a "xls" folder).  With LibO, when I set the path to the XLS folder in "spreadsheet" it also appears in "writer".  If I set the path to DOC in "writer, it also appears in "spreadsheet".  I cannot set separate paths for the desired data in each application.
Comment 1 m.a.riosv 2013-01-24 01:49:01 UTC
Hi dannsdc, thanks for reporting.

So is how it works, the path is common for all modules.

This is why it is not a bug.

If are agree, please modify the title for a request, and change the importance from normal to enhancement.
Comment 2 dann2dc 2013-01-24 14:37:34 UTC
OK, but the ability to set individual data folder paths for specific modules is important and provided in MS Office.
Comment 3 m.a.riosv 2013-01-24 15:04:44 UTC
Thanks for change the importance.

The importance always depends on each one. This is the only bug I can find about it.
I do not remember in XP, but in Win7 you can add a path to favorites, and using the system file dialog, can be a good workaround. (Menu/Tools/Options/Libreoffice/General - Open/Save dialog.)
Comment 4 Thomas Lendo 2018-11-17 00:06:47 UTC
Adding needsUXEval.

Is this something that
* should be customizable in the options dialog (https://help.libreoffice.org/6.1/en-US/text/shared/guide/workfolder.html?DbPAR=SHARED#bm_id3150789) by path per component or
* should work with a checkbox in the options dialog ('Allow different path per component') or
* should work smart, automatically and without any user setting?
Comment 5 Heiko Tietze 2019-03-07 11:55:12 UTC
We discussed the topic in the design meeting. There was a similar request in the past that we closed since files are typically stored per project/task/scenario. It's very uncommon to have text documents separated from the accompanying spreadsheet, for example. So the verdict is WFM.