Bug 59818 - VIEWING: Bad Font Rendering in KDE
Summary: VIEWING: Bad Font Rendering in KDE
Status: CLOSED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-24 19:44 UTC by Zeki Bildirici
Modified: 2016-09-19 16:48 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample screenshots (131.37 KB, image/png)
2013-01-24 19:44 UTC, Zeki Bildirici
Details
ubuntu 110 zoom (144.08 KB, image/png)
2013-01-24 19:45 UTC, Zeki Bildirici
Details
kubuntu normal-hinting (122.50 KB, image/png)
2013-01-24 19:46 UTC, Zeki Bildirici
Details
kubuntu 110 zoom normal hinting (132.74 KB, image/png)
2013-01-24 19:46 UTC, Zeki Bildirici
Details
kubuntu normal view thin hinting (133.67 KB, image/png)
2013-01-24 19:47 UTC, Zeki Bildirici
Details
kubuntu 110 zoom thin hinting (145.65 KB, image/png)
2013-01-24 19:47 UTC, Zeki Bildirici
Details
Best font rendering setting in KDE settings module (46.16 KB, image/jpeg)
2015-10-28 21:34 UTC, Zeki Bildirici
Details
Sample of a clear rendering by this settings. (218.56 KB, image/jpeg)
2015-10-30 20:35 UTC, Zeki Bildirici
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zeki Bildirici 2013-01-24 19:44:24 UTC
Created attachment 73605 [details]
Sample screenshots

Problem description: 

LibreOffice 3.5 improved the font rendering performance in Linux, which was very good for writers. But however, it has only effects GNOME and Unity, KDE has still not performing as good as Windows, Gnome or Unity.

I take screenshots from a native Unity installation and Kubuntu installation. I checked it in Debian too.

The problem is, in normal view and normal font hinting KDE renders fonts badly, not smooth, when you zoom out to %110 the fonts changes like they are bold. 

Some ppl advises to use Thin font hinting, i also tried it, not better as GNOME too, and as it is blurry, it causes headaches also if you have astigmatic, it is nightmare for you. 

Somehow font rendering in GNOME seems like native, no distortions, and no change in zoom in/out. 

It will be very nice to have that font rendering performance in KDE.

Having beautiful looking fonts makes good feeling when writing, but working with some pre-historic java style fonts does not give that feel.

The sample document is made just different font lines, working with block text and reading it look worse.


Current behavior:

Font rendering performance is not good

Expected behavior:

Having a better font rendering in KDE.

Note: The screenshot app in Ubuntu-Unity was not good as Kscreenshot, it seems like blurry, but it was smooth, sharp and cleaner in real.
              
Operating System: Ubuntu
Version: 3.6.3.2 release
Comment 1 Zeki Bildirici 2013-01-24 19:45:33 UTC
Created attachment 73606 [details]
ubuntu 110 zoom
Comment 2 Zeki Bildirici 2013-01-24 19:46:08 UTC
Created attachment 73607 [details]
kubuntu normal-hinting
Comment 3 Zeki Bildirici 2013-01-24 19:46:33 UTC
Created attachment 73608 [details]
kubuntu 110 zoom normal hinting
Comment 4 Zeki Bildirici 2013-01-24 19:47:00 UTC
Created attachment 73609 [details]
kubuntu normal view thin hinting
Comment 5 Zeki Bildirici 2013-01-24 19:47:23 UTC
Created attachment 73610 [details]
kubuntu 110 zoom thin hinting
Comment 6 Zeki Bildirici 2013-01-25 23:26:26 UTC
Sorry for messing about the attachments. Bugzilla recognized it as text/plain and i forgot to change it during upload.

Uploading here will be make crowd so i share the screenshots via Dropbox

Here is the attachements:

Normal view in Ubuntu
http://dl.dropbox.com/u/38862200/LO-Screenshots/ubuntu-nvidia-normal-view.png

%110 Zoom in Ubuntu
http://dl.dropbox.com/u/38862200/LO-Screenshots/ubuntu-nvidia-110-zoom.png

Medium font hinting in Kubuntu
http://dl.dropbox.com/u/38862200/LO-Screenshots/kubuntu-nvidia-normal-view-medium-font-hinting.png

%110 zoom in Kubuntu medium fpnt hinting
http://dl.dropbox.com/u/38862200/LO-Screenshots/kubuntu-nvidia-110-zoom-view-medium-font-hinting.png

Thin font hinting in Kubuntu
http://dl.dropbox.com/u/38862200/LO-Screenshots/kubuntu-nvidia-normal-view-thin-font-hinting.png 

%110 Thin font hinting in Kubuntu
http://dl.dropbox.com/u/38862200/LO-Screenshots/kubuntu-nvidia-110-zoom-view-thin-font-hinting.png


Sample odt file:
http://dl.dropbox.com/u/38862200/LO-Screenshots/Font-sample.odt
Comment 7 Luboš Luňák 2013-03-15 17:46:27 UTC
Font rendering is done by LibreOffice, not its platform integration modules, so I doubt this has anything to do with LibreOffice itself. Please try running LO in exactly the same environment and compare the results. You can use

SAL_USE_VCLPLUGIN=<plugin> libreoffice

to run different LO platform plugins (where <plugin> can be gtk, gtk3, kde, kde4, none).
Comment 8 Zeki Bildirici 2013-03-19 18:30:55 UTC
(In reply to comment #7)
> Font rendering is done by LibreOffice, not its platform integration modules,
> so I doubt this has anything to do with LibreOffice itself. Please try
> running LO in exactly the same environment and compare the results. You can
> use
> 
> SAL_USE_VCLPLUGIN=<plugin> libreoffice
> 
> to run different LO platform plugins (where <plugin> can be gtk, gtk3, kde,
> kde4, none).

Sorry but i am not able to understand the difference. I've already tried it on the same system and different components like KDE GNOME and XFCE etc.

If it is rendered by LibreOffice not by the system, how can the font hinting could change the font quality?

You may see, it is ok with GNOME but as you may see KDE is crappy, same system same LibreOffice same packages installed, only desktop enviroment changes.
Comment 9 Luboš Luňák 2013-03-20 10:48:38 UTC
And I'd like you to test it even without the desktop environment changing.
Comment 10 Zeki Bildirici 2013-03-23 10:36:32 UTC
(In reply to comment #7)
> SAL_USE_VCLPLUGIN=<plugin> libreoffice
> 
> to run different LO platform plugins (where <plugin> can be gtk, gtk3, kde,
> kde4, none).
Firstly i've installed libreoffice-gtk3 and libreoffice-gtk to my Kubuntu system.

Then used the commands. The result was no different from the native version.

Also after installing gtk3 package, there were lots of errors in the konsole and was not responding. I think it is not related to here but like dto say:
(soffice:3824): Gtk-CRITICAL **: gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed
        1 -> 1136,627 144x118
Unhandled is native supported for Type: 80, Part 107 

It was the same and not good as the native Ubuntu Unity and Debian. Now i don't have a native Ubuntu installation to test the platforms. If i have i will test it.

Btw, do you think trying with openSUSE or others can make a sense? If so i can try it.
Comment 11 Zeki Bildirici 2013-08-04 14:12:06 UTC
I've installed Ubuntu 13.04 and installed to KDE and LXDE over it.
KDE's font rendering was bad again, but LXDE's was good. The same with Ubuntu Desktop. 

I've installed LXDE on Kubuntu 12.10 but font rendering on LXDE was not good.

I doubt that i on the only one who cavils about the font rendering in KDE :(
Comment 12 Zeki Bildirici 2013-08-05 18:05:29 UTC
(In reply to comment #7)
> Font rendering is done by LibreOffice, not its platform integration modules,
> so I doubt this has anything to do with LibreOffice itself. Please try
> running LO in exactly the same environment and compare the results. You can
> use

After all tests i've done, i can say that font rendering is definitely made by the platform not LibreOffice. May be this is the bug, something by-passes LO?

- Font hinting from system settings changes the rendering quality

Also in previous message, i said LXDE renders fine, but i was wrong. The strange thing is that, LXDE renders fine, only if there is an Ubuntu session was running behing. 

If you start with Ubuntu, then log-out and start a new session with LXDE, it will display the fonts fine, no disturbance in zoom factors. But if you restart your computer to a fresh LXDE session, fonts are not rendered good.

- The problem exists in all other KDE distors, Mageia, openSUSE, Arch and PisiLinux has the same issue..


Also, i've found this, exactlty the same issue: https://bbs.archlinux.org/viewtopic.php?id=143071 installing patched freetype2 solved his problem, but not worked for me in Kubuntu.

Regards,
Zeki
Comment 13 Joel Madero 2013-12-23 20:46:18 UTC
Hi All,

I can confirm that there is a difference - although I don't think it's a really serious issue at 110% fonts do appear bold in KDE but don't look that way in Unity, Gnome, or Cinnamon. I have tested this one:

LibreOffice Version 4.1.3.2 release (installed through Ubuntu ppa)
LibreOffice Version 4.2.0.1 rc (installed through debian packages from LibreOffice.org/download)
LibreOffice Version 4.3 built on Sun Dec 15 23:07:57 2013 +0100 w/ only --without-doxygen as an option

Lubos - let me know if there's something else you want me to try. What I can say is the same product renders fonts differently on different DE's - if this isn't our bug, can we get a pointer of what it *may* be so that Zeki can head over there to file a bug.


Thanks!
Comment 14 Zeki Bildirici 2014-01-10 13:17:06 UTC
Hi,

I've opened a topic in KDE forum for some time ago and there are some thoughts here: http://forum.kde.org/viewtopic.php?f=17&t=118879

Fyi,
Zeki
Comment 15 Zeki Bildirici 2014-01-11 11:06:26 UTC
(In reply to comment #7)
Hi Lubos,
> Font rendering is done by LibreOffice, not its platform integration modules,
> so I doubt this has anything to do with LibreOffice itself. Please try
> running LO in exactly the same environment and compare the results. You can
> use

Today i tried the Linux Infinality stuff here: http://www.webupd8.org/2013/06/better-font-rendering-in-linux-with.html and fonts are now looking great in LibreOffice. I can definitely confirm that font rendering in LibreOffice made by the system not by LibreOffice itself *in KDE, LXDE and other DE's. Only GNOME and Ubuntu DE's made by LibreOffice -with a great success- as far as i see.

Best regards,
Zeki
Comment 16 Zeki Bildirici 2014-04-03 07:58:24 UTC
Hi Adolfo,

Please do not mark bugs resolved worksforme without any info like in his case; distrubution, platform, DE, DE version etc. 

I'm reverting the bug status to Reopened.

Regards,
Zeki
Comment 17 Joel Madero 2014-04-03 15:23:50 UTC
REOPENED is incorrect status - moving back to NEW
Comment 18 Adolfo Jayme 2014-04-03 19:58:33 UTC
Yes, you’re right. This should actually be NOTOURBUG rather than WORKSFORME. Because LibreOffice is respecting the hinting setting of the desktop environment, and once you modified it with a third party tweak (Infinality) you found out that you like it.
Comment 19 Zeki Bildirici 2014-04-03 20:16:09 UTC
Hi Adolfo,

Are you aware that you do not have to triage bugs -at least my reports and please don't...

Regards,
Zeki
Comment 20 Adolfo Jayme 2014-04-03 20:51:04 UTC
Yet I waste time doing it because I like it. Yes, I’m not forced to translate LibreOffice, nor I am forced to give UX advise, but I do it. Problem? </offtopic> 

I do not understand why, even when in comment 15 you resolved the “problem”* (which is in Kubuntu’s default freetype configuration, i.e. a distro bug) you now want to have an open Bugzilla ticket here.

Comment by you:
> After all tests i've done, i can say that font rendering is definitely made by the platform not LibreOffice.

---
* “Problem” is in quotation marks because this thread is really just another bug report about different font rendering styles which look wrong to some people but others may like it, and so there’s not a single setting that makes averyone happy and that stuff…
Comment 21 Adolfo Jayme 2014-04-03 21:01:37 UTC
(In reply to comment #19)
> Are you aware that you do not have to triage bugs -at least my reports and
> please don't...

So you want me to retire because it’s the first time someone disagrees with the status of a bug report of yours? How should I take this? Since when is it bad that I express the reasons why I disagree with having this report open here, when it’s clearly a KDE thing?
Comment 22 Joel Madero 2014-04-03 21:32:33 UTC
Okay I am actually moving this back to UNCONFIRMED and requesting dev input - maybe it's not ours. Zeki - please don't mark it as NEW again until an expert gets involved
Comment 23 Zeki Bildirici 2014-04-04 09:21:59 UTC
Hi,

Adolfo, it is clear that you didn't read what i've post here hundred of lines, and if you just decide and act without any info this won't be a respectful way of communication.

I don't have time to re-write the things that i've written before just to explain the problem to you...

You say it's a distro bug of Kubuntu but on https://bugs.freedesktop.org/show_bug.cgi?id=59818#c12 you may see that i wrote 4 other KDE distros has the same issue.

Lubos wrote that font rendering is made by LO, not the DE... But in KDE DE it seems not, and i tried to prove that... Which may be the reason, but you come and cut the issue 'LO respects the hinting...' who said it doesn't? 

On the other hand, my workaround is not a solution. I'm a KDE user and i am not the only KDE user, LO is a cross platform software and KDE users can demand good font rendering as rest of the enviroments and platforms without any third party tool or hacking...

This is all about to improve LO, not about just closing the bugs for 'any reason'... 

I always try to encourage people to involve in community and contribute to LO. But your way of behaviour is not correct. You just marked 'Worksforme' without giving any detail... And then you marked as 'Notourbug' without any proper prove... This way gives no benefit to anyone...

And just an advise, please do not interfere without reading and understanding the whole issue. 

Anyway, Joel is right...
Regards,
Zeki
Comment 24 Nicolas Mailhot 2014-05-16 13:00:24 UTC
IIRC that's because GTK/GNOME people decided to override the cross-platform font stack configuration mecanisms and export settings with their own methods.

The GTK layer in libreoffice then reads this configuration and applies it.

You happen to like the GTK font choices. If you run an ubuntu or gnome session it will export them. If you use another DE it will read the normal standard configuration files.

There is no consensus on what is proper font configuration, different people have different preferences, which is why GNOME people decided in their usual way to force their vision on their users and ignore everyone else.

Since you like those choices, you need to dig in GNOME/ubuntu to find where they are carefully hidden away from user control and set the same values in your fonts.conf where non-gnome-descended DEs will read them
Comment 25 Michael Meeks 2014-05-22 15:02:36 UTC
Do you see this Lubos ? :-) [ie. can we mark it NEW].
Comment 26 retired 2014-07-25 08:21:54 UTC
Zeki: has this changed in Ubuntu 14.04? For worse or better and with latest LO 4.3RC3?

This is a complex bug, dev input had been requested a while ago.

@Lubos: where you able to confirm this bug?

I'm putting this to NEEDINFO until we have feedback how this behaves with newer version of both OS and LO. After providing that, please set the bug back to unconfirmed or if Lubos or someone else was able to confirm, then to NEW.
Comment 27 Zeki Bildirici 2014-11-13 20:46:00 UTC
(In reply to foss from comment #26)
> Zeki: has this changed in Ubuntu 14.04? For worse or better and with latest
> LO 4.3RC3?
Hi,

Sorry for the delay, i have been away from KDE due to my old hardware. But now i have a new laptop which i am able to run a recent version of KDE.

I am running Kubuntu 14.10, have LibreOffice 4.3.3.2 Build: 430m0(Build:2) and i can still reproduce the rendering issue.

> This is a complex bug, dev input had been requested a while ago.
> 
> @Lubos: where you able to confirm this bug?
Ping
This bug was noted on ESC minutes on 8 May and 25 July

- http://lists.freedesktop.org/archives/libreoffice-qa/2014-May/007106.html
- http://lists.freedesktop.org/archives/libreoffice-qa/2014-July/007539.html 

> I'm putting this to NEEDINFO until we have feedback how this behaves with
> newer version of both OS and LO. After providing that, please set the bug
> back to unconfirmed or if Lubos or someone else was able to confirm, then to
> NEW.
ı'm settig the but to UNCONFIRMED.

Best regards,
Zeki
Comment 28 Daniel Pastushchak 2014-12-12 18:26:03 UTC
Could not reproduce. I'm using Ubuntu 14.10 with KDE(4.14.1) and LibreOfficeDev Version: 4.5.0.0.alpha0+
Build ID: dad173d9588e6abc2a465198b7d2881d4629246a
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-12-10_22:53:28
Comment 29 Adolfo Jayme 2014-12-12 18:53:28 UTC
(In reply to Nicolas Mailhot from comment #24)
> IIRC that's because GTK/GNOME people decided to override the cross-platform
> font stack configuration mecanisms and export settings with their own
> methods.
> 
> The GTK layer in libreoffice then reads this configuration and applies it.
> 
> You happen to like the GTK font choices. If you run an ubuntu or gnome
> session it will export them. If you use another DE it will read the normal
> standard configuration files.
> 
> There is no consensus on what is proper font configuration, different people
> have different preferences, which is why GNOME people decided in their usual
> way to force their vision on their users and ignore everyone else.
> 
> Since you like those choices, you need to dig in GNOME/ubuntu to find where
> they are carefully hidden away from user control and set the same values in
> your fonts.conf where non-gnome-descended DEs will read them

Nicolas is right. I was trying to say this from the beginning. This is NOTOURBUG, like it or not.
Comment 30 Robinson Tryon (qubit) 2014-12-27 03:53:51 UTC
(In reply to Adolfo Jayme (UX) from comment #29)
> Nicolas is right. I was trying to say this from the beginning. This is
> NOTOURBUG, like it or not.

Okay: updating Status -> NOTOURBUG
Comment 31 Zeki Bildirici 2015-02-19 09:09:26 UTC
Just to note for KDE users this whole report is a very good example of acceptence of the situation again, for years, how hard you push KDE on LibreOffice does not move much...

+1 to KDE native software
-1 to LibreOffice on KDE
Comment 32 Michael Meeks 2015-02-19 10:58:25 UTC
Zeki - it seems you've still not done as Lubos asked:

https://bugs.documentfoundation.org/show_bug.cgi?id=59818#c7

Please keep KDE as your desktop environment, and then rotate through the various plugins as he describes with the env. var - and report the status. Ensure that you:

$ pkill -9 -f soffice.bin

between runs to ensure a clean slate. No doubt things can be improved here - but the improvements are not achieved by complaining (which has only a counter-productive effect), but by careful testing - and also submitting code changes: that is by far the best way to get anything fixed: we love to review & include patches :-)

I guess it would also be ideal to have a (new) clean, brief, readable bug with a single comment, crisp description of the issue, links to the relevant standards, poking at the code to see where these are used etc. [ I believe we use Cairo for text rendering these days ~across the board ].

And of course, finally the diagnosis that the KDE settings are not being propagated to any cairo using app is entirely plausible =)
Comment 33 Adolfo Jayme 2015-02-19 14:31:32 UTC
(In reply to Zeki Bildirici from comment #31)
> Just to note for KDE users this whole report is a very good example of
> acceptence of the situation again, for years, how hard you push KDE on
> LibreOffice does not move much...
> 
> +1 to KDE native software
> -1 to LibreOffice on KDE

The stupidest thing I’ve read in this bug tracker yet.
Comment 34 Zeki Bildirici 2015-08-23 14:27:43 UTC
(In reply to Daniel Pastushchak from comment #28)
> Could not reproduce. I'm using Ubuntu 14.10 with KDE(4.14.1) and
> LibreOfficeDev Version: 4.5.0.0.alpha0+
> Build ID: dad173d9588e6abc2a465198b7d2881d4629246a
> TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time:
> 2014-12-10_22:53:28

Just to note here. 

Still reproducable on Version: 5.0.0.5  Builf NO: 00m0(Build:5) plus same habit on different zoom factors 160 % to  %180 and 220 % to 250 %

Zeki
Comment 35 Zeki Bildirici 2015-10-28 21:34:28 UTC
Created attachment 120064 [details]
Best font rendering setting in KDE settings module

Now with this setting LibreOffice fonts look crystal clear.
Comment 36 Zeki Bildirici 2015-10-28 21:43:21 UTC
Hi,

Finally i've found a workaround for this issue. I've attached the KDE System Settings screenshot.

Just go to Font- Use Anti Allising- Configure -> Change Hinting style to "None".

By this setting the fonts are rendered like native&crystal clear with LibreOffice.

Have a nice day.
Zeki
Comment 37 Adolfo Jayme 2015-10-29 13:27:05 UTC
> By this setting the fonts are rendered like native&crystal clear with
> LibreOffice.

That’s your opinion, of course. Every user out there has different preferences on font rendering style, and the term “crystal-clear” is, obviously, interpreted differently by different people.
Comment 38 Zeki Bildirici 2015-10-30 20:35:38 UTC
Created attachment 120122 [details]
Sample of a clear rendering by this settings.
Comment 39 Zeki Bildirici 2015-10-30 21:00:29 UTC
(In reply to Adolfo Jayme from comment #37)
> That’s your opinion, of course. Every user out there has different
> preferences on font rendering style, and the term “crystal-clear” is,
> obviously, interpreted differently by different people.

I've uploaded a sample screenshot of this settings, it is obviously clear.

If your eyes are healthy -plus have a high dpi monitor- you can determine a clear font rendering.

I wish you had never looked to this bug report and trolled it, never read your name and face with your annoyance. 

Sorry for polluting the bugzilla, but i must admit that such behave makes me alienated from submitting bug reports.
Comment 40 Adolfo Jayme 2015-10-30 21:53:08 UTC
> > That’s your opinion, of course. Every user out there has different
> > preferences on font rendering style, and the term “crystal-clear” is,
> > obviously, interpreted differently by different people.
> 
> I've uploaded a sample screenshot of this settings, it is obviously clear.

Which is a lossy JPEG. So yeah. So clear.

As I stated before, what may be obvious to you it is may not be for everybody else. And what is obvious to me is that you’re unwilling to accept that “clear” rendering is just an adjective with wildly varied meanings based on personal preference. That’s all I have said in this thread.

> If your eyes are healthy -plus have a high dpi monitor- you can determine a
> clear font rendering.

I think I have both of those items. But what I clearly don’t have is your pettiness. I have never insulted you, but this is the Internet – I shouldn’t expect to get reciprocal feedback.

> I wish you had never looked to this bug report and trolled it, never read
> your name and face with your annoyance. 

It’s okay with me.

> Sorry for polluting the bugzilla, but i must admit that such behave makes me
> alienated from submitting bug reports.

It’s also okay with me. Bye.
Comment 41 Robinson Tryon (qubit) 2015-12-18 10:44:01 UTC Comment hidden (obsolete)
Comment 42 Xisco Faulí 2016-09-19 16:48:11 UTC Comment hidden (obsolete)