Bug 59932 - FILEOPEN: Text boxes with bulleted lists containing wrapped text resize when re-opening saved .pptx format
Summary: FILEOPEN: Text boxes with bulleted lists containing wrapped text resize when ...
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-27 14:15 UTC by Dr Mike Brooks
Modified: 2016-03-06 04:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Slide with four text boxes originally in a two-by-two arrangement, now malaligned. (506.62 KB, image/png)
2013-01-27 14:15 UTC, Dr Mike Brooks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dr Mike Brooks 2013-01-27 14:15:46 UTC
Created attachment 73731 [details]
Slide with four text boxes originally in a two-by-two arrangement, now malaligned.

Problem description: 
When saving a LibreOffice Impress file as .pptx for compatibility, text boxes containing bullets are ruined. On reopening the file, any text boxes with wrapped text are shown with their horizontal dimension extended so that there is no longer any wrapped text. The text boxes therefore render with their left border far leftwards from their original position, ruining the slide layout.

Also, the bullets in these text boxes render as an empty square (no known character) instead of their original bullet character.


Steps to reproduce:
1. Open an existing PPTx document created by MS PowerPoint (document renders correctly initally)
2. Add a few slides, and add some text boxes to the slide. Create a bulleted list with enough text in at least one of the lines so that it wraps onto another line.
3. Save the document in .pptx compatibility.
4. Reopen the document and navigate to the slide you created.
5. Marvel at how your corporate presentation has been totally obliterated!
6. Wonder why you ever thought ditching MS Office and embracing FLOSS office packages was a good idea...

Current behavior:
- Text boxes with wrapped text become horizontally enlarged so that no more text wrapping occurs.
- Bullet point characters are forgotten and render as empty squares.


Expected behavior:
- Text boxes retain the size and position that the user told them to be
- Bullet point lists retain the bullet point characters that were selected by the user
- Wrapped lines stay wrapped


              
Operating System: Ubuntu
Version: 3.6.2.2 release
Comment 1 Jorendc 2013-02-10 15:36:40 UTC
Thanks for reporting!

(In reply to comment #0)
> Steps to reproduce:
> 1. Open an existing PPTx document created by MS PowerPoint (document renders
> correctly initally)
Is it possible for you to attach a sample pptx file to reproduce this behavior?

> - Bullet point characters are forgotten and render as empty squares.
This behavior is also reproducible when you just create a simple presentation using LibreOffice Impress and save it as pptx. (tested using Linux Mint 14 x64 with LibreOffice 4.0.0.3 rc3)

Steps:
* Create new presentation
* Type a text 'test' for example
* Click on 'bullets on/off' button to place a button before your text
* Save presentation as pptx
* Reopen
Comment 2 QA Administrators 2015-07-18 17:43:25 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 3 Buovjaga 2015-10-17 13:52:57 UTC
The bullet problem is gone and the other problem never got a test case document.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists and attach the test document. Change to RESOLVED WORKSFORME, if the problem went away.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 186f32f63434e16ff5776251657f902d5808ed3d
TinderBox: Win-x86@39, Branch:master, Time: 2015-10-16_09:42:47
Locale: en-US (fi_FI)
Comment 4 Adolfo Jayme 2016-03-06 04:12:31 UTC
In the absence of a follow-up by the original poster, we shall close this as INSUFFICIENTDATA.