Download it now!
Bug 60106 - EDITING: Position of left quotation mark is not fully left at the margin
Summary: EDITING: Position of left quotation mark is not fully left at the margin
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-31 07:18 UTC by bugquestcontri
Modified: 2013-07-16 12:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Writer file with examples and explanations (15.18 KB, application/vnd.oasis.opendocument.text)
2013-01-31 07:18 UTC, bugquestcontri
Details
Screenhshot does not show problems? (142.50 KB, image/png)
2013-01-31 10:31 UTC, Rainer Bielefeld Retired
Details
screen shot showing locations of q-marks with descripton on how they were created (403.17 KB, image/jpeg)
2013-02-06 09:33 UTC, bugquestcontri
Details
Quotation marks in the first position in a line, page and paragrah - odt (10.29 KB, application/vnd.oasis.opendocument.text)
2013-02-18 00:40 UTC, bugquestcontri
Details
Quotation marks in the first position in a line, page and paragrah - jpg (188.02 KB, image/jpeg)
2013-02-18 00:42 UTC, bugquestcontri
Details
example of wrong displayed font (61.39 KB, application/x-pdf)
2013-02-18 02:14 UTC, bugquestcontri
Details
the file documenting the second part of the findings in above comment - odt (39.46 KB, application/vnd.oasis.opendocument.text)
2013-02-18 03:11 UTC, bugquestcontri
Details
the file documenting the second part of the findings in above comment - pdf (39.46 KB, application/vnd.oasis.opendocument.text)
2013-02-18 03:11 UTC, bugquestcontri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-01-31 07:18:43 UTC
Created attachment 73977 [details]
Writer file with examples and explanations

Problem description: 
When a quotation mark is used as the first character in a line, it's position is not fully left aligned the with the first characters of lines above and below. If the quotation mark is written somewhere in a line and flows over due to adding of text before the quotation mark, the left quotation mark is in correct position.

See also examples in attached file. Various test were made and explained

Steps to reproduce:
1. write a text and end it with a ENTER to create a new line
2. type left quotation mark as the first character in a line
3. result: quotation mark is not left aligned

The same happens when unformated text is pasted and in the pasted text there is a left quotation mark the first character in a line.



Current behavior:
Left quotation mark is not left aligned when typed or copied as first character in a line.

Expected behavior:
Left quotation mark is always fully left aligned when it is the first character in a line
              
I am not sure if this is linked to:
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=57815
Operating System: Windows XP
Version: 3.6.4.3 release
Comment 1 Rainer Bielefeld Retired 2013-01-31 10:31:35 UTC
Created attachment 73986 [details]
Screenhshot does not show problems?

NOT reproducible with "LibO  4.0.0.2 rc   -  GERMAN UI / German Locale  [Build ID: 5991f37846fc3763493029c4958b57282c2597e)]"  {tinderbox: @6, pull time 2013-01-24  07:20(?)} on German WIN7 Home Premium (64bit) with User Profile automatically created form renamed /3 User profile used by 3.6.5.2

@bugquestcontri
We can't know what you see on you PC, of course we need a screenshot

For me position of Quots. at beginning of "“The quotation mark appear to far left ..." seems quite ok.

In general comments like "too far" ar too imprecise. 1cm? 1μm?

Please also contribute concerning other related circumstances:
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Language)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration, Experimental features enabled,
     anti aliasing, ...)
Comment 2 Rainer Bielefeld Retired 2013-01-31 11:06:26 UTC
Also looks fine for me with Server Installation of "LibreOffice 3.6.5.2 rc" German UI/ German Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit)
Comment 3 bugquestcontri 2013-02-06 09:31:28 UTC
I could see from Rainer's screenshot that the Writer file at this PC looks completely different from mine.

I added  a screenshot showing what I am seeing.

Although I upgraded from 3.6.4.3 to Version 3.6.5.2 (Build ID: 5b93205) in the meantime. The problem remains the same.

English US, GUI English, additional languages: Japanese, German, and Dutch

Distance is one character. Now to be seen in screenshot.

OS: XP Prof. English v2002,  Asian language support, SP3

PC video card: I cannot find this information. Please give me hint on where to find it.

LibO experimental features: enabled

Use Anti-Alising: checked

Hardware acceleration: checked


Which other settings do you need? Please advice.
Comment 4 bugquestcontri 2013-02-06 09:33:22 UTC
Created attachment 74280 [details]
screen shot showing locations of q-marks with descripton on how they were created
Comment 5 Rainer Bielefeld Retired 2013-02-06 10:30:05 UTC
(In reply to comment #4)
Thx. for screenshot, I'll have to think about that.
Comment 6 Rainer Bielefeld Retired 2013-02-14 05:29:55 UTC
Until now I do not have any idea concerning the root's of the problem and how to reproduce it.

@bugquestcontri:
Does the problem also appear for a quotation mark as the first character in the first line?
Comment 7 bugquestcontri 2013-02-18 00:40:44 UTC
Created attachment 75012 [details]
Quotation marks in the first position in a line, page and paragrah - odt

yest the quotation mark is 1 character width too far to the right. See 2 attachements 1) odt, 2) screenshot of the same document.

Note: I upgraded to: Version 3.6.5.2 (Build ID: 5b93205)
Comment 8 bugquestcontri 2013-02-18 00:42:07 UTC
Created attachment 75013 [details]
Quotation marks in the first position in a line, page and paragrah - jpg

screen shot as mentioned in comment above
Comment 9 Urmas 2013-02-18 00:55:38 UTC
The problem is caused by a quotation mark being in MS Mincho font.
Still, I cannot reproduce it with LO 4.
Comment 10 bugquestcontri 2013-02-18 02:13:35 UTC
No that you see the MS Mincho font is a different bug. If I recall it correct I reported that bug already a while ago. 
Whenever I type a western font there are a bit problems with the display of the western font. 
I earlier versions I needed to select a few characters to have the used western font displayed. Now I see that in LibO Version 3.6.5.2 (Build ID: 5b93205), the bug only is visible when I type the first paragraph in a new document and after hitting the ENTER button and start a new paragraph and the cursor is positioned at the beginning of the paragraph with out a character typed. However, when entered the first character in the 2nd or another following paragraph the correct western font is displayed. 
The screen shot below shows the Asian default font after I hit the ENTER button and create a new paragraph. But if there is a text with an empty line in between and the cursor is positioned in an empty line, the Asian default font is displayed again, event the entire document is written in a western font.
See attachment.
Comment 11 bugquestcontri 2013-02-18 02:14:49 UTC
Created attachment 75016 [details]
example of wrong displayed font
Comment 12 bugquestcontri 2013-02-18 03:00:13 UTC
Umas, 

you could be possibly be right. After saving my last comment and uploading of the file I recognized the following.

The Mincho font is a double byte character and only indicated when the cursor is in first position of new paragraph. "new" means, no other characters are typed in the paragraph.

 The quotation mark is only wrongly positioned when it is the first character in a paragraph.

I made a test creating a Japanese document and tested the position of the quotation mark. In the Japanese text it is correct at the very left of the new paragraph.

"_ is the correct position in Japanese. I used the underscore to simulate  the  double byte situation of Japanese

However, if I type a western font the position at the beginning of a new paragraph is
_". Thus different from the Japanese positioning. Writer places the quotation mark close to the next western character (=correct) but adds an empty space.

Now I combined my observations and enforced the western font on the empty space and the quotation mark and this solved the problem. Thus we also have a work around.

Please look at attached documents "WorkAround" where I described the details. You might not see the bug in the odt file because you don't have a double byte language installed at your machine . Therefore I add a pdf-file.

I am using LibO Version 3.6.5.2 (Build ID: 5b93205) English US with GUIs and language support for English (default), Japanese, German and Dutch.

Wiindows XP Professional SP3 english and Asian language support. 

I hope this contributes to the solution. If more information is need please let me know.
Comment 13 bugquestcontri 2013-02-18 03:11:01 UTC
Created attachment 75017 [details]
the file documenting the second part of the findings in above comment - odt
Comment 14 bugquestcontri 2013-02-18 03:11:59 UTC
Created attachment 75018 [details]
the file documenting the second part of the findings in above comment  - pdf
Comment 15 Urmas 2013-02-18 08:48:07 UTC
I cannot reproduce it with your document in version 4. Actually I cannot find a way for opening quote at the beginning of the line to be considered a FE character at all.
Comment 16 bugquestcontri 2013-02-18 09:55:09 UTC
Assuming that you run only a LibO version without Japanese, I am not surprised that you cannot reproduce the bug.

It would ne necessary to use a different machine with Japanese, Chinese or Korean fonts and language support installed.

Do you know someone who uses such a system and is willing to make a test?
Comment 17 bugquestcontri 2013-07-13 13:06:05 UTC
I made a new test using 
Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2)
and the bug does not show up anymore.

Thanks to the one(s) who removed it.
Comment 18 Jacques Guilleron 2013-07-16 12:22:08 UTC
In accordance with last comment, I set this report as NOTABUG.

Jacques