Download it now!
Bug 60118 - Calc - Errors in function "Conditional Formatting" in Calc, some formatting to save or modify the file ....
Summary: Calc - Errors in function "Conditional Formatting" in Calc, some formatting t...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2013-01-31 13:26 UTC by Anderson C. Soprana
Modified: 2019-01-14 17:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Archive of sheet integrating with a simple table of the Base (63.73 KB, application/x-rar-compressed)
2013-01-31 13:26 UTC, Anderson C. Soprana
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anderson C. Soprana 2013-01-31 13:26:44 UTC
Created attachment 73993 [details]
Archive of sheet integrating with a simple table of the Base

I developed a spreadsheet in Calc sheet point integrating with a simple table of the Base. This worksheet counts the months and puts the color line steeper alert conditional formatting day regarding Saturday and Sunday. Just having a problem with the system of "conditional formatting" when I create a new worksheet this worksheet subsequent months (a copy) loses the previous conditional formatting ..
Or even when I close the spreadsheet and reopen it back without the conditional formatting.


some formatting to save or modify the file ....
Comment 1 zoe81 2013-06-15 18:11:52 UTC
Ccan confirm this bug. A cell formatted with conditional formatting firstly works properly. After saving and re-opening of the same file the conditional formatting got lost
Comment 2 tommy27 2014-07-01 19:57:47 UTC
zoe81
which version did you test?
Comment 3 mpjdevine 2014-08-15 02:05:29 UTC
I am seeing this bug in Version: 4.3.0.4
Build ID: 430m0(Build:4)
on Ubuntu.

Conditional formatting copied using Paste Special with only Formats selected will appear to work okay. After the file is saved and reopened, the original cell still has the conditional formatting but the copied formatting is gone.
Comment 4 ign_christian 2014-08-15 02:34:33 UTC
Anderson, please take a look Bug 81611. Does it the same case?

@mpjdevine@gmail.com, I guess you talked about Bug 82503. It's happen since 4.3.x
Comment 5 Buovjaga 2014-11-12 09:44:16 UTC
I reproduced -> NEW.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-12_00:19:18
Comment 6 QA Administrators 2015-12-20 16:07:44 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-01-03 19:46:33 UTC Comment hidden (obsolete)
Comment 8 Timur 2019-01-14 12:40:26 UTC
Please test with current LO and also if possible with daily version from https://dev-builds.libreoffice.org/daily/master/.
Comment 9 Buovjaga 2019-01-14 17:45:06 UTC
1. Right-click Janeiro sheet tab - Move or copy sheet
2. Copy it
3. Save and reload

The conditional formatting stays in the copied sheet.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 6e3c4ae8bca898700cde9caaff43c3a8a61eebc2
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 13 January 2019
Comment 10 Buovjaga 2019-01-14 17:46:00 UTC
To check the conditional formatting's existence: Format - Conditional - Manage.