Download it now!
Bug 60123 - UI: Spinning rotation-degree-values should allow crossing 0°
Summary: UI: Spinning rotation-degree-values should allow crossing 0°
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium enhancement
Assignee: Katarina Behrens
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-31 15:27 UTC by Rainer Bielefeld Retired
Modified: 2014-09-28 19:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (9.15 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2013-01-31 15:27 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-01-31 15:27:38 UTC
Created attachment 74000 [details]
Sample Document

Steps how to reproduce [Reproducible] with "LibO  4.0.0.2 rc   -  GERMAN UI / German Locale  [Build ID: 5991f37846fc3763493029c4958b57282c2597e)]"  {tinderbox: @6, pull time 2013-01-24  07:20(?)} on German WIN7 Home Premium (64bit) with User Profile automatically created form renamed /3 User profile used by 3.6.5.2

1. open attached sample.ods
2. click A1
3. Menu 'Format -> Cells -> Alignment - Text orientation
4. in pane 'Degrees' you see "0", spin up / down value using spin buttons or
    arrowup / arrow down
   > 0° is not a frontier, you can do 10° -> 5° -> 0° -> 355° ... and back
5. <Cancel>

12. Rightclick Rectangle
13. Context Menu 'Position and size -> Rotation'
14. in pane 'Degrees' you see "0", spin up / down value using spin buttons or
    arrowup / arrow down
   > 0° IS A FRONTIE a frontier, you can NOT 10° -> 5° -> 0° -> 355° ... and back
     Value can not cross 0°
15. <Cancel>

That should be improved the way as it works for text rotation.
Comment 1 Rainer Bielefeld Retired 2013-01-31 15:28:04 UTC
This one might have impact to "Bug 60120 - UI: object rotation does not allow decimals and negative numbers"
Comment 2 Joel Madero 2013-01-31 16:52:23 UTC
Rainer - doesn't look like I can reproduce this on XP using daily from last night. 

Also can't reproduce on Linux, master pulled a few days ago.

Am I missing something? 

With both the A1 cell and the box I can go back and forth across the 0°. Shape and text rotate as expected.
Comment 3 Rainer Bielefeld Retired 2013-01-31 17:23:58 UTC
Might have changed last night? Or WIN7 related? I doubt.

I will check Linux today with 3.5
Comment 4 Rainer Bielefeld Retired 2013-01-31 21:36:06 UTC
Hm, I'm telling nonsense, of course it's impossible to check a 4.0 Bug with 3.5 ...

And that does not work for me with latest Master build, neither old profile not new one. 

I'll check that on a XP machine tomorrow
Comment 5 Jorendc 2013-02-01 16:22:46 UTC
Thanks Rainer for this -again- wonderful accurate bug report and such clear steps to reproduce. Thank you, thank you, thank you :).

I can reproduce this behavior using Linux Min 14 x64;
* LibreOffice Versie 4.0.0.2 .0.2 (Bouw-id: 408fe71bd18616c467b3dcd7ab6756528ffcae2)
and master build today:
* Version 4.1.0.0.alpha0+ (Build ID: 6c76cdce33d29d25a1023d5363a840ac5972c95)

Therefore I mark this as NEW ... you already did the prioritizing stuff, so nothing to change there :).

Kind regards,
Joren
Comment 6 Commit Notification 2014-09-28 19:12:09 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=559484d5871c7c0a7e771f75916c46f3a6a590ae

fdo#60123: Make rotation angle spinbox wrap



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.