Bug 60137 - Allow exporting charts ("Export as Graphic") also to vector graphics (SVG, PDF,...)
Summary: Allow exporting charts ("Export as Graphic") also to vector graphics (SVG, PD...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard: target:4.1.0
Keywords:
: 59083 64988 65228 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-31 21:50 UTC by Gerry
Modified: 2013-10-24 17:41 UTC (History)
9 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2013-01-31 21:50:50 UTC
LibreOffice 4.0 will have the new feature to export charts as graphic files. However, it does not work with SVG-files. The created SVG graphic file has 0 Bytes size.

How to reproduce:
* Start Calc
* Create any new chart
* Perform a right mouse click on the chart and choose as export filter "SVG -Scalable Vector Graphics" and save it somewhere.
* Look at the created file. It has 0 Bytes file size and is - of course - broken.


System: Ubuntu 12.10, LibreOffice 4.0.rc2
Comment 1 Thomas van der Meulen 2013-02-01 10:35:08 UTC
than you for reporting thus bug
i can reporduce this bug running lo 4.0 rc 2 and rc3 on mac os x 10.6.8
Comment 2 Gerry 2013-02-02 17:27:14 UTC
Added Tomaz to this bug. He added the "Export as Graphic" feature.
Comment 3 Gerry 2013-02-23 20:10:56 UTC
The export as graphic for charts which was newly introduced in LibreOffice 4.0 is a great enhancement, but only supports raster formats such as jpg and png (bug 30944).

Please add vector graphics support when exporting charts.
Comment 4 Tomaz Vajngerl 2013-02-26 10:09:42 UTC
Hi,

In the way it is currently done I did not find a easy way to export a chart as SVG. For release 4.1 I will try to find a way to make it possible using a different solution but I don't think I can do anything other than to disable export to SVG for release 4.0 

Regards, Tomaž
Comment 5 Francisco 2013-03-04 19:01:43 UTC
(In reply to comment #4)
> Hi,
> 
> In the way it is currently done I did not find a easy way to export a chart
> as SVG. For release 4.1 I will try to find a way to make it possible using a
> different solution but I don't think I can do anything other than to disable
> export to SVG for release 4.0 
> 
> Regards, Tomaž

Hi Tomaž.

I understand if it is not an easy task to allow Calc to export charts as SVG, and it isn't already implemented. But in my opinion, if it is not possible, the save dialog should not allow the user to chose formats that are not supported.
Comment 6 sam tygier 2013-04-16 17:30:45 UTC
If this is fundamentally difficult, a high res bitmap option would be useful. the current bitmap output is lower quality than the chart on screen, due to lack of anti-aliasing.
Comment 7 Tomaz Vajngerl 2013-04-16 18:01:53 UTC
Hi,

This problem has been resolved in master (LibreOffice 4.1) with commit [1] and [2]. Exporting as any vector format (including SVG) works now.

Regards, Tomaž

[1] - http://cgit.freedesktop.org/libreoffice/core/commit/?id=4fa8df7320f6bdc8333f5936537d2ed93e8892ce
[2] - http://cgit.freedesktop.org/libreoffice/core/commit/?id=a5e22906c0b27019b61b41161ccc8cbc2cf40ade
Comment 8 Gerry 2013-04-17 16:00:47 UTC
@Tomaz: Thanks, that's excellent news!

I now marked the bug as RESOLVED -> FIXED. I am looking forward to LibreOffice 4.1.
Comment 9 Gerry 2013-04-19 09:03:10 UTC
Added information to the 4.1 release notes: https://wiki.documentfoundation.org/ReleaseNotes/4.1#Chart Please cross-check.
Comment 10 sam tygier 2013-04-19 09:27:27 UTC
Can the non-working option be removed from the Graphics Export save dialog in 4.0? should that be filed as a separate bug?
Comment 11 Gerry 2013-04-19 09:34:41 UTC
@Sam: Is this necessary, since these options will work in version 4.1 ?
Comment 12 sam tygier 2013-04-19 09:42:46 UTC
People will still be using 4.0.x for many months. I think its bad to have an option in the UI that looks like it works, but only outputs a broken (zero byte) file. It means people waste time trying to work out what they did wrong. They might not even realise that the bitmap options do work.
Comment 13 Tomaz Vajngerl 2013-04-19 10:09:19 UTC
Hi,

I could prepare a patch to also make it work in 4.0 but without fix in 4fa8df7320f6bdc8333f5936537d2ed93e8892ce SVG export won't work.

To remove the option out is not trivial. I will try to do something about this. 

Regards, Tomaž
Comment 14 sam tygier 2013-04-19 10:22:59 UTC
Thanks. Yes, i'm happy to wait for 4.1 for the vector export to work, bring large patches to stable releases is risky. Just asking for the non-working options to be hidden in 4.0 (i imagine that this is less work, but maybe i am wrong).
Comment 15 Gerry 2013-04-30 14:53:01 UTC
*** Bug 59083 has been marked as a duplicate of this bug. ***
Comment 16 Jorendc 2013-05-25 22:14:45 UTC
*** Bug 64988 has been marked as a duplicate of this bug. ***
Comment 17 Jorendc 2013-06-01 10:04:46 UTC
*** Bug 65228 has been marked as a duplicate of this bug. ***
Comment 18 Jorendc 2013-06-01 16:09:52 UTC
*** Bug 65228 has been marked as a duplicate of this bug. ***
Comment 19 chtfn 2013-06-01 16:15:03 UTC
I reported the bug about SVG still being an available option in https://bugs.freedesktop.org/show_bug.cgi?id=65228

cheers
Comment 20 Florian Manschwetus 2013-07-13 19:00:13 UTC
*** Bug 59083 has been marked as a duplicate of this bug. ***