Download it now!
Bug 60318 - Impress EDITING: [ppt, pptx] cannot edit diagrams created in MS Office
Summary: Impress EDITING: [ppt, pptx] cannot edit diagrams created in MS Office
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-05 10:59 UTC by Kirill
Modified: 2015-03-28 20:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
pptx file (159.84 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-02-05 10:59 UTC, Kirill
Details
ppt file (1.45 MB, application/vnd.ms-powerpoint)
2013-02-05 11:00 UTC, Kirill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill 2013-02-05 10:59:45 UTC
Created attachment 74233 [details]
pptx file

Tested with LO 3.6.5.2, Windows 7 x64

I have files with diagrams (PPT or PPTX), created in MS Office 2010.

When i try to edit diagrams in this files, it opens like images, not like diagrams.
Comment 1 Kirill 2013-02-05 11:00:44 UTC
Created attachment 74234 [details]
ppt file
Comment 2 Jorendc 2013-02-06 22:33:13 UTC
I can reproduce this behavior using Linux Mint 14 x64 with LibreOffice 4.0.0.3 rc3 with the attached ppt file. But when I save the pptx file as .ppt... I can't reproduce this anymore.
Comment 3 Jorendc 2013-03-04 19:14:49 UTC
(In reply to comment #2)
> But when I save the pptx file as .ppt... I can't reproduce this anymore.

@Bug reporter: can you reproduce that it is fixed when you save the pptx file as ppt?

Kind regards,
Joren
Comment 4 ign_christian 2013-06-04 10:11:07 UTC
I saw different results on LO 4.0.4.1 (Win7 32bit)

- Chart on PPTX attached can be opened as chart
- Chart on PPT attached opened as image
Comment 5 Jorendc 2013-06-04 11:05:13 UTC
(In reply to comment #4)
> - Chart on PPT attached opened as image

So, still valid -> NEW

Thanks!
Comment 6 QA Administrators 2015-03-16 23:09:20 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

    Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
    https://www.libreoffice.org/download/

    If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
  
  If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

    Update the version field
    Reply via email (please reply directly on the bug tracker)
    Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-03-16
Comment 7 Jean-Baptiste Faure 2015-03-28 20:54:17 UTC
Same behavior as in comment #2 with LibreOffice 4.4.3.0.0+ built at home under Ubuntu 14.10 x86-64. I guess that the second attachment (ppt file) is another problem because saving the pptx as ppt gives a working chart.

So closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF