Bug 60349 - FORMATTING: Icon in Calc toolbar - wrap text alignment
Summary: FORMATTING: Icon in Calc toolbar - wrap text alignment
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard: BSA target:4.4.0 target:4.3.5
Keywords:
: 67325 84278 88054 (view as bug list)
Depends on:
Blocks: Calc-Toolbars-Revamp
  Show dependency treegraph
 
Reported: 2013-02-06 04:17 UTC by Ivan Stephen
Modified: 2017-10-22 20:27 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Stephen 2013-02-06 04:17:07 UTC
Problem description:  Why is there no efficient way to do this in one or many cells?  (I frequently need to use the menu, which means three or four steps for something which I should be able to do in one step.)

I am not a programmer, so I lack the ability to do this myself.

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: Mac OS X
Version: 3.6.5.2 release
Comment 1 Emir Sarı (away) 2013-02-07 02:40:15 UTC
I think this is an enhancement request, so changing importance level. 

Also this applies to all OS's, changed the platform as well.
Comment 2 Timur 2013-12-05 09:49:05 UTC
Temporary solution is to use http://extensions.libreoffice.org/extension-center/wrap-unwrap-insert-copied-row-or-column-and-paste-value. 
But the "wrap text" toolbar icon should be added to LO ASAP.
Comment 3 Timur 2014-10-20 11:44:05 UTC
Seems like there's still no Wrap Text icon in LO 4.3.
Comment 4 Yousuf Philips (jay) (retired) 2014-10-28 22:06:04 UTC
Well the easiest workaround is to click the checkbox in the sidebar. :D

I couldnt find an .uno command for this, so its not a simple process of just adding it to the menu.
Comment 5 Maxim Monastirsky 2014-10-28 22:45:40 UTC
(In reply to Jay Philips from comment #4)
> Well the easiest workaround is to click the checkbox in the sidebar. :D
> 
> I couldnt find an .uno command for this, so its not a simple process of just
> adding it to the menu.
Is this about the "Wrap text" checkbox from the Alignment panel? In that case the command is .uno:WrapText, and it can be found in the customization dialog under the Format category with the title "Automatic Row Break". Unfortunately it has no icon.
Comment 6 Yousuf Philips (jay) (retired) 2014-10-29 07:03:21 UTC
(In reply to Maxim Monastirsky from comment #5)
> Is this about the "Wrap text" checkbox from the Alignment panel? In that
> case the command is .uno:WrapText, and it can be found in the customization
> dialog under the Format category with the title "Automatic Row Break".
> Unfortunately it has no icon.

Well that was my assumption from the bug description. So do you think we should rename the title as i was searching through all the categories looking for 'Wrap' and didnt find anything that i thought resembled it. I'll start working on an icon.

Any suggestions on where in the toolbar the button should be placed?
Comment 7 Maxim Monastirsky 2014-10-29 08:57:49 UTC
(In reply to Jay Philips from comment #6)
> So do you think we
> should rename the title as i was searching through all the categories
> looking for 'Wrap' and didnt find anything that i thought resembled it.
Yes, this probably would be a good idea.
Comment 8 Timur 2014-10-29 09:55:33 UTC
> Well that was my assumption from the bug description. So do you think we
> should rename the title as i was searching through all the categories
> looking for 'Wrap' and didnt find anything that i thought resembled it. I'll
> start working on an icon.
> 
> Any suggestions on where in the toolbar the button should be placed?

I renamed to "FORMATTING: Icon in Calc toolbar -  wrap text alignment".

I think the button should be in the alignment part of Formatting toolbar, right from Merge and Center Cells.
Comment 9 Yousuf Philips (jay) (retired) 2014-10-29 11:20:08 UTC
(In reply to Timur from comment #8)
> I think the button should be in the alignment part of Formatting toolbar,
> right from Merge and Center Cells.

I thought so as well after seeing it in Excel. :D
Comment 10 Timur 2014-10-29 14:26:27 UTC
I hope it will be done, and backported to LO 4.3.
Comment 11 Yousuf Philips (jay) (retired) 2014-10-29 21:27:12 UTC
(In reply to Timur from comment #10)
> I hope it will be done, and backported to LO 4.3.

Doubt it can be backported as there is a UI freeze.
Comment 12 Maxim Monastirsky 2014-10-29 21:36:54 UTC
(In reply to Timur from comment #10)
> I hope it will be done, and backported to LO 4.3.
I wonder why do you need anything backported to 4.3, when you can add it yourself to the toolbar? (right click->Customize Toolbar...->Add->Format->Automatic Row Break)
Comment 13 Yousuf Philips (jay) (retired) 2014-10-30 03:08:51 UTC
I did some initial work on an icon, using the icon metaphor from other office suites, and here is the result. ( https://redmine.documentfoundation.org/attachments/download/341/text%20wrap.png )
Comment 14 Maxim Monastirsky 2014-10-30 08:28:47 UTC
(In reply to Jay Philips from comment #13)
> I did some initial work on an icon, using the icon metaphor from other
> office suites, and here is the result. (
> https://redmine.documentfoundation.org/attachments/download/341/text%20wrap.
> png )
Looks good!
Comment 15 Yousuf Philips (jay) (retired) 2014-10-31 12:11:36 UTC
Patch sent - https://gerrit.libreoffice.org/#/c/12163/1
Comment 16 Commit Notification 2014-11-01 14:24:10 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=80f49553518e6d344dae81358b8d7fb5f24c3cf1

fdo#60349 - FORMATTING: Icon in Calc toolbar for wrap text

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Kevin Suo 2014-11-03 00:59:19 UTC
*** Bug 84278 has been marked as a duplicate of this bug. ***
Comment 18 Kevin Suo 2014-11-03 01:48:00 UTC
*** Bug 67325 has been marked as a duplicate of this bug. ***
Comment 19 Timur 2014-11-03 10:43:17 UTC
Very nice. 

(In reply to Maxim Monastirsky from comment #12)
> (In reply to Timur from comment #10)
> > I hope it will be done, and backported to LO 4.3.
> I wonder why do you need anything backported to 4.3, when you can add it
> yourself to the toolbar? (right click->Customize
> Toolbar...->Add->Format->Automatic Row Break)

Well, I didn't know about it. I only looked for "Wrap". 
But finally for 4.3 it's not about me, because I used the wrap extensions (meaning I solved it somehow), but about majority of others who don't customize the toolbar. 
And I'm still on 4.2, so it'll take long before I go to 4.4, and probably many users. Although I understand if that can't be done.
Comment 20 Yousuf Philips (jay) (retired) 2014-11-03 13:42:12 UTC
How about for 4.3, we backport the icon and add a hidden entry in the formatting toolbar to enable it. What do you think Maxim?
Comment 21 Maxim Monastirsky 2014-11-03 21:55:16 UTC
(In reply to Jay Philips from comment #20)
> How about for 4.3, we backport the icon and add a hidden entry in the
> formatting toolbar to enable it. What do you think Maxim?
Not sure, the rules of the UI freeze aren't clear to me. But keep in mind that there is also a string freeze, so the title change could be also problematic.
Comment 22 Yousuf Philips (jay) (retired) 2014-11-03 22:18:41 UTC
(In reply to Maxim Monastirsky from comment #21)
> Not sure, the rules of the UI freeze aren't clear to me. But keep in mind
> that there is also a string freeze, so the title change could be also
> problematic.

Yes i wasnt planning to change the string as the icon should tell it all. ;D

Any idea who is should get approval about this from?
Comment 23 Yousuf Philips (jay) (retired) 2014-11-04 14:47:37 UTC
Okay it has been backported as hidden in the toolbar, so users can easily enable it if they want and the label was left as is. https://gerrit.libreoffice.org/12254
Comment 24 sophie 2014-11-04 16:21:57 UTC
Hi, as said on IRC, even if the string freeze rule can be broken for few strings to be added, it should always be worth the work it will create (extract the strings, update Pootle tremplate, translate in x languages, commit the changes, etc). So we do that when it's really mandatory to fix an issue or a feature. I don't think it's the case here :) Sophie
Comment 25 Yousuf Philips (jay) (retired) 2014-11-12 22:25:58 UTC
So the 4.3 patch is in and will be in the next release. :D
Comment 26 Timur 2014-12-21 17:56:02 UTC
In 4.3.5 I can see the icon in the toolbar (not visible by default), but it's still "Automatic Row Break" instead of "Wrap text" as it's named in sidebar?
Comment 27 Yousuf Philips (jay) (retired) 2014-12-21 18:52:01 UTC
Unfortunately changing the name of the button doesnt outweigh the extra work by others that would need to go into it.
Comment 28 Maxim Monastirsky 2015-07-07 16:12:45 UTC
*** Bug 88054 has been marked as a duplicate of this bug. ***