Bug Hunting Session
Bug 60460 - [EDITING] Entering double quote doesn't cause the text language to change
Summary: [EDITING] Entering double quote doesn't cause the text language to change
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2013-02-08 03:27 UTC by Andrew Panin
Modified: 2018-10-21 20:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
A screenshot (5.03 KB, image/png)
2013-02-08 03:27 UTC, Andrew Panin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Panin 2013-02-08 03:27:15 UTC
Created attachment 74397 [details]
A screenshot

Many times I've encountered a situation in which LibreOffice Writer suggests a wrong sort of double quotes.

Here's how it works now. I'm typing in Russian:
...телефоны Huawei “залочены»...

You may see that the opening double quote is different from the closing. This is because when I had typed in Huawei, the Writer was thinking I'm writing in English, and for that language it has chosen the '“'. When I had written the word in Russian, the Writer determined Russian language and suggested the '»'.

HOW IT MIGHT WORK. Basically, the sort of double quotes must be chosen based on the language in which the enclosed word is written, NOT on the language the preceding word is written.

Therefore: let it function as it is now until the user puts a closing quote. After that, determine the language of the quoted word(s), go back to the beginning and fix the opening quote.
Comment 1 Florian Reisinger 2013-04-21 15:17:23 UTC
Plese specify version (and ple4ase test with LibO 4)
Comment 2 Urmas 2013-04-21 16:07:06 UTC
This is a bug, as all the other characters entered in Russian layout cause the language to change; only double quote doesn't.
Comment 3 QA Administrators 2015-03-04 02:22:03 UTC Comment hidden (obsolete)
Comment 4 Roman Kuznetsov 2015-03-27 08:36:43 UTC
bug is reproduced in LO 4.4.2.1
Comment 5 tommy27 2016-04-16 07:23:35 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-05-22 13:23:47 UTC Comment hidden (obsolete)
Comment 7 Thomas Lendo 2018-10-21 20:32:56 UTC
Can't reproduce anymore.

Version: 6.2.0.0.alpha0+
Build ID: 3846561f79cf9065abd9ca83c9fbfbe7e52e28e2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: threaded
from today

Closing as RESOLVED WORKSFORME.

If this still occurs in your installation, please reopen as NEW.