Download it now!
Bug 60551 - Pasting text removes bullet
Summary: Pasting text removes bullet
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 50260 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-09 17:20 UTC by Clemens Eisserer
Modified: 2015-03-15 16:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
demo file (231.45 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-02-09 17:20 UTC, Clemens Eisserer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2013-02-09 17:20:55 UTC
Created attachment 74496 [details]
demo file

When pasting text into a bullet-list, the line which gets the text pasted in, looses it's bullet.

Steps required to reproduce:
- Open the attached example presentation
- Navigate cursor to the bullet list
- Press enter to start a new line
- The new line has a bullet on the left
- Copy&Paste some text into that line -> Bullet is removed. Even pressing the "Bullets On/Off"-toolbar button does not restore the bullet.
Comment 1 Clemens Eisserer 2013-02-09 17:25:47 UTC
I've created a screencast which illustrates the issue using the attached testcase: http://youtu.be/5Y2m8HZKDrg

As shown in the video, strange things happen when pressing the "Bullets On/Off" toolbar button.
Comment 2 Jorendc 2013-02-10 15:32:58 UTC
Thanks for reporting!
I can reproduce this behavior using your attached file using Linux Mint 14 x64 and Libreoffice 4.0.0.3 rc3.
There is something quite wrong with the bullets lists when exporting/importing to LibreOffice (Impress). 
The bullets aren't 'filled' anymore (it's now a strange non-filled rectangle). But this behavior is already mentioned/filed in Bug 59932.

Kind regards,
Joren
Comment 3 Clemens Eisserer 2013-02-10 19:57:34 UTC
Hi Joren,

Please also take a look at the linked screencast. Some strange things happend there - I was lucky it was captured.

Thanks
Comment 4 Cao Cuong Ngo 2013-04-12 09:17:36 UTC
*** Bug 50260 has been marked as a duplicate of this bug. ***
Comment 5 QA Administrators 2015-03-04 02:22:32 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 6 Jean-Baptiste Faure 2015-03-15 16:49:44 UTC
Not a bug for me. The copied text is pasted with its style. If you want to keep the bullet you only have to paste the text without formatting. Use ctrl+maj+V instead of ctrl+V.

Closing as NotABug. Please, feel free to reopen if you disagree.

Best regards. JBF