Bug Hunting Session
Bug 60577 - "Use English function names" - 100 function names are still not in English
Summary: "Use English function names" - 100 function names are still not in English
Status: RESOLVED DUPLICATE of bug 50118
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-10 11:19 UTC by Mirosław Zalewski
Modified: 2014-07-09 15:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
List of functions not translated to English (19.58 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-02-10 11:19 UTC, Mirosław Zalewski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mirosław Zalewski 2013-02-10 11:19:06 UTC
Created attachment 74526 [details]
List of functions not translated to English

Calc can use English function names in otherwise localized environment. Unfortunately, after checking this option, exactly 100 function names still appear in localized language instead of English. Please see attached spreadsheet for excessive list. It seems that they all appear in files that are in scaddins directory in Pootle, which may help narrow down the issue.

Expected output:
After checking "Use English function names", all function names should be in English.

I could reproduce this on:
- LO 3.5.6 on Arch Linux (i386)
- LO 3.6.5 on Debian GNU/Linux (amd64)
- LO 4.0.0 on Windows 7 (i386)

One user pointed out that this bug was introduced in 3.5.6; 3.5.5 and earlier worked as expected, which would classify this issue as regression. I did not check if this is really a case.

I have checked only Polish version of LO. Don't know if this appears in other languages and to what avail.

This might be seen as duplicate of:
- #32686 - I could reproduce this problem on other OSes, so this is not Ubuntu-specific bug.
- #50118 - I don't know if this is matter of LO's core or add-in; it does appear on standard installation of LO (without any third-party extensions) and users perceive it as a bug, so I strongly believe it is a bug.

Feel free to reopen one of above and mark this issue as duplicate.

Best regards,
Mirosław Zalewski
Comment 1 Mateusz 2013-02-10 11:57:21 UTC
The same bug occur in 4.0.1.0+ (Build ID: aade07de7b404d1254e2135de751c3af4a05e1)
TinderBox: Linux-x86_10-Release-Configuration, Branch:libreoffice-4-0, Time: 2013-02-07_18:18:32
Comment 2 Mateusz 2013-06-28 17:18:13 UTC
Bug still exist in 4.1 daily build. Some functions are in English back, some new functions are in Polish (earlier weren't). Si it's a toss-up.
Comment 3 Markus Mohrhard 2013-07-03 02:52:25 UTC
As long as we have no hard data this is not a regression.

If you find a release where this worked correctly please add it back with detailed information about the version. I'd be surprised if 3.5.5 would work when 3.5.6 would not work anymore.

the regression keyword with a release that does not work is a hint for us developers to notify that it worked at some point and limit the range of commits that might have introduced it.
Comment 4 Mateusz 2013-07-03 07:15:58 UTC
(In reply to comment #3)
> As long as we have no hard data this is not a regression.
> 
> If you find a release where this worked correctly please add it back with
> detailed information about the version. I'd be surprised if 3.5.5 would work
> when 3.5.6 would not work anymore.

Thank for your clue! I checked LO 3.5.5 and it works perfectly there! :-)

LibreOffice 3.5.5.3 
Build ID: 7122e39-92ed229-498d286-15e43b4-d70da21

Download link:
http://download-euro.oldapps.com/LibreOffice/LibO_3.5.5rc3_Win_x86_install_multi.msi
Comment 5 Gerry 2014-01-20 18:13:20 UTC
Isn't this bug a duplicate of bug 50118?
Comment 6 Mateusz 2014-01-20 18:59:59 UTC
No. None of bugs mentoined above are not fixed yet.

I tested it on LO 4.2 RC2 (Build ID: 601a398b803303d1a40a3299729531824fe0db56)
Comment 7 Eike Rathke 2014-01-21 00:28:45 UTC
This IS a duplicate of bug 50118.

*** This bug has been marked as a duplicate of bug 50118 ***
Comment 8 Mateusz 2014-01-23 08:27:17 UTC
(In reply to comment #7)
> This IS a duplicate of bug 50118.
> 
> *** This bug has been marked as a duplicate of bug 50118 ***

Function wizard still contain Polish formula names with English "_ADD" suffix. There is no way to find it in Pootle. 

After setting "Use English formula names", user must restart program. In earlier version of LO it was unnecessary.
Comment 9 Konrad 2014-01-26 13:35:46 UTC
LO 4.2 RC3 still is not fixed.

We have formula CZY.NIEPARZYSTA_ADD but the proper name for this string is CZY.NIEPARZYSTA.DODATKOWE. String is translated correctly, but program display it in wrong way.

Proof:
https://translations.documentfoundation.org/pl/libo_help/translate.html#search=isodd_add&sfields=source,target
Comment 10 Winfried Donkers (retired) 2014-07-09 15:33:36 UTC
Translations have been fixed, at least with version 4.2.5.
Function name tips are partly fixed with 4.2 and will be fully fixed with version 4.3.

After setting 'Use English Function Names' it is neccessary to restart LibreOffice in order to get English function names for add-in functions.

*** This bug has been marked as a duplicate of bug 50118 ***