Download it now!
Bug 60663 - Adapt hyphenation dialog to HIG
Summary: Adapt hyphenation dialog to HIG
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Honza Minarik
URL:
Whiteboard: target:4.1.0
Keywords: difficultyInteresting, easyHack, skillHIG, topicUI
Depends on:
Blocks:
 
Reported: 2013-02-11 13:31 UTC by Caolán McNamara
Modified: 2015-12-15 16:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Changed grid bottom padding,dialog spacing and help button name in hyphenate.ui (1.67 KB, patch)
2013-03-15 16:02 UTC, Honza Minarik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Caolán McNamara 2013-02-11 13:31:51 UTC
i.e. cui/uiconfig/ui/hyphenate.ui

writer: tools->language->hyphenation

See https://wiki.documentfoundation.org/Development/WidgetLayout#Widgets_requiring_HIG_guidelines_review for details
Comment 2 Honza Minarik 2013-03-14 00:15:41 UTC
Hi,

I will try to solve this, if I can ;)
Comment 3 Caolán McNamara 2013-03-14 12:21:54 UTC
great, its even possible that the hyphenation dialog is HIG-clean already, which is a good result too. Its to review it to see if it fails any of the requirements.
Comment 4 Honza Minarik 2013-03-15 16:02:09 UTC
Created attachment 76568 [details]
Changed grid bottom padding,dialog spacing and help button name in hyphenate.ui

I replaced grid bottom padding with dialog spacing to be more consistent with other dialogs. Changed name of help button to "help" for better readability, other files shouldn't be affected. Now it seems it is HIG-clean. But there is still remaining FIXME about HyphenEdit...
Comment 5 Caolán McNamara 2013-04-03 10:18:40 UTC
looks good so...

a) could you add yourself to https://wiki.documentfoundation.org/Development/Developers (send a mail like the examples, e.g. http://lists.freedesktop.org/archives/libreoffice/2012-December/043153.html) to libreoffice@lists.freedesktop.org and then link to the archive
b) what's the "fixme" for HyphenEdit ? If glade isn't showing a proper widget there then we now have a new glade catalog in master (how to use it is shown after you do a make dev-install) which provides glade with enough info as how to show a better preview
Comment 6 Commit Notification 2013-04-03 13:35:04 UTC
Honza Minarik committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2409c4b291f720a1c607bd0dfdf5986f396a045c

Resolves: fdo#60663: Adapt hyphenation dialog to HIG



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Honza Minarik 2013-04-03 20:03:26 UTC
Hi again! :)

a) Done (I forgot write Subject to mail with licence statement, I'm very sorry for this :( )

b) Yes, you're right. Glade wasn't able to show proper widget, but everything works as intended
Comment 8 Robinson Tryon (qubit) 2015-12-15 16:51:51 UTC
Migrating Whiteboard tags to Keywords: (EasyHack TopicUI DifficultyInteresting SkillHIG )
[NinjaEdit]