Bug Hunting Session
Bug 60755 - Display formula in cell instead of value of result after editing formula (may show ###) , undedited cells not affected
Summary: Display formula in cell instead of value of result after editing formula (ma...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: (target:4.0.2)
Keywords:
: 61316 63174 63176 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-12 22:58 UTC by Larry Johnson
Modified: 2013-06-05 07:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
WinXP.LO4.Calc not Calculating (105.15 KB, image/gif)
2013-03-15 15:38 UTC, Centenium
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Johnson 2013-02-12 22:58:00 UTC
A well used calc spread sheet created in a version prior to 3.6.5.2 returns as display in cell the text of the formula whenever the formula has been edited, and not the value of the formula calculation. Unedited formulas still return values (until edited).

Menu:Tools→Options⇒Options(Popup)⇝LibreOff Calc⇝View:Display:Formula Box is unchecked. Toggling this has no effect, except that text of formulas are displayed for all formulas when the box is checked.

Re-entering formula even using formula wizard has no effect.

The calc sheet has multiple sheets and cross sheet references.
Comment 1 Larry Johnson 2013-02-22 23:33:48 UTC
Same bug in 4.0.0.3 https://www.libreoffice.org/bugzilla/show_bug.cgi?id=61316
Comment 2 Markus Mohrhard 2013-02-23 03:17:39 UTC
*** Bug 61316 has been marked as a duplicate of this bug. ***
Comment 3 Larry Johnson 2013-02-28 19:11:35 UTC
This bug does not occur in Windows version
Comment 4 Larry Johnson 2013-02-28 19:12:53 UTC
Please see attached worksheet in https://bugs.freedesktop.org/show_bug.cgi?id=61316
Comment 5 Larry Johnson 2013-02-28 19:14:25 UTC
Please consider increasing severity of this bug.  It essentially makes Linux version unusabe.
Comment 6 Centenium 2013-03-15 15:38:32 UTC
Created attachment 76564 [details]
WinXP.LO4.Calc not Calculating

This is a screenshot of this bug also happening on Windows XP with LO 4.0.1.2.
Comment 7 Rainer Bielefeld Retired 2013-04-11 04:21:20 UTC
*** Bug 63174 has been marked as a duplicate of this bug. ***
Comment 8 Rainer Bielefeld Retired 2013-04-11 04:22:25 UTC
*** Bug 63176 has been marked as a duplicate of this bug. ***
Comment 9 Rainer Bielefeld Retired 2013-04-11 04:26:49 UTC
This seems to be an aspect of the "Not all user settings imported" problems with 3.6 -> 4.0 updates?
Comment 10 Larry Johnson 2013-04-11 19:23:01 UTC
This bug has been resolved (no longer occurs) in the latest version.
Comment 11 Rainer Bielefeld Retired 2013-04-11 20:55:08 UTC
So WFM for now

@Larry Johnson:
Please feel free to reopen this bug if you find out that the problem still exists with the current stable LibreOffice version and if you can contribute requested additional information
Comment 12 Cor Nouws 2013-06-05 07:23:26 UTC
*** Bug 65390 has been marked as a duplicate of this bug. ***