Bug 60773 - [regression] FORMATTING: date format fields are not formatted automatically
Summary: [regression] FORMATTING: date format fields are not formatted automatically
Status: CLOSED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.1 rc
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-13 09:05 UTC by Hugo Hirsch
Modified: 2015-02-19 15:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hugo Hirsch 2013-02-13 09:05:34 UTC
If you enter values into date formatted columns no autoformat happens. Thus you have to enter a fully qualified date, although in recent versions either a day or a day-month-combination was reformatted to be either a day of the current month or a day-month of the current year.

This saved lots of typing in bigger lists with date values /e.g. for accounting/.

It is a regression in 3.6.5 and 4.0Release seen on Ubuntu and MacOS X.

How to reproduce:
* open a new spreadsheet
* format one column to be a date YYYY-mm-dd
* enter the following values to verify:
- 13. - no reformatting happens
- 13.2 - no reformatting happens
- 13.2.2013 - is formatted to YYYY-mm-dd

* if you enter these values and apply cell formatting afterwards the first two inputs are not formatted into date values

Expected behaviour:
In versions prior to 3.6.5 and 4.0Release a date was automatically formatted if entered in a spreadsheet, thus
- 13. => current month, e.g. 2013-02-13
- 13.2 => reformatted to a valid date: 2013-02-13
- 13.2.2013 => reformatted to a valid date: 2013-02-13

This bug is very annoying if you enter many values in lists because you have to type much more to have an appropriately formatted input for date values.
Comment 1 m.a.riosv 2013-02-13 23:26:26 UTC
Hi Hugo, thanks for reporting.

Please take a look to this article.
http://erack.org/blog/archives/archives/8-LibreOffice-date-acceptance-patterns.html

The new option is in Menu/Tools/Options/Languages&settings/Language/Date acceptance patterns.
Comment 2 Hugo Hirsch 2013-02-15 20:29:56 UTC
Thanks for the feedback - I can confirm that there are date patterns available in version 4.0.0.4. release on mac. This seems to solve the problem with the current 4.x trunk.

Version 3.6.0.1 (Build ID: 360m1 (Build: 101)) does not have this menu but contains the regression to not accept date values.
Comment 3 Hugo Hirsch 2013-02-15 22:07:25 UTC
After I saw the thing working on Mac I tried the manual installation on my Ubuntu box.

Although I do see the date pattern in my Options dialog, the date input is not formatted properly. A two element date is interpreted as text and remains left-bound and unformatted after hitting enter.

Installed version is: Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Comment 4 Buovjaga 2014-11-05 06:28:28 UTC
(In reply to Hugo Hirsch from comment #0)
> Expected behaviour:
> In versions prior to 3.6.5 and 4.0Release a date was automatically formatted
> if entered in a spreadsheet, thus
> - 13. => current month, e.g. 2013-02-13
> - 13.2 => reformatted to a valid date: 2013-02-13
> - 13.2.2013 => reformatted to a valid date: 2013-02-13

If I have as Date acceptance pattern:
D.M.Y;D.M.;D.M;D.

Your examples work.

I need you to test on Ubuntu. If it works, set the status as RESOLVED WORKSFORME.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: ad6d94009cf8ea526eb70bf1a07e5c6a21320f83
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-04_00:06:27
Comment 5 Eike Rathke 2015-02-19 15:58:44 UTC
Apparently you work in a German locale, for which the default date acceptance patterns are
D.M.Y;D.M.
so you have to enter dates as 13.2.2013 or 13.2. (note the trailing dot) unless you extend or change the patterns. This works as requested many times.