Download it now!
Bug 60914 - Number FORMATTING not changed in all cells of selection
Summary: Number FORMATTING not changed in all cells of selection
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-15 17:22 UTC by Rainer Bielefeld Retired
Modified: 2015-03-22 14:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-02-15 17:22:30 UTC
I found this problem during my research for "Bug 56045 - Data-Labels- and Axis-Number-FORMATTING needs Complete Recalculation for update" with parallel Dev-installation of  "Version 4.1.0.0.alpha0+ (Build ID: 2b9394f0c009b385756a0c5d75e3c1cd412f723) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-02-14_00:13:52" ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with LODev/4 Masters User Profile: Steps how to reproduce:

1. Open  Attachment 54073 [details] Details for Bug 43467
2. Select B2:B5 with dragged mouse button
3. Click 'Currency' Icon in Formatting Toolbar
   Expected: all cells change to "Currency"
   Actual: only B2 changes to currency

The problem might be related to use of cell values in chart:
10. Close without changes -> reopen
11.  Select B2:B5 with dragged mouse button
12. <control+c> for copy
13. Click B25
14. Paste with <control+v>
    > Values look identical to source cells
15. Proceed 1 ... 3
    > Now all cells are currency, works fine

Has noting to do with anything special in cells B2:B5 (except chart relation, of course):

21. Copy+Paste B25:B28 to B2:B5
    > All cells with currency
22. Proceed Steps 1-3
    Bug appears again, only B2 loses Currency

<control+shift+f9> will heal the incomplete formatting change in all cases

Was ok with 3.6.5

I will do further research where that started if desired.
Comment 1 Rainer Bielefeld Retired 2013-02-15 18:38:01 UTC
Already [Reproducible] with 
---------------------------
* parallel Dev. Installation of "LODev  4.0.1.0+   -  English UI / German Locale  [Build ID: 693217465486667d38c3b7cd6d654136fe1efc8)]"  {tinderbox: @6, pull time  2013-02-03 09:04:55} on German WIN7 Home Premium (64bit) with newly created user profile ….\LODev\401\
* Server Installation of "LibO  4.0.0.3   -  GERMAN UI / German Locale  [Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)]"  {tinderbox: @6, pull time 2013-01-31 11:30(?)} on German WIN7 Home Premium (64bit) with separate  new User Profile    


Still was ok with 
------------------
* Server Installation 4.0.0.1 2013-01-15
* server  installation of  "LOdev  4.0.0.0.beta2+   -  ENGLISH UI / German Locale  [Build ID: 6738ae52bd075dc6478dedfeddc60d1c25cffcb)]"  {tinderbox: Win-x86@6, pull time 2013-01-04 23:41:48} on German WIN7 Home Premium (64bit) with own separate User Profile
* Server-installation of Master " 3.7.0.0.alpha0+  – ENGLISH UI [Build ID: f2e622]" {tinderbox: Win-x86@16, pull time 2012-10-06 09:31:39} on German WIN7 Home Premium (64bit) UserInstallation=$SYSUSERCONFIG/LOdev/3
* server-installation of Master "3.7.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: b255de8]" (tinderbox: Win-x86@6-fast, pull time 2012-06-05 23:16:58)

NEW because observed in independent versions
Comment 2 GerardF 2013-02-15 20:38:57 UTC
Not reproducible with Version 4.1.0.0.alpha0+ (Build ID: b7aa16fe0da53001e056ad347ac5e1085537636)
TinderBox: Win-x86@6, Branch:master, Time: 2013-01-17_01:46:38

nor 4.0.0.3
Comment 3 Rainer Bielefeld Retired 2013-03-02 08:31:27 UTC
I can no longer reproduce the problem with sample document of original report.

But for me the problem still exists in Attachment 74880 [details] for Bug 56045:

30. Download sample document
31. open sample document from LibO Start Center
32. Select B2:B5 using mouse
33. Click 'Currency' icon in Formatting Toolbar
    Expected: all cells switch to currency
    Actual: only B2 becomes currency
Comment 4 Muthu 2013-04-29 09:04:53 UTC
This problem seems to be with 'refresh'.
The format change actually happens but not displayed (because the cell doesn't seem to be refreshed).

E.g. after formatting cells - move to another sheet and return back.
(or edit the cell content with the same value).
Comment 5 QA Administrators 2015-03-04 02:21:10 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 6 Buovjaga 2015-03-22 14:02:27 UTC
(In reply to Rainer Bielefeld Retired from comment #3)
> I can no longer reproduce the problem with sample document of original
> report.
> 
> But for me the problem still exists in Attachment 74880 [details] for Bug
> 56045:
> 
> 30. Download sample document
> 31. open sample document from LibO Start Center
> 32. Select B2:B5 using mouse
> 33. Click 'Currency' icon in Formatting Toolbar
>     Expected: all cells switch to currency
>     Actual: only B2 becomes currency

No problem for me -> WFM.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI