Download it now!
Bug 60994 - Export PDF: Enabling "Embed OpenDocument file" will disallow exporting selective page(s)
Summary: Export PDF: Enabling "Embed OpenDocument file" will disallow exporting select...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other All
: high minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-17 10:44 UTC by Jiero
Modified: 2015-03-24 05:31 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiero 2013-02-17 10:44:46 UTC
Problem description: 



Current behavior:
PDF export function do not allow selective page export.

Expected behavior:
PDF export allow user to select pages to export.
              
Operating System: All
Version: 4.1.0.0.alpha0+ Master
Comment 1 Rainer Bielefeld Retired 2013-02-17 12:10:29 UTC
I haven't a clue what reporter is talking about

@Jiero 
Please be more precise! What's your problem?
a) You can not select a particular page you want to export
b) You can not export selection on page, always whole page will be
   exported.
Comment 2 Jiero 2013-02-17 15:30:52 UTC
Sorry, I missed an important step.

Check "Embed OpenDocument file Makes this PDF easily editable in LibreOffice"
Comment 3 Daniel L 2013-05-21 09:46:56 UTC
Reproduce steps:
 1. File > Export to PDF
 2. Initial View tab > Page layout > select Single page
 3. Export

Result: A PDF with the expected content inside but the page layout is "Default"
Expected result: A PDF with the expected content on a "single page"

Tested on: Windows 7 x64 and MacOS

Note: As I remember, this bug does not appear in 4.0.1.2
Comment 4 ign_christian 2013-06-18 14:00:30 UTC
> Check "Embed OpenDocument file Makes this PDF easily editable in LibreOffice"
Doing that makes 'Range' part on the left side greyed out so we can't select page(s).

@Daniel, 
I think your steps is a different problem. Perhaps you should open new bug report & attach your sample. Anyway I can't reproduce, choosing Default nor Single page doesn't make any difference.

Confirmed with LO 4.0.4.2 (Win7 32bit)
Comment 5 ign_christian 2013-06-18 14:18:07 UTC
Sorry I forgot the steps:
1. Menu File: Export as PDF
2. Check mark 'Embed OpenDocument file' under "General" on the right side
3. See that all selection under "Range" on the left side greyed out

+Modify Summary to fit reporter's description
Comment 6 QA Administrators 2015-03-16 23:22:26 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

    Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
    https://www.libreoffice.org/download/

    If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
  
  If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

    Update the version field
    Reply via email (please reply directly on the bug tracker)
    Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-03-16
Comment 7 Jean-Baptiste Faure 2015-03-24 05:31:38 UTC
It is clearly by design. It has been judged inconsistent to embed the entire document in odt format and to export only a part of the same document in pdf.
If you first choose under "Range" the pages you want to be exported then check "Hybrid PDF (embed ODF file)", the range goes back to All before to be grayed.

Embedding the ODF file means that when you open the hybrid pdf in LibreOffice, it opens the ODF file instead importing the pdf. It would be inconsistent to have different behaviors when you open the same pdf in your favorite pdf viewer and in LibreOffice.

Closing as NotABug.

Best regards. JBF