Bug 61083 - Underlines are not imported from EMF
Summary: Underlines are not imported from EMF
Status: RESOLVED DUPLICATE of bug 31814
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2013-02-18 20:23 UTC by Gergő Mocsi
Modified: 2017-05-09 01:47 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Original EMF file (69.92 KB, application/emf)
2013-02-18 20:23 UTC, Gergő Mocsi
Details
Imported to Writer, saved as PDF (56.85 KB, application/pdf)
2013-02-18 20:24 UTC, Gergő Mocsi
Details
Version: 5.3.0.0.alpha0+ (92.49 KB, image/png)
2016-10-09 18:58 UTC, Xisco Faulí
Details
Version: 5.3.0.0.alpha0+ (Windows 7) (118.33 KB, image/png)
2016-10-10 10:44 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gergő Mocsi 2013-02-18 20:23:35 UTC
Created attachment 75071 [details]
Original EMF file

The user says that when importing an emf file (image -> insert), the underline disappears in the values with accents (in this case, Hungarian words, as you can see in the m.emf file) He/she also says that this feature was working in version 3.6.
Comment 1 Gergő Mocsi 2013-02-18 20:24:50 UTC
Created attachment 75072 [details]
Imported to Writer, saved as PDF
Comment 2 Andras Timar 2013-02-18 20:37:49 UTC
In fact, all underlines are missing. Only a small artifact is there (start of the underline?).
Comment 3 Michael Stahl (CIB) 2013-02-19 14:10:56 UTC
for me underlines are a little thinner on master than on 3.6
but they're still there.

Writer doesn't render EMFs so reassigning to graphics stack.
Comment 4 Matthew Francis 2014-12-29 15:07:04 UTC
Adding Cc: to chris.sherlock79@gmail.com

Chris, here's another EMF one for you. This could be bibisected/bisected if it would help at all? If not, I'll skip it.

(Rendering of the text in this file looks completely borked on OSX in a way unrelated to underlines, but not on Linux. Must be an OSX specific font rendering issue - I think there's a similar bug open somewhere)
Comment 5 Robinson Tryon (qubit) 2015-03-05 18:26:52 UTC
(In reply to Matthew Francis from comment #4)
> This could be bibisected/bisected if
> it would help at all? If not, I'll skip it.

Good question. Seems valid for bibisect, so tossing on the stack for now.
Devs: If irrelevant, please change to bibisectNotNeeded
Whiteboard -> bibisectRequest
Comment 6 Robinson Tryon (qubit) 2015-12-14 05:32:42 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2016-10-08 18:05:14 UTC
I can no longer reproduce the underlines problem in

Version: 5.3.0.0.alpha0+
Build ID: ae3ec79354f7b4967e736c6a4cd7c08fc52e2b7d
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

thus, closing it as RESOLVED WORKSFORME
Comment 8 Aron Budea 2016-10-09 17:40:11 UTC
Still there for me in 5.2.2.2 and master build / Windows 7.
Comment 9 Xisco Faulí 2016-10-09 18:58:04 UTC
Created attachment 127900 [details]
Version: 5.3.0.0.alpha0+

Hi Aron,
I'm sorry but I can't see the problem.
This is how the image looks for me when I insert it in 

Version: 5.3.0.0.alpha0+
Build ID: ae3ec79354f7b4967e736c6a4cd7c08fc52e2b7d
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 10 Aron Budea 2016-10-10 10:44:25 UTC
Created attachment 127918 [details]
Version: 5.3.0.0.alpha0+ (Windows 7)

Might be Windows only now?
Comment 11 Bartosz 2017-05-09 01:47:46 UTC
The issue was resolved with commit:
https://gerrit.libreoffice.org/#/c/37319/

CLosed as duplicate.

*** This bug has been marked as a duplicate of bug 31814 ***