Download it now!
Bug 61154 - EDITING: Table of Content (ToC) doesn't cross mark deleted text with Track changes Shown
Summary: EDITING: Table of Content (ToC) doesn't cross mark deleted text with Track ch...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:7.2.0 target:7.1.0.0.beta2
Keywords:
: 88817 (view as bug list)
Depends on:
Blocks: TableofContents-Indexes
  Show dependency treegraph
 
Reported: 2013-02-20 05:46 UTC by Nitin
Modified: 2021-01-05 12:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
An example of how the ToC wrongly displays deleted contents (11.43 KB, application/vnd.oasis.opendocument.text)
2013-02-20 05:46 UTC, Nitin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nitin 2013-02-20 05:46:42 UTC
Created attachment 75154 [details]
An example of how the ToC wrongly displays deleted contents

With Edit->Changes->On, if I delete text from a heading, LibreOffice produces a ToC that contains that deleted text. I have attached an example. 
Operating System: Debian
Version: 3.5.7.2 release
Comment 1 Brenda Granados 2013-02-26 17:28:28 UTC
I have confirmed this issue using LibreOffice 4.0.1.0+ on Ubuntu 12.04. The steps I followed to reproduce:

1. Go to Edit -> Changes ... enable Show.
2. Edit some of the text in the heading. Changes are visible.
3. Currently, the ToC shows none of the changes, and you can click on the old ToC listing and go to the recently changed entry in the document.
4. Right click ToC, and select Update...

Result: ToC shows the heading with even text that is deleted. This does not occur if Show is not enabled under Edit -> Changes. Sounds like it's just copying the text from the line as visible...
Comment 2 QA Administrators 2015-02-19 15:47:40 UTC Comment hidden (obsolete)
Comment 3 Jean-Baptiste Faure 2015-02-25 05:49:55 UTC
For me, the bug is not that the ToC shows the deleted text (you asked for that with track changes), it is that the ToC does not show the deleted text the same way as in the heading (that is as deleted text).

Best regards. JBF
Comment 4 A (Andy) 2015-04-04 19:40:46 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 5 tommy27 2016-04-16 07:28:51 UTC Comment hidden (obsolete)
Comment 6 Jean-Baptiste Faure 2016-05-01 08:53:37 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-05-22 13:40:41 UTC Comment hidden (obsolete)
Comment 8 Jean-Baptiste Faure 2017-07-24 11:41:50 UTC Comment hidden (obsolete)
Comment 9 Timur 2018-07-18 11:23:50 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2019-07-19 02:53:51 UTC Comment hidden (obsolete)
Comment 11 Jean-Baptiste Faure 2019-08-10 17:17:53 UTC
Still reproducible with LO 6.3.1.0+ and current master both built at home under Ubuntu 18.04 x86-64.

Comment #3 still valid.

Best regards. JBF
Comment 12 Timur 2019-11-24 12:05:23 UTC
Still here 6.5+. Inherited. I change the title per Comment 3.
Comment 13 Timur 2020-08-02 08:33:57 UTC
*** Bug 88817 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2020-12-04 09:16:01 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/daf2a7d957c829c551754871a3545495c0f76bc0

tdf#61154 sw Table of Contents: remove tracked deletion

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-12-04 10:07:22 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/d0a1179d2ee9de52bcad864cc19af76c46917817

tdf#61154 sw Table of Contents: remove tracked deletion

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 NISZ LibreOffice Team 2021-01-05 12:48:20 UTC
Verifed in: 

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 96bafa464ebdbce3ef04bec9beae5e745bb37794
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded